Jump to content
marla

Ancora Buffer.api...

Recommended Posts

ciao a tutti

ho un annoso problema che

è già stato segnalato qualcosa di molto simile in precedenza ma voglio essere più specifico:

cosa bisogna impostare nel buffer.api per renderizzare un'animazione di camera? perchè solo il primo fotogramma corrisponde alle prove nella preview di maya mentre tutti gli altri divengono via via sempre più luminosi?

cosa sbaglio?

c'è qualcuno che ha riscontrato lo stesso problema?

Share this post


Link to post
Share on other sites

Non ho mai provato a renderizzare un' animazione usando anche il ctrl_buffer, quindi non sono sicuro che funzioni, però hai provato ad utilizzare il buffer_write al posto del buffer_api ?

Francesca ha scritto diverse volte che il buffer_api (che funziona come un lens_shader) andrebbe usato solo come "preview" e che poi i sett andrebbero trasferiti sul buffer_write ( che funziona come output shader). La cosa era riferita soprattutto alla possibilità di avere il tonemapping non solo sul render_buffer ma anche sugli altri framebuffer, ma magari può risolvere anche il tuo problema.

Ciao :hello:

Share this post


Link to post
Share on other sites

grazie mille della risposta Talama e della delucidazione, ho provato come dici tu a trasferire tutti i valori sul buffer write e tutto fuziona correttamente nel senso che tutti i fotogrammi sono equilibrati ed hanno lo stesso livello di illuminazione, però cavolo i valori a quanto pare non corripondono: cè un enorme differenza tra buffer.api e buffer.write a livello di luminanza, bruciature ecc... provo a fare delle prove a 16 bit

Share this post


Link to post
Share on other sites

ho fatto mille prove ma niente

solo una cosa ho notato: sembra che sia un po tutto degammato, la soluzione migliore l'ho ottenuta mettendo un nodo gamma (solito 2.2) sul lens shader della camera in aggiunta al buffer_write: il livello di illuminazione sembra ripreso ma i colori sballano parecchio.

non riesco a credere che non ci sia soluzione... :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...