Vai al contenuto
nicola r

Rendering In Video Post

Recommended Posts

salve, sto renderizzando un'animazione con video post ma non riesco a renderizzare l'effetto lens effects flare

ho già fatta questa animazione, qualche tempo fa e mi era venuta, ma ore no

cosa devo fare? grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ciao, ti incollo il procedimento utilizzato dal sottoscritto per gli effetti col videopost...non parlo del lens flare ma puoi cmq usare i passaggi per realizzare tutti i differenti effetti:

clik col tasto destro sull'oggetto al quale vuoi assegnare l'effetto X col VP (video post) e scegli proprietà...in basso a destra, nella sezione G-Buffer, assegni un numero all'Object ID...un numero non a caso perchè se hai altri oggetti nella scena ai quali darai altri effetti il numero sarà identificavo per quell'oggetto; diciamo che assegni 1, poi vai su Rendering (nella barra dei menù) e scegli Video Post...si apre una finestra dove andrai a mettere una successione di eventi:

1) clikka sul pesciolino azzurro e scegli la camera o la vista che il VP userà poi per renderizzarti la scena con l'effetto desiderato (dagli anche una etichetta così ti regoli meglio);

2) clikka sul tastino "Add Image Filter Event" e nel menù a tendina scegli il tuo effetto e poi clicca su Setup;

3) Setup: controlla che la voce "Object ID" sia impostato su 1 (il numero messo nella sezione G-Buffer nella finestra proprietà dell'oggetto a cui vogliamo dare l'effetto) e clikka su Preview...non succederà nulla eheheh clikka su OK...torni alla finestra Video Post dove troverai la successione degli eventi che stiamo dando all'oggetto..fai il doppio clik sull'icona del tuo effetto che troverai nella parte sinistra sotto l'evento camera creato in primis...

4) ti troverai di nuovo nelle proprietà dell'effetto, clikka di nuovo su Setup e magicamente oltre Preview troverai altri due bottoni selezionabili e cioè Update e VP Queue cioè la coda degli effetti del Video Post clicca su quest'ultimo pulsante e attendi...Max farà un piccolo render della scena e ti mostrerà l'effetto coi parametri dell'effetto X di default...ti basta andare sulla scheda "Preferences" e giocare con i vari paramentri...fatto ciò premi OK

5)se vuoi fare il rendering con le impostazioni che hai scelto di v-ray (o altri motori) puoi farlo direttamente o dicendo al VP dove e in che formato salvare l'immagine o filmato, questi i due metodi:

A ) clicca sull'omino che corre nel pannello del VP e scegli Single se vuoi il render in un singolo fotogramma o Range se vuoi fare un filmatino scegliendo "da-->a", l'Output size per le dimensioni dell'immagine ed il resto che credo tu lo conosca eheheh

B ) se vuoi dire al VP come e dove deve memorizzare il rendering o filmato devi aggiungere un altro evento e cioè devi cliccare sull'icona del "Add Image Output Event" e poi su File...anche questo pannello ti sarà familiare eheheh

se vuoi cambiare le impostazioni del rendering puoi fare il doppio clik sull'iconcina della camera nella parte sinistra del VP e da li scegliere "Render Options"

una cosa importante...SOLO lanciando il rendering dal VP otterrai gli effetti inseriti...se lo lanci dal bottone classico con la teiera di Max gli effetti non verranno inseriti nella scena

Spero ti possa essere utile :rolleyes:

cià :hello:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
ciao, ti incollo il procedimento utilizzato dal sottoscritto per gli effetti col videopost...non parlo del lens flare ma puoi cmq usare i passaggi per realizzare tutti i differenti effetti:

clik col tasto destro sull'oggetto al quale vuoi assegnare l'effetto X col VP (video post) e scegli proprietà...in basso a destra, nella sezione G-Buffer, assegni un numero all'Object ID...un numero non a caso perchè se hai altri oggetti nella scena ai quali darai altri effetti il numero sarà identificavo per quell'oggetto; diciamo che assegni 1, poi vai su Rendering (nella barra dei menù) e scegli Video Post...si apre una finestra dove andrai a mettere una successione di eventi:

1) clikka sul pesciolino azzurro e scegli la camera o la vista che il VP userà poi per renderizzarti la scena con l'effetto desiderato (dagli anche una etichetta così ti regoli meglio);

2) clikka sul tastino "Add Image Filter Event" e nel menù a tendina scegli il tuo effetto e poi clicca su Setup;

3) Setup: controlla che la voce "Object ID" sia impostato su 1 (il numero messo nella sezione G-Buffer nella finestra proprietà dell'oggetto a cui vogliamo dare l'effetto) e clikka su Preview...non succederà nulla eheheh clikka su OK...torni alla finestra Video Post dove troverai la successione degli eventi che stiamo dando all'oggetto..fai il doppio clik sull'icona del tuo effetto che troverai nella parte sinistra sotto l'evento camera creato in primis...

4) ti troverai di nuovo nelle proprietà dell'effetto, clikka di nuovo su Setup e magicamente oltre Preview troverai altri due bottoni selezionabili e cioè Update e VP Queue cioè la coda degli effetti del Video Post clicca su quest'ultimo pulsante e attendi...Max farà un piccolo render della scena e ti mostrerà l'effetto coi parametri dell'effetto X di default...ti basta andare sulla scheda "Preferences" e giocare con i vari paramentri...fatto ciò premi OK

5)se vuoi fare il rendering con le impostazioni che hai scelto di v-ray (o altri motori) puoi farlo direttamente o dicendo al VP dove e in che formato salvare l'immagine o filmato, questi i due metodi:

A ) clicca sull'omino che corre nel pannello del VP e scegli Single se vuoi il render in un singolo fotogramma o Range se vuoi fare un filmatino scegliendo "da-->a", l'Output size per le dimensioni dell'immagine ed il resto che credo tu lo conosca eheheh

B ) se vuoi dire al VP come e dove deve memorizzare il rendering o filmato devi aggiungere un altro evento e cioè devi cliccare sull'icona del "Add Image Output Event" e poi su File...anche questo pannello ti sarà familiare eheheh

se vuoi cambiare le impostazioni del rendering puoi fare il doppio clik sull'iconcina della camera nella parte sinistra del VP e da li scegliere "Render Options"

una cosa importante...SOLO lanciando il rendering dal VP otterrai gli effetti inseriti...se lo lanci dal bottone classico con la teiera di Max gli effetti non verranno inseriti nella scena

Spero ti possa essere utile :rolleyes:

cià :hello:

grazie per l'esauriente risposta ma non riesco l'unica cosa che non facevo era quella dell'ID perchè quell' effetto bisogna associarlo a un oggetto per il resto è quello che facevo bo !!!!!

ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
l'unica cosa che non facevi era proprio la più importante :lol:

cià :hello:

ma l'ID non c'è nel set up dell'effetto e poi quello che mi sto chiedendo è perchè lo vedo mentre fa il rendering ma poi sul file che mi salva si vede solo l'oggetto e non l'effetto del video post

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

chiedo scusa...il procedimento per il Lens Flare in VP non contempla effettivamente l'utilizzo degli ID ma l'assegnazione dell'effetto ad un oggetto della scena, ti posto due screenshot:

screen00vo3.th.jpg

come vedi ho creato una sfera dietro il cubo (da rendere trasperente nelle sue proprietà così in fase di rendering non si vedrà) poi...

screen01dq7.th.jpg

...nel setup del Lens Flare ho cliccato su "Node Sources" e nell'elenco degli oggetti presenti nella scena ho selezionato la sfera"...come vedi l'effetto appare correttamente nel rendering

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
chiedo scusa...il procedimento per il Lens Flare in VP non contempla effettivamente l'utilizzo degli ID ma l'assegnazione dell'effetto ad un oggetto della scena, ti posto due screenshot:

screen00vo3.th.jpg

come vedi ho creato una sfera dietro il cubo (da rendere trasperente nelle sue proprietà così in fase di rendering non si vedrà) poi...

screen01dq7.th.jpg

...nel setup del Lens Flare ho cliccato su "Node Sources" e nell'elenco degli oggetti presenti nella scena ho selezionato la sfera"...come vedi l'effetto appare correttamente nel rendering

sono riuscitooooooooooooooo!!!!!!!!!!!!!!

grazie di tutto cippiboy

il problema era come assegnavo gli effetti e l'ordine rispetto al rendering

in pratica prima ho assegnato gli effetti e poi sono entrato nel setup

bo così mi è venuto

ciao e tante grazie spero di darti una mano in qualche cosa

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×