Vai al contenuto
Ospite

Ram Ed Errore Di Sistema

Recommended Posts

Ospite   
Ospite

Salve,

Vorrei raccontare in poche righe la mia esperienza, dai risvolti drammatici, vissuta a causa di un banco di ram. Premetto che in materia di hardware (e non solo) ho un'ignoranza colossale.

Tutto ha originato dall'opinione, peraltro infondata, ma suffragata da altri ignoranti, che avrei innalzato le prestazioni del PC nei processi di 3D Studio Max aggiungendo 1Gb di ram al giga di cui già disponevo. Falso: perché Max usa solo la ram che gli serve, com'è esaustivamente spiegato in molte discussioni di treddi da gente che sa, e al massimo ne userebbe 1.5 Gb, salvo apportare modifiche in boot.ini (con relativa certezza di successo nel risultato delle modifiche), com'è illustrato in un thread di treddi.

Ebbene, io ho aggiunto un banco da 1024 Mb ai due banchi della stessa marca da 512 Mb che avevo (fabbricati e installati un anno e mezzo prima), e dopo due giorni di apparente stabilità (un solo riavvio inspiegabile), è scoppiato l'inferno. Il Pc si riavviava in continuazione (a causa del check di default nelle opzioni di ripristino), così da impedirmi di entrare anche in modalià provvisoria.

Unica soluzione: rimuovere il banco di ram. Per essere sicuri di non patire questi inconvenienti acquistate soltanto banchi di memoria gemelli, non basta della stessa marca, e neanche della stessa capacità, e se volete aggiungere ram, consiglio caldamente di cambiarla tutta. Io sono ritornato al mio giga, e per il momento, visto quelle quattro cose che so fare, mi accontento di questo.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Nemmeno io sono 1 esperto hardware, tutt'altro, però l'implementazione della ram a mio vedere non e' tanto rischiosa come l'hai descritta tu. A me e' capitato in alcune occasioni di aggiungere banki, anche di diversa capacità, e non ho avuto alcun problema, come mi è capitato di prendere ram gemelle come dici tu ed avere 1 sacco di noie.

Molto dipende dalla qualità della ram stessa, da eventuali problemi di montaggio (ammesso che ci possano essere con della ram, ma a me e' capitato pure quello :P) e dalla fortuna...un banko fallato può capitare a tutti. Inoltre c'e' da considerare 1 altro aspetto: sicuro che la tua scheda madre supporti 2 giga? Xche' alcune chede datate ad esempio non li riescono a gestire.

Con questo ovviamente non voglio dire che non sia meglio prendere banki gemelli, che senz'altro vengono sfruttati meglio avendo le stesse caratteristiche, ma solo che non e' dogmatica la tua esperienza ^_^


Modificato da JJ McTiss

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite

@ JJ Mc Tiss

sicuro che la tua scheda madre supporti 2 giga?

Credo di sì. Possiedo una seppur modesta e datata ASRock 939S56-M con n. 4 slot DDR. Il libretto delle istruzioni dice max 4GB, ma forse è relativo. Di sicuro ti posso dire che il sistema leggeva 2048 MB.

Non escludo che, nel mio caso, il banco di memoria incriminato sia fallato, ma dopo il panico che ho vissuto con quest'esperienza (fino ad allora era andato sempre tutto liscio), non mi sentirei di fare un altro tentativo, dato che a giudicare anche dalle discussioni di treddi, non sono il primo che ha avuto problemi montando ram spaiate e diverse. Ciò non toglie che fare le cose fatte per bene sia sempre una garanzia, come dici tu, e nemmeno che possa filare tutto liscio quando non si osservano le "regole". Sono d'accordo che un po' di fortuna ci vorrebbe sempre, ed io non ne ho avuta neanche un po'.

Escludo invece di averla montata nello slot in modo errato. Infatti, è fisicamente impossibile. Il pettine può entrare solo se combacia con la sede dello slot, altrimenti i fermagli non scattano.

Per quanto riguarda infine l'intento del mio post, non ho nessuna pretesa di fare passare la mia esperienza per dogmatica, quanto piuttosto proporla come suggerimento per risparmiarsi panico e tachicardia, o soltanto seccanti inconvenienti.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Credo di sì. Possiedo una seppur modesta e datata ASRock 939S56-M con n. 4 slot DDR. Il libretto delle istruzioni dice max 4GB, ma forse è relativo. Di sicuro ti posso dire che il sistema leggeva 2048 MB.

E' stata la prima idea che mi e' venuta, poichè avevi accennato essere completamente digiuno di hw

Non escludo che, nel mio caso, il banco di memoria incriminato sia fallato, ma dopo il panico che ho vissuto con quest'esperienza (fino ad allora era andato sempre tutto liscio), non mi sentirei di fare un altro tentativo, dato che a giudicare anche dalle discussioni di treddi, non sono il primo che ha avuto problemi montando ram spaiate e diverse. Ciò non toglie che fare le cose fatte per bene sia sempre una garanzia, come dici tu, e nemmeno che possa filare tutto liscio quando non si osservano le "regole". Sono d'accordo che un po' di fortuna ci vorrebbe sempre, ed io non ne ho avuta neanche un po'.

Purtroppo capita (ed a me e' successo diverse volte :crying: ) che ti vendano direttamente 1 banco fallato e la cosa fa girare parecchio le @@ <_< x questo accennavo anche alla componente fortuna... Cmq ti do ragione sul fatto che sicuramente la cosa migliore e' prendere la ram accoppiata, purtroppo però non sempre e' possibile farlo, x una questione economica :blush:

Escludo invece di averla montata nello slot in modo errato. Infatti, è fisicamente impossibile. Il pettine può entrare solo se combacia con la sede dello slot, altrimenti i fermagli non scattano.

Non dubitavo, ma l'ho detto xche' a me una volta e' successo (non chiedetemi come ho fatto :P), quindi non si sa mai!

Per quanto riguarda infine l'intento del mio post, non ho nessuna pretesa di fare passare la mia esperienza per dogmatica, quanto piuttosto proporla come suggerimento per risparmiarsi panico e tachicardia, o soltanto seccanti inconvenienti.

Circa l'ultimo punto, la mia non voleva essere una critica e spero tu non l'abbia presa come tale, semplicemente ho ripostato la mia esperienza personale, spero non te la sia presa ^_^


Modificato da JJ McTiss

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Non sono un esperto di mobo, ma è anche possibile che se la tua è dual channel (anche se hai scritto che è un pò datata) è più che normale che, se avevi installato due banchi da 512, e tu gli vai a montare un altro banco da 1GB, succeda un patatrac.

Se non è dual channel il discorso è diverso e probabilmente è solo un problema di compatibilità delle ram fra di loro, o con la mobo.


Modificato da fabergambis

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite
spero non te la sia presa

E perché mai? Invece, giova sempre ascoltare esperienze diverse.

Ciao

G.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Non sono un esperto di mobo, ma è anche possibile che se la tua è dual channel (anche se hai scritto che è un pò datata) è più che normale che, se avevi installato due banchi da 512, e tu gli vai a montare un altro banco da 1GB, succeda un patatrac.

Se non è dual channel il discorso è diverso e probabilmente è solo un problema di compatibilità delle ram fra di loro, o con la mobo.

In teoria, che supporti il dual o meno la mobo, se installi 1 banco diverso perdi il dual channel, ma nulla di +, nessun patatrac. Circa il discorso della compatibilità effettivamente potrebbe essere benissimo.

E perché mai? Invece, giova sempre ascoltare esperienze diverse.

Ciao

G.

^_^

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

1 confermo febergambis che dice che essendo la mainboard con supporto dual channel qual'ora si và ad inserire un terzo banco di ram si vada a scombussolare il tutto. prova ad installare il terzo banco da 1 giga previa disattivazione del dual channel dal bios, dovrebbe funzionare così...

viene detto anche nel manuale della mainboard ch epuoi trovare a questo indirizzo:

http://www.asrock.com/manual/939S56-M.pdf


Modificato da Mark83

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite

@fabergambis

@mark83

se la tua è dual channel (anche se hai scritto che è un pò datata) è più che normale che, se avevi installato due banchi da 512, e tu gli vai a montare un altro banco da 1GB, succeda un patatrac.
viene detto anche nel manuale della mainboard
.

Ed infatti, la mia (vecchia di un anno e mezzo) scheda supporta la tecnologia dual channel memory. Il manuale dice: "per la configurazione a due canali è necessario installare sempre coppie identiche (stessa marca, velocità, dimensioni e tipo di chip) di DIMM DDR negli alloggiamenti dello stesso colore." Più chiaro di così! Solo che io non l'avevo letto, ed avevo escluso a priori di possedere una dual channel (sì, avevo sentito di questo problema prima di comprarla). Chiarificato e risolto il mistero, grazie fabergambis per la pulce nell'orecchio.

Rimane tuttavia una questione: con il mio processore che va ad 1.8 Mhz, e che non intendo overloccare, quanto mi possono essere utili 2 Gb di ram (considerata anche l'ampia disponibilità di memoria virtuale) in termini di velocità nei rendering di Max? Ho letto molte discussioni sull'argomento, ma ancora non ho capito granché. Le voci sono molteplici e discordanti.

In pratica, Max quando ha esaurito 1Gb (e con quel che faccio io, hai voglia) va a cercare altra ram, e se non la trova fa lo swap con la memoria virtuale. La differenza tra le due possibilità sta solo nella maggiore velocità di scambio offerta dalla ram, vero? Non è la stessa cosa se mi accontento del mio giga, allora?

@mark83

previa disattivazione del dual channel dal bios

Mi sai spiegare che vantaggi apporta il dual channel? È vero che possiedo 1Gb di ram, ma non voglio farlo entrare a tutti i costi, specie se a quanto pare non mi serve granché.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite

Dopo avere letto Wikipedia mi è sorto un altro dubbio: installando un altro giga (512 + 512) nel secondo canale, vado ad aumentare la velocità di elaborazione? In teoria sì, per via che non si verificano colli di bottiglia, ossia la CPU pesca un po' dal primo e un po' dal secondo canale. Confermate o smentite?

Se è vero che la CPU viaggia sempre a 1.8 Mhz, e quindi non ci si devono attendere miracoli, è vero anche, forse, che col dual channel essa dovrebbe evitare di rimanere inattiva, perché riceve sempre un po' di ram in pasto. O no?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Dopo avere letto Wikipedia mi è sorto un altro dubbio: installando un altro giga (512 + 512) nel secondo canale, vado ad aumentare la velocità di elaborazione? In teoria sì, per via che non si verificano colli di bottiglia, ossia la CPU pesca un po' dal primo e un po' dal secondo canale. Confermate o smentite?

Se è vero che la CPU viaggia sempre a 1.8 Mhz, e quindi non ci si devono attendere miracoli, è vero anche, forse, che col dual channel essa dovrebbe evitare di rimanere inattiva, perché riceve sempre un po' di ram in pasto. O no?

mmm allora premetto che lo trovo un pò difficile da spiegare ad una persona a digiuno di hardware però ci provo...

praticamente non è proprio la velocità di elaborazione che fai aumentare (infatti tale processo cel'ha il PROCESSORE e non la ram) ma quello che aumenta è il trasferimento dei dati trà la cpu e la ram, e quindi di conseguenza diminuiscono i tempi di attesa (un pò come quando si diminuisce la cas latency dal bios, ma è meglio non divagare sennò non ne usciamo più :rolleyes: )

e facendo fluire meglio i dati da e verso la cpu,per quanto riguarda la frase "non si verificano colli di bottiglia, ossia la CPU pesca un po' dal primo e un po' dal secondo canale." non mi sembra proprio che sia così, perchè la ram all'inizio dell'accensione del pc è vuota e và via via riempiendosi non casualmente ma dipende dalla grandezza dei programmi da mettere in ram, quindi diciamo che la ram si riempie quasi incrementalmente 8parlando a livello di indirizzi fisici), perciò posso dire che non si verifica che unpò prende da un canale e un pò da un altro anche perchè non funziona come il raid in striping... non sò se mi sono spiegato....

mentre questa frase"Se è vero che la CPU viaggia sempre a 1.8 Mhz, e quindi non ci si devono attendere miracoli, è vero anche, forse, che col dual channel essa dovrebbe evitare di rimanere inattiva, perché riceve sempre un po' di ram in pasto" non l'ho capita per niente....

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×