Jump to content
Nekaris

Problema Ombra In Trasparenza

Recommended Posts

Salve a tutti, ho un problema, volevo generare un'ombra partendo da un oggetto con una texture "bucata" da canale alfa o trasparency che sia...

il risultato porta però un difetto... questo maledetto alone d'ombra a forma del poligono (rettangolare).

Qualcuno mi sa dire come si toglie?

Allego file con immagine...

post-31053-1170077828_thumb.jpg

Share this post


Link to post
Share on other sites

controlla che il bianco della texture (ovvero il colore che assegna valore 100 all'attributo trasparenza del materiale) sia un bianco al 100% e non una tonalità anche chiarissima di grigio, se già lo è puoi provare con un procedimento un pò più complicato che ho visto funzionare bene con le displacement, praticamente vai nell'hypershade e fai questo collegamento utilizzando il connection editor:

outalpha della texture --> input (x) *multyplier/divide* output (x)---> trasparency del materiale

Una volta fatto apri l'attribute editor del multy/divide, dovresti vedere la casella input1 X colorata d giallo, vuol dire che la connessione funziona, ora vai nella casellina input2 X, il valore che assegnerai sarà il fattore di moltiplicazione dei dati che riceve in ingresso il multy/divide, prova ad andare di 10 in 10, teoricamente lui aumenta il contrasto della tua texture e dovrebbe sparire quell'alone...

Non sono espertissimo a riguardo, magari il tuo problema stà da un'altra parte ma a naso mi sembra un difetto della texture...

Share this post


Link to post
Share on other sites

non posso perchè sono in ufficio e maya è sul mio pc mentre internet su unla'ltro pc neanche in rete, ma ti ho trovato il link del tutorial che spiega il procedimento per le displacement map, prova ad applicarlo con la tua texture tanto cambia solo che invece di un cheker in ingresso c'è la tua texture :)

http://67.15.36.49/team/Tutorials/controll..._displace01.asp

tutto tuo!

Share this post


Link to post
Share on other sites

Invece di scervellarvi con tutto quel bordello.... basta che andate nel materiale usato ed alla tendina raytrace options mettere a 0 lo shadow attenuation e vedrai che l'alone del piano se ne andrà via.... ;)

Share this post


Link to post
Share on other sites
Ah però sei di cosenza?... sei la 2-3 persona che incontro su sto forum che sia di cosenza... mi sento meno solo qua dentro :D perchè un giorno non ti fai un giro nel chan di treddi?

Cominciano ad esserci un pò troppi cuzentini ^_^:P:hello:

Share this post


Link to post
Share on other sites
Invece di scervellarvi con tutto quel bordello.... basta che andate nel materiale usato ed alla tendina raytrace options mettere a 0 lo shadow attenuation e vedrai che l'alone del piano se ne andrà via.... ;)

:crying:

purtroppo non mi ero mai trovato ad usare le mappe per la trasparenza ma solo per bump e disp, buono a sapersi!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...