Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
jonny1

Texture Che Non Rendono

Recommended Posts

Ciao a tutti!

Mi sta succedendo una cosa strana, ho ripreso in mano un vecchio progetto fatto con vray (quando non lo sapevo minimamente usare), per vedere come verrebbe fuori adesso alla luce delle varie cose che ho imparato da allora.

Diciamo che sostanzialmente è migliorato tutto di molto, soprattutto l'illuminazione, le ombre, la mappatura e la qualità delle texture, ma una cosa inspiegabilmente è nettamente peggiorata.

In poche parole, prima se facevo una vista d'assieme dell'edificio, riuscivo a vedere bene le texture lontane, senza che si appiattissero e che perdessero profondità, adesso invece se vado vicino le medesime texture sono ottime, realistiche, danno il senso di profondità e sono soddisfatto, non appena mi allontano, tutto si appiattisce e quasi non si percepisce neanche che c'è una texture, sembra un colore e basta.

In buona sostanza da vicino è molto realistico e credibile, da lontano fa schifo..

Prima era tutto molto peggio, però non c'era questa differenza...

Non riesco a capire il motivo, a qualcuno è mai successa una cosa del genere?

Da cosa potrebbe dipendere???

Grazie a tutti!

Ciao

Jonny

Share this post


Link to post
Share on other sites

Si che si riferisse a quello avevo capito, è che speravo in qualche consiglio più mirato! :)

Sulla nuova versione utilizzo adaptive subdivision e come filtro ho selezionato catmull-rom, nella vecchia usavo simple-two level e come filtro avevo cubic.

Ora capisco ad esempio perchè prima mi veniva un pò sfuocato, fatto sta che se apro il vecchio progetto e al posto di cubic metto catmull-rom migliora ulteriormente, ma sul nuovo non so come fare per sistemare le cose..

Vi prego datemi una mano o questa è la volta buona che mando tutto al diavolo e mi metto a zappare la terra! ;)

Ciao!

Jonny

Share this post


Link to post
Share on other sites

Dipende anche dalla risoluzione dell'immagine che renderizzi.

se renderizzi in 800x600 per esempio è ovvio che molti dettagli come le bump vanno a farsi benedire, sopratutto se lontani dalla telecamera

Share this post


Link to post
Share on other sites
Dipende anche dalla risoluzione dell'immagine che renderizzi.

se renderizzi in 800x600 per esempio è ovvio che molti dettagli come le bump vanno a farsi benedire, sopratutto se lontani dalla telecamera

Esatto. Prova anche a verificare nel rollout delle texture se il sampler è impostato su "pyramidal" o "summed area".

L'effetto moire su trexture complesse si riduce di molto se imposti questo valore su "summed area" (la cosa vale sia per il motore standard di max che per quelli di terze parti come Brazil, Vray etc...)

Ciao :)

Gt6

Share this post


Link to post
Share on other sites
Dipende anche dalla risoluzione dell'immagine che renderizzi.

se renderizzi in 800x600 per esempio è ovvio che molti dettagli come le bump vanno a farsi benedire, sopratutto se lontani dalla telecamera

Si questo è vero, le cose infatti un minimo migliorano ad alta ris, ma non di tanto, e poi rimane comunque il fatto che nel vecchio render questo problema non si poneva...

Ragazzi non so cosa pensare..Comincio ad essere un pò avvilito..

Share this post


Link to post
Share on other sites
Esatto. Prova anche a verificare nel rollout delle texture se il sampler è impostato su "pyramidal" o "summed area".

L'effetto moire su trexture complesse si riduce di molto se imposti questo valore su "summed area" (la cosa vale sia per il motore standard di max che per quelli di terze parti come Brazil, Vray etc...)

Ciao :)

Gt6

Ti ringrazio per la preziosa informazione che prima non sapevo!

Sono andato di corsa a verificare che fosse quello il motivo ma..purtroppo è gia settato su pyramidal.. :(

Provo ad allegarvi 2 foto per farvi capire il concetto, sono entrambe 2 bozze fatte a bassa risoluzione, e quella nuova è ancora molto incompleta.

Comunque come vedete nella nuova, le texture che in primo piano sono così belle e definite, via via che si allontanano dalla camera si appiattiscono, cosa che nella vecchia immagine non succede...

ciao a tutti

Jonny

Share this post


Link to post
Share on other sites

.....il problema e' molto semplice,....le immagini che hai utilizzato come mappatura delle superfici non sono ripetibili,...quindi quando sei vicino tali ripetizioni non si vedono e l' immagine e' migliore quando pero' ti allontani si comincia a notare che la textur viene ripetuta, questo perche i punti di diunzione sono molto diversi tra loro, e perde di realismo,.....l' unica soluzione e' utilizzare delle immagini piu' omogenee, in modo da mascherale il tiling della testur,...o altrimenti crei una mappatura apposita per ogni parete in photoshop mettendo piu immagine a sieme fondendole e sporcandole,.....su "3dtotal.com" potresti sicuramente trovare molto materiale come riferimenti e tutorial,...tra laltro questo e' il sistema che piu preferisco perche' da la possibilita' di togliere l' effetto tipo "mister pulito" che solitamente si vede nei rendering di architettura..... :blink:

Ciao..... :devil:

Share this post


Link to post
Share on other sites
.....il problema e' molto semplice,....le immagini che hai utilizzato come mappatura delle superfici non sono ripetibili,...quindi quando sei vicino tali ripetizioni non si vedono e l' immagine e' migliore quando pero' ti allontani si comincia a notare che la textur viene ripetuta, questo perche i punti di diunzione sono molto diversi tra loro, e perde di realismo,.....l' unica soluzione e' utilizzare delle immagini piu' omogenee, in modo da mascherale il tiling della testur,...o altrimenti crei una mappatura apposita per ogni parete in photoshop mettendo piu immagine a sieme fondendole e sporcandole,.....su "3dtotal.com" potresti sicuramente trovare molto materiale come riferimenti e tutorial,...tra laltro questo e' il sistema che piu preferisco perche' da la possibilita' di togliere l' effetto tipo "mister pulito" che solitamente si vede nei rendering di architettura..... :blink:

Ciao..... :devil:

Purtroppo non è neanche questo il problema.

Se ci fai caso, le mappe usate nella nuova immagine, sono le stesse usate per la vecchia, solo che l'effetto tile nella nuova è stato quasi del tutto eliminato!

Nelle pareti verticali con quella texture rosina ad esempio nel vecchio file si vedono chiaramente tutte le varie giunzioni, sembrano quasi piastrelle infatti, nel nuovo file è quasi totalmente omogeneo.

E' proprio un fatto di profondità..La prima immagine nonostante le texture siano mal mappate, e tutto quanto, mantiene tutta la sua profondità anche lontano dalla camera, nella nuova immagine no..E' questo il problema che purtroppo non riesco a risolvere..

Share this post


Link to post
Share on other sites

Come gia' detto imposta bene l'AA e magari aggiungi un po' di bump alle texture ... un engine diverso (vray) come saprai da risultati diversi dallo scanline ... piu' "realistici" e quindi risalta o come in questo caso affievolisce le proprieta' del materiale se non accuratamente definito.

Un altro consiglio che ti posso dare e' di usare materiali vray .... forse risolve qualcosa.

ciao.


Edited by MaxiPT

Share this post


Link to post
Share on other sites
Come gia' detto imposta bene l'AA e magari aggiungi un po' di bump alle texture ... un engine diverso (vray) come saprai da risultati diversi dallo scanline ... piu' "realistici" e quindi risalta o come in questo caso affievolisce le proprieta' del materiale se non accuratamente definito.

Un altro consiglio che ti posso dare e' di usare materiali vray .... forse risolve qualcosa.

ciao.

Innanzi tutto grazie anche a te per l'aiuto!

Sarà il caso che dia qualche indicazione in più per inquadrare meglio il problema!

Allora, in tanto non so se si era capito, ma sia la vecchia immagine che la nuova sono state renderizzate con vray.

L'AA dovrebbe essere ben settato, di sicuro è settato anni luce meglio di quanto non lo fosse stato nella vecchia versione! :)

Venendo ai materiali, nella vecchia erano std, nella nuova sono vray.

Per quanto riguarda l'illuminazione, nella vecchia c'era lo skylight e una vray light usata a mò di sole, nella nuova c'è un hdri nello skylight e una direct con ombre vray a simulare la luce del sole.

Spero che dicendovi queste cose possa venirvi in mente qualche ragione..

In ogni caso vi ringrazio tantissimo perchè siete stati tutti molto gentili! :lol:

Ciao!

Jonny

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...