Vai al contenuto
franco rnd

Icone Sballate In Max 8

Recommended Posts

Non sapevo dove postare, se sballliato spostatemi e scusatemi.

Dunque il problema è questo:

In max (8) avete presente quel menu a tendina dell'align? quello dove c'è align, align camera, place highlight, ecc. ecc?

Ecco i comandi funzionano, però le icone visualizzate sono tutte sballate tranne align object. Ad esempio place highlight mi salta fuori con l'icona di align normal e mi è sparito l'align to grid. Sembra che il menu sia slittato verso il basso.

Ho provato a cercare nel max.ini, ho provato a rinominare il file e riaprire max, ad entrare nel customize UI, ma nulla.

Qualcuno sa dirmi dove andare a beccare quel menu in modo da poterlo editare e risistemare? Grazie... :TeapotBlinkRed:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

prova ad andare a vedere nella cartella delle icone di max, cerca il file che ha quelle icone e controlla di non averlo modificato o sostituito per sbaglio..

Oppure mi sa che ti tocca fare un reset dell'interfaccia.....

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Se hai customizzato l'interfaccia, probabilmente a qualche punto qualcosa e' andato storto.

La main toolbar non puo' essere modificata. E' hardcoded in max, cosi' se i file dell'interfaccia custom vengono cancellati o chissa cosa, la main toolbar puo' essere ricreata.

Le customizzazione dell'interfaccia sono salvate nei files .CUI (Custom User Interface), e sono editabili con un file di testo, ma non sono stati creati con l'idea di lasciare gli utenti modifcarli in quel modo... quindi sconsiglio di tentare di fissare il problema hackerando quei file.

Puoi sempre ricuperare l'interfaccia originale caricando "DefaultUI" o copiando i vari "DefaultUI.*" sopra i file "MaxStart.*".

Ma fa una copia dell'intera directory UI prima di fare esperimenti.

Rob

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Grazie Zicher!

Temevo infatti una cosa del genere.

Le mie Ui sono personali e ho ovviamente lasciato intatte le default.

Ho semplicemente customizzato la mia interfaccia e salvata con nome.

é probabile che avendo preso la customizzazione dal Max7 prima e dal 7.5 poi, qualcosa si sia sballato.

Comunque la cosa la posso risolvere facendo un'altra toolbar con i comandi che mi servono. E' che per abitudine il mouse va da solo su quell'icona ;-)

A proposito Zicher, visto che ne sai sicuramente molto, sai se è possibile, magari con uno script, crearsi un'icona con discesa a tendina per una toolbar (così come è possibile in Autocad)?

Sai ho una Ui leggermente "piena" di iconcine e sarebbe comodo poterle raggruppare per argomenti in icone a discesa....


Modificato da franco-rnd

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Non credo sia supportato o exposed a MaxScript.

Magari puoi fare una dialog in maxscript con i comandi che vuoi disposti in gruppi... non so bene quanti e come li vuoi organizzare. Ma puo' essere un alternativa.

Maxscript non e' il mio forte... ma se riesci a farlo allora la tua UI diventa portabile alle versioni successive senza problemi.

Rob

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×