Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
fabergambis

Alias Imf_copy X Alleggerire Textures E Alias Render

Recommended Posts

Leggendo i Mstercalss 2004 di Paolo Berto sull'ottimizzazione della memoria, mi sono imbattutto in questi due piccoli programmini che la fù Alias ha messo per facilitarci la vita. Ho una scena di poco più di un milione di facce e non riesco a renderizzarla a 1024x768, nemmeno con i calci; MR va out of memory, e si capisce...

Ho 1.5gb di RAM e un misero AMD XP2400.

Così ho provato a seguire i consigli del Master Berto e tra le tante cose a me incomprensibili, ho provato a fare funzionere queste due utility. Per quanto riguarda Render, sono riuscito a immettere tutte le informazioni neccessarie dal prompt comandi di windows (cmd.exe), caricando "Render -r mr -help" e impostando (penso) correttamente i settaggi del render della mia scena (percorso e nome del file da salvare \ formato dell'immagine \ camera \ risoluzione \ percorso e nome della scena); infatti la carica correttamente, mi dice che inizia a renderizzare e poi sembra bloccarsi senza alcun preavviso. Almeno così mi pare perchè dopo che do l'invio lui si carica la scena, inizia le operazioni di rendering e poi mi riappare C:\Document and Settings e il "cursore" come se attendesse un nuovo comando. Si, ma qual'è sto comando? Ho provato anche a risoluzioni inferiori e tutto rimane uguale. Invece per imf_copy, l'ho caricato ma non ho idea di cosa debba fare; non capisco se devo scrivere il nome delle textures con relative opzioni di conversione o cos'altro. Purtroppo a differenza di Render, non c'è alcun esempio che faccia capire la procedura e io non so proprio dove mettere mano.

C'è qualche buon uomo che mi sappia spiegare come funzionano queste due utility?

Grazie anticipatamente.

Fabrizio.

P.S. chiedo perdono ai moderatori, ma credo di aver sbagliato sezione, mi sa che deve essere spostata in "Rendering ed illuminazione", sorry.


Edited by fabergambis

Share this post


Link to post
Share on other sites

non sono un grande esperto di command line ma provo a risponderti

l'utility render ti permette di renderizzare tramite command line, cosa utile quando hai poca ram perché non devi caricarti maya in memoria

il comando che hai usato è corretto, ma serve per accedere all'help, lì puoi trovare tutte le opzioni attivabili tramite stringa

se vuoi renderizzare salvati la scena con i render global già impostati

poi scrivi: render -r mr nomefile

e lanci... così dovrebbe partire il render nudo e crudo

per imf_copy invece ti consiglio questo utilissimo script di Francesca Luce che ti permette di utilizzarlo dentro a photoshop

http://forums.cgsociety.org/showthread.php...hlight=imf_copy

una volta convertite le tue textures in .map dovrai ovviamente sostituirle nella tua scena

un ultimo consiglio, prova a usare il large bsp (lo trovi sotto memory and performance, nel render global) per il raytracing, io ho un 3200+ con 1gb di ram, ma sono riuscito a renderizzare fino a 10milioni di poligoni a 4000x3000...

Share this post


Link to post
Share on other sites

Ho provato ad utilizzare large BSP come consigliato da Paolo e ad aumentare di poco il Depth del BSP (40), ma nulla. Il massimo che sono riuscito ad ottenere in Batch con i settaggi di Paolo, è stato 800x600 a 300dpi perchè servivano per la stampa, ma forse avrei potuto provare anche a 600dpi. Cmq ora ho risolto cambiando tutta la vegetazione 3D con piani mappati col canale Alpha e la scena si è alleggerita di parecchio e sembra funzionare a dovere. C'è solo un albero bastardo che mi fa 2 ombre: quella delle foglie e quella del piano mappato leggermente più chiara. Ho smanettato vari parametri (Alpha Gain, Diffuse, Ambient Color...) ma non sortisce nulla. Ho provato a vedere con PS se il nero dell'Alpha è nero assoluto e lo è. Non mi vengono in mente altre cose, se non provare a cambiare la texture.

Se ti interessa, per la cronaca sto usando un polyplane Lambert con una mappa colore jpeg in Color e una mappa Alpha jpeg nel canale Transparency. Essendo due mappe separate (color e Alpha), non credo serva tenerle in TGA, ma spero di non sbagliarmi. In tutti gli altri piani funzionano bene, mentre in questo (guarda caso in primo piano) no. Argh!

Per fortuna per ora non mi serve più fare quegli esperimenti con la conversione in .map e con Alias Render, ma ti ringrazio per le info e per il link che ora mi andrò a spulciare.

Ciao.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x

Ti piacerebbe rimanere sempre aggiornato sulle ultime novità nel campo della computer grafica?.

Iscrivendoti alla newsletter, potrai ricevere direttamente nella tua casella di posta tutte le novità dal mondo della computer grafica, le iniziative della community, le offerte di lavoro, i tutorial, gli articoli, le interviste, le promozioni, gli eventi e molto altro. I tuoi dati saranno trattati nel pieno rispetto della privacy e potrai scegliere di disiscriverti in ogni momento.

SUBITO UN REGALO PER TE!
Iscrivendoti alla Newsletter riceverai subito il codice promozionale per scaricare gratuitamente le immagini da HDRI pro.