Vai al contenuto
lollos

Maya Fast Skin Shader

Recommended Posts

Ciao a tutti

Ho provato ad inserire una bump map sul canale bump shader del materiale fast skin shader ma in fase di rendering il bump non è bump ma semplicenete mi sporca tutto il materiale di macchie grigie.

Forse lo slot del bump non è bump shader???

Se non è quello qual'è?

grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

imploro aiuto anche io!!!! non riesco a capire come far funzionare sss in mental ray!!!! l'unica cosa che mi dà è l'effetto di diffusione della luce SOPRA la superfice, ma per quanto riguarda la luce che passa ATTRAVERSO alla superfice per creare l'effetto di traslucenza (l'esempio delle orecchie in controluce) niente.

Ho provato a variare il parametro per la conversione di scala, a variare lo spessore degli strati, ma mi da sempre un risultato come se sotto il primo strato non ce ne sia un secondo... :'( come funziona???

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite

Su cgtalk c'era un tutorial sulle connessioni da fare per il FastSkinMaya...cercalo...anche perche' se non fai le connessioni giuste(vedi lightmap) il FastSkin applicato di default non fa una beneamata cippa.

Se ritrovo il link te lo passo...comunque dovresti trovarlo con una ricerchina...

Ciao,Andrea.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

che io sappia non ci sono problemi con il bump per i misss_fast... non è che puoi postare una schermata del tuo shader graph? hai attaccato al nodo bump un bump2d di maya? che tipo di mappatura usi? mi pare che funzioni solo con la normal (ma ti consiglio di fare un uv map magari col pelt plugin)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ora sono al lavoro

Questa sera posto l'immagine.

Comunque ho applicato un montain grigio e nero sul canale bump shader.

Ho spianato le UV con una mappa cilindrica.

Ma invece di venire un bump mi da delle chiazze grigie.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

non puoi usare le proiezioni per il bump, devi usare il normal, oppure mappare le uv ;)

ah e ricordati di usare il bump2d, ovvero attacca il bump2d al canale bump, e la texture (mappata in normal) sul bump2d

il canale bump di maya ti fa in automatico le connessioni, quello di mr no


Modificato da dagon

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Scusa Dagon dimmi se il procedimento è giusto:

Creo il fast skin shader poi creo un bump 2d e lo connetto nel canale bump map del materiale.Creo una texture e la connetto in default sul bump 2d.

Ora per normal che intendi?? Le tre opzioni normal, as stencil as projection??

E che intendi per mappare le uv??

grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

sì esatto, il procedimento è quello e per normal intendo i 3 tipi di mappatura, non usare projection e stancil

per mappare gli uv intendo fare l'unwrap ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Infatti l'unwrap l'ho fatto, come ti ho scritto prima ho usato una mappa cilindrica.

Ora provo a fare come mi hai suggerito poi ti faccio sapere

grazie ancora ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Un ultima cosa

perchè mi da sempre questo errore?

Error: (Mayatomr.Output) : file error: C:/Documents and Settings/lorenzo/Documenti/MAYA_PROJECT/VOLTO/sourceimages/volto.bmp

Alla fine però quando renderizzo la texture me la fa vedere comunque.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Anche a me dà sempre questo errore ma poi funziona tutto: sarà qualche bug innocuo. NOn ci fare caso.

P.S. perdonate la mia ignoranza ma l'unwrap si fa a mano o c'è qualche funzione ben precisa? perchè io non la trovo.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Anche a me dà sempre questo errore ma poi funziona tutto: sarà qualche bug innocuo. NOn ci fare caso.

P.S. perdonate la mia ignoranza ma l'unwrap si fa a mano o c'è qualche funzione ben precisa? perchè io non la trovo.

pelting tools è di sicuro il migliore, sul sito trovi un tutorial su come usarlo

http://sunitparekh.com/pelting/

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Anche a me dà sempre questo errore ma poi funziona tutto: sarà qualche bug innocuo. NOn ci fare caso.

No infatti poi funziona tutto bene :D

grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

se ti da ancora problemi,vai sul nodo bump e sotto il pannello effects porta a zero "filter"

poi vai sul nodo file che hai collegato al bump(se hai usato un'immagine) e sotto il pannello effects porta anche li a zero il filter (non mettere filtro off perchè non funziona,devi portare lo slider a zero).

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×