Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
fisik74

Elaborazione Molto Lenta ...

Recommended Posts

Ciao a tutti,

questa è la prima volta che scrivo su questo forum, anche se vi seguo assiduamente da un po’ di tempo. Comincio con il presentarvi un mio piccolo problema :blush: da utente assolutamente inesperto. Premetto che utilizzo 3D studio max 6.0, su una macchina AMD Athlon 2600+ XP, con un 1GB di RAM ed una scheda grafica creative (5600xp) con chipset nvidia e 256 mb di memoria dedicata Mi sono cimentato nel creare una forma con una spline, che vi riporto nell’immagine. Ho fatto una estrusione con un numero di segmenti abbastanza elevato. I problemi cominciano quando cerco di fare un meshsmooth per ammorbidire le linee. Ho utilizzato un meshsmooth con i seguenti parametri:

Subdivision Method: NURBS

Subdivision Amount:

Iterations:2

Smoothness:1

Settings:

Quadratino

Keep Faces Convex

Ovviamente la parte in figura non è la sola del progetto. Ora vengo al dunque. La mia macchina non riesce a gestire questo lavoro, mi manda in crash il programma, va in out di memoria. Mi sembra un po’ strano, qui sul vostro sito ho visto lavori bellissimi realizzati con macchine anche meno potenti della mia. Quindi c’è qualcosa che non va. Se provo a diminuire le iterations, ottengo una superficie tutta segmentata, abbastanza brutta (figura 2). Mi potete aiutare.

post-10557-1141651192_thumb.jpg

post-10557-1141651203_thumb.jpg

Share this post


Link to post
Share on other sites
Guest
Ciao a tutti,

questa è la prima volta che scrivo su questo forum, anche se vi seguo assiduamente da un po’ di tempo. Comincio con il presentarvi un mio piccolo problema :blush: da utente assolutamente inesperto. Premetto che utilizzo 3D studio max 6.0, su una macchina AMD Athlon 2600+ XP, con un 1GB di RAM ed una scheda grafica creative (5600xp) con chipset nvidia e 256 mb di memoria dedicata Mi sono cimentato nel creare una forma con una spline, che vi riporto nell’immagine. Ho fatto una estrusione con un numero di segmenti abbastanza elevato. I problemi cominciano quando cerco di fare un meshsmooth per ammorbidire le linee. Ho utilizzato un meshsmooth con i seguenti parametri:

Subdivision Method: NURBS

Subdivision Amount:

Iterations:2

Smoothness:1

Settings:

Quadratino

Keep Faces Convex

Ovviamente la parte in figura non è la sola del progetto. Ora vengo al dunque. La mia macchina non riesce a gestire questo lavoro, mi manda in crash il programma, va in out di memoria. Mi sembra un po’ strano, qui sul vostro sito ho visto lavori bellissimi realizzati con macchine anche meno potenti della mia. Quindi c’è qualcosa che non va. Se provo a diminuire le iterations, ottengo una superficie tutta segmentata, abbastanza brutta (figura 2). Mi potete aiutare.

Share this post


Link to post
Share on other sites
Guest

Premetto che io utilizzo la ver. 8 S.P.2

Prova in Customize(personalizza)>Preferences(opzioni)>Viewports>Configure Driver>clicca e metti OpenGL. Riavvia 3D Studio.

Se l'hai già fatto, allora non so darti altra risposta. In bocca al lupo. Ciao.

Giovanni

Share this post


Link to post
Share on other sites

guardando le immagini di esempio, e non avendo visto un wire

credo il problema stia nel modo in cui tu hai definito la geometria di base.

Il mesh smooth funziona bene con geometrie semplici e con facce più o meno di dimensione uguale fra loro.

devi cioè creare un reticolo omogeneo, prima di applicare il modificatore

Invece tu sei forse partito da una spline con vertici di bezier o smooth con interpolation alta, poi l'hai estrusa e a quel punto hai applicato il meshsmooth.

manda il wire che cos' si capisce meglio e cerca di spiegare quale risultato vuoi ottenere dalla forma che hai definito.

Forse è sufficiente usare un estrusione col bevel.

ciao

Share this post


Link to post
Share on other sites

Per GIANE

Ho già provato a cambiare i driver video, ho provato sia con directx9 sia con open GL, in realtà non cambia nulla.

Per TEOKITE

ho fatto esattamente come scrivi tu. Quindi in realtà non va bene questo tipo di procedimento. Cosa significa fare prima una estrusione (tra l'altro ho utilizzato un numero di segmenti nell'estrusione molto alto 100) e poi un bevel. Devo utilizzare prima il modificatore extrude e poi il modificatore bevel?

In realtà voglio realizzare una estrusione del profilo che vedete in figura con spigoli leggermente arrotondati. Avevo pensato di utilizzare il modificatore meshsmooth semplicemente per correggere le anomalie sul contorno, in quanto il profilo è stato realizzato a mano ricalcando un disegno.

Per Cecofuli

Purtroppo non ho davanti a me il lavoro, appena posso ti faccio avere il numero di poligoni.

Share this post


Link to post
Share on other sites

ok...non devi usare il meshsmooth allora

devi fare un extrude con il modificatore bevel

attivi il secondo livello cui dai un fattore di smusso e un altezza.

Comunque se tu estrudi una spline e non devi successivamente distorcerla nel senso dell'estrusione è sufficiente il valore segment=1.

ci credo che ti andava in crash il sistema...

ciao

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...