Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
CLASPA

Animazione...impazzisco

Recommended Posts

Ciao Ragazzi…spero che qualcuno possa chiarirmi questo problema per me fondamentale. Spiego in due parole.

Sto eseguendo un’animazione di cui ho allegato le immagini. E’ una struttura composta da dalle travi.

L’animazione si svolge in questo modo: All’inizio si vede solo il piano poi una alla volta appaiono le travi che si animano mediante estrusione del profilo a T delle travi. Praticamente ho semplicemente animato l’estrusione di ogni singola trave che compone l’intera struttura.

In primari bounces IM, in secondari QMC, come antialiasing utilizzo mitchel-Netravali con blur=0 e ring=1. Faccio il calcolo con il Multiframe incremental e imposto Every Nth Frame ogni 10 considerando che i fotogrammi totali della mia animazione sono 1650 ma la telecamera non si sposta di un mm. Naturalmente utilizzo il medium animation in current present Il problema è che APPAIONO LE MACCHIE CHE HO EVIDENZIATO!!!

L'immagine a è il primo fotogramma.

L'immagine b è l'ultimo fotogramma.

Come faccio a toglierle…cosa sbaglio? Spero che qualcuno possa aiutarmi.

Grazie a tutti.

CLASPA

post-16004-1136276583_thumb.jpg

post-16004-1136276610_thumb.jpg

Share this post


Link to post
Share on other sites

Vray..scusate...ultima versione full.

Il mio dubbio è che abbia messo un valore Every Nth frame troppo basso..cioè ogni 10 fotogrammi.

Sto facendo delle prove inserendo 100 anzichè 10 e forse le cose cambiano...MA NON CAPISCO...VORREI DEI CHIARIMENTI...

Ciao

Già che ci siamo posto la stampa della finestra.

post-16004-1136282120_thumb.jpg

Share this post


Link to post
Share on other sites

Premetto non conosco assolutamente vray uso maya, ma il tuo problema sembra dato dalle occlusioni che rimangono inspiegabilmente anche quando l'oggetto non c'è più, perche non provi a toglierle ed a metterle in un post cosi da poterle gestire meglio.

Ciao Ring.

Share this post


Link to post
Share on other sites
Vray..scusate...ultima versione full.

Il mio dubbio è che abbia messo un valore Every Nth frame troppo basso..cioè ogni 10 fotogrammi.

Sto facendo delle prove inserendo 100 anzichè 10 e forse le cose cambiano...MA NON CAPISCO...VORREI DEI CHIARIMENTI...

Ciao

Già che ci siamo posto la stampa della finestra.

Ciao

senti io nn sono molto esperto di animazioni ma se metti il valore 100 anzichè 10, significa che le cose peggiorano xchè ti calcola la irr map ogni 100 frame.

Dubito che il multiframe incremental possa funzionare x questo genere di cose..... prova a mettere ogni 5 frame e vedi cosa succede.

Io cmq te ne sconsiglio l'utilizzo, il mutliframe incremental è buono se hai una camera in movimento ma se gli oggetti della scena si spostano o cambiano geometria conviene calcolare frame x frame l'irr map.

Calcola un piccolo pezzo della tua animazione così e vedi se le cose migliorano.

Share this post


Link to post
Share on other sites

il multiframe incremental funziona quando non ci sono cambiamenti radicali nella scena (non mi sembra il tuo caso)

prova ad impostare il calcolo su single frame, fai una prova su un pezzetto di animazione e vedi se risolvi

il problema, come avrai capito, sarà costituito dall'aumento sensibile dei tempi di calcolo


: :  Youtube : : 

Share this post


Link to post
Share on other sites

Philix (anche Ferlo)avete perfettamente ragione...senza il multiframe non ci sono quelle macchie schifose...

L'unica pecca è appunto il tempo...col multiframe me la cavavo in 15 ore...ora 56 non bastano...considerando che il PC è bello superato. Comunque grazie.

Share this post


Link to post
Share on other sites
...ora 56 non bastano...

Ottimizza...cerca di ridurre al massimo il tempo di render x ogni frame andando a togliere riflessioni/rifrazioni agli oggetti etc....

buona fortuna

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...