Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ghika

Editor Materiali Max 8

Recommended Posts

lo so che sara' una banalita' ma non ci cavo le zampe e ripropongo il quesito: :blush:

ho installato max 8 e nell'editor materiali quando apro una libreria architettonica mi appaiono le "palline" senza texture applicata sopra, la quale invece appare come tale a fianco (dopo aver tolto la spunta a root only)

Nella libreria di default cio' non accade (le "palline" hanno la loro texture applicata).

Sapete perche'?

GhiKa GraPh

Share this post


Link to post
Share on other sites

A me lo faceva quando avevo installato max con i file demo che avevo scaricato dal sito Discreet.

Mai avuto problemi intallando da CD.

Mi sembra di ricordare di aver risolto inserendo a mano il percorso nel file 3dsmax.ini

Una cosa del genere : (questo è un estratto del mio attuale 3dsmax.ini....)

[bitmapDirs]

Dir1=C:\3dsmax7\maps

Dir2=C:\3dsmax7\maps\fx

Dir3=C:\3dsmax7\downloads

Dir4=C:\3dsmax7\maps\Concrete

Dir5=C:\3dsmax7\maps\Fabric

Dir6=C:\3dsmax7\maps\Ground

Dir7=C:\3dsmax7\maps\Lights

Dir8=C:\3dsmax7\maps\Metal

Dir9=C:\3dsmax7\maps\Brick

Dir10=C:\3dsmax7\maps\Organics

Dir11=C:\3dsmax7\maps\Reflection

Dir12=C:\3dsmax7\maps\Skies

Dir13=C:\3dsmax7\maps\Space

Dir14=C:\3dsmax7\maps\Stones

Dir15=C:\3dsmax7\maps\Water

Dir16=C:\3dsmax7\maps\Wood

Dir17=C:\3dsmax7\maps\misc

Dir18=C:\3dsmax7\maps\Vehicles

Dir19=C:\3dsmax7\maps\Backgrounds

Dir20=C:\3dsmax7\maps\ArchMat

Share this post


Link to post
Share on other sites

Anche io ho lo stesso problema. Avevo già aperto un post analogo

http://www.treddi.com/forum/index.php?act=ST&f=28&t=12843

ma nessuno si è degnato di rispondermi... :crying:

Il Mio file max.ini ha i percorsi nel seguente modo:

[bitmapDirs]

Dir1=C:\Programmi\Autodesk\3dsMax8\maps

Dir2=C:\Programmi\Autodesk\3dsMax8\maps\Backgrounds

Dir3=C:\Programmi\Autodesk\3dsMax8\maps\ArchMat

Dir4=C:\Programmi\Autodesk\3dsMax8\maps\fx

Dir5=C:\Programmi\Autodesk\3dsMax8\downloads

Dir6=C:\Programmi\Autodesk\3dsMax8\Photometric

Dir7=C:\Programmi\Autodesk\3dsMax8\maps\Concrete

Dir8=C:\Programmi\Autodesk\3dsMax8\maps\Fabric

Dir9=C:\Programmi\Autodesk\3dsMax8\maps\Ground

Dir10=C:\Programmi\Autodesk\3dsMax8\maps\Lights

Dir11=C:\Programmi\Autodesk\3dsMax8\maps\Metal

Dir12=C:\Programmi\Autodesk\3dsMax8\maps\Brick

Dir13=C:\Programmi\Autodesk\3dsMax8\maps\Organics

Dir14=C:\Programmi\Autodesk\3dsMax8\maps\Reflection

Dir15=C:\Programmi\Autodesk\3dsMax8\maps\Skies

Dir16=C:\Programmi\Autodesk\3dsMax8\maps\Space

Dir17=C:\Programmi\Autodesk\3dsMax8\maps\Stones

Dir18=C:\Programmi\Autodesk\3dsMax8\maps\Wood

Dir19=C:\Programmi\Autodesk\3dsMax8\maps\Misc

Ho controllato ed effettivamente sembra che vadano bene, le cartelle corrispondono..... quindi punto e a capo... cosa posso fare?

Share this post


Link to post
Share on other sites

Urk :eek:

Mi dispiace allora, forse non era questo...

Non mi ricordo più di preciso cosa avevo cambiato.

Se volete tentare un ultimo esperimento, fate una copia del file 3dsmax.ini e toglietelo dalla directory.

all' avvio di Max dovrebbe ricreare un' altro .ini e vediamo come va.

Mal che vada ripristinate quello vecchio.

Share this post


Link to post
Share on other sites

Allora ragazzi...

Ho provato anch' io a togliere il file 3dsmax.ini e al riavvio mi capita proprio come a voi, cioè non si vedono più le texture nei materiali.

Allora ho copiato il percorso delle bitmapdirs dal vecchio file .ini al nuovo e come per magia funziona tutto !!!

Quindi il problema dev' essere li...

Controllate bene il percorso, se esistono le directory e soprattutto le texture !!!!

Share this post


Link to post
Share on other sites

Ho provato a smanettare con i file ini come hai detto tu, ma non sono riuscito a combinare nulla di buono. Forse perchè il mio file ini non è completo e manca qualche voce. In tal caso dovrei confrontare il mio file ini con quello di qualcuno a cui funziona correttamente e vedere quali voci mancano (oltre alle bitmap dir). La cosa buffa è che i materiali non vengono visualizzati nell'anteprima ma vengono correttamente renderizzati!!! Che casino....

Cmq è vero che se tolgo il file ini e ne faccio ricreare uno nuovo a max, non si vedono neanche le anteprime dei materiali di max (quelli non architettonici). Purtroppo non sono ancora riuscito ad individuare la voce mancante che fa tutto questo casino.... grrr :wallbash:

Share this post


Link to post
Share on other sites

Niente da fare ...... :wallbash::wallbash::wallbash:

ho smanettato all'inverosimile seguendo i vostri ultimi consigli ma non sono riuscito a cavare un ragno da un buco: i materiali architettonici non riesco a visualizzarli con le textures

a i u t o !!!

C'e' per caso qualcuno a cui vengono visualizzati bene che ci puo' inviare il suo 3dsmax.ini ???

Ne sarei grato tantissimissimo :)

GhIka GraPh

Share this post


Link to post
Share on other sites

:lol::lol::lol::lol: Ci sono arrivato finalmente!!! Che mi offrite se vi do la soluzione??? :D :D :D

Vi illustro il ragionamento:

La questione è molto semplice, le texture dei materiali architettonici hanno tutte la spunta "real world" (che teoricamente servirebbe a scalare la texture come se fosse nel mondo reale.... mentre secondo me fa solo casino) Non appena ho disattivato questa voce, le anteprime delle texture sono magicamente apparse!!!! Questo lavoro andrebbe iterato per tutte le texture dei materiali architettonici!!! Per riassumere dovrei

caricare il materiale che nn si vede nel material editor, poi andare a modificare le texture associate a quel materiale (una ad una) e togliere la spunta a "use real world scale"....

Cambiare tutte le texture è una gran rotta di maroni, ciò che mi domando ora è: "esiste ora una procedura veloce per sistemarle tutte o per impedire a max di usare "use real world scale"???" Ebbene si, grazie a questa domanda risolvo definitivamente questo problema!!!

SOLUZIONE FINALE

Aprite il material editor/options/options.. e deselezionate "Auto Select Texture Map Size" > click su OK

:lol::lol::lol: TUTTO QUI!!! :w00t::w00t::w00t:

Buon render a tutti!!! B)


Edited by zapii

Share this post


Link to post
Share on other sites

Scusa Zapii, ma il tuo sistema non funzia....

Ho capito invece dove sta il problema. I materiali li vedo neri negli slot perchè i mat architettonici sono molto scuri. Ho risolto cambiando l'ambient color nelle opzioni del mat editor.... devo trovare il modo di farlo anche nel mat browser adesso.....

Share this post


Link to post
Share on other sites

Il mio problema non era i materiali che si vedono scuri -_- , ma il fatto non si vedevano le texture sia nel material editor che nel material browser, vedevo solo il "diffuse color" (come può testimoniare il mio primo post http://www.treddi.com/forum/index.php?act=ST&f=28&t=12843 che poi è anche il problema segnalato da ghika in questa discussione !!!)

Hai provato a vedere materiali tipo "legno" cioè materiali chiari??? Mi sembra strano che li vedi tutti scuri!!! :blink2: A meno che tu non usi Maxwell, e allora i materiali nn li vedi proprio sul material editor, almeno finchè nn risolveranno questo problema nel plugin!!! :wallbash:

Se mi spieghi meglio dove stanno le differenze tra il mio e il tuo caso, forse riesco ad aiutarti!!! :blush:

Ciao!! :TeapotBlinkRed:


Edited by zapii

Share this post


Link to post
Share on other sites

Solo alcuni effettivamente sono scuri. mi sono accorto che c'erano le textures solo facendo lo zoom dello slot. Strano che con il 7.5 non si presentano problemi. Non uso Maxwell.

Cioè con il 7.5 l'ambient degli slot è bloccato sul nero e i mat si vedono, nell'8 lo devo mettere a grigio 70% per vedere le textures.... BOHHHHH!!!!

Share this post


Link to post
Share on other sites

FUNZIONA ALLA STRAGRANDE !!!!!!!

M I T I C O :Clap03::Clap03::Clap03:

GhIKa gRApH

:lol::lol::lol::lol: Ci sono arrivato finalmente!!! Che mi offrite se vi do la soluzione??? :D :D :D

Vi illustro il ragionamento:

La questione è molto semplice, le texture dei materiali architettonici hanno tutte la spunta "real world" (che teoricamente servirebbe a scalare la texture come se fosse nel mondo reale.... mentre secondo me fa solo casino) Non appena ho disattivato questa voce, le anteprime delle texture sono magicamente apparse!!!! Questo lavoro andrebbe iterato per tutte le texture dei materiali architettonici!!! Per riassumere dovrei

caricare il materiale che nn si vede nel material editor, poi andare a modificare le texture associate a quel materiale (una ad una) e togliere la spunta a "use real world scale"....

Cambiare tutte le texture è una gran rotta di maroni, ciò che mi domando ora è: "esiste ora una procedura veloce per sistemarle tutte o per impedire a max di usare "use real world scale"???" Ebbene si, grazie a questa domanda risolvo definitivamente questo problema!!!

SOLUZIONE FINALE

Aprite il material editor/options/options.. e deselezionate "Auto Select Texture Map Size" > click su OK

:lol::lol::lol: TUTTO QUI!!! :w00t::w00t::w00t:

Buon render a tutti!!! B)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...