Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
MikGraphix

Problema Texturing

Recommended Posts

salve a tutti, ho un problema. ho modellato una scatola partendo dalla sua fustella :D . dalla stessa fustella ho creato la grafica che deve rivestire la scatola. il problema sorge quando vado ad applicare la texture al modello :eek: . le ho provate tutte, ma non riesco a trovare la soluzione. di seguito alcune immagini per chiarirvi la situazione :wallbash: :

1: la texture :D

texture2ab.th.jpg

2: la base <_<

base7bu.th.jpg

3: il problema :blink2:

schermatacinema1ee.th.jpg

se qualcuno mi potesse aiutare....

grazie :hello:

Share this post


Link to post
Share on other sites

non conosco cinema 4d ma a prima vista sembrerebbe un problema di tile, prova a portarlo a 1.

Ma devi creare un'animazione della scatola che si chiude da sè? Altrimenti potevi fare il box e mappare ogni faccia della texture sul poligono corrispondente

:hello:

Share this post


Link to post
Share on other sites

ciao, nemmeno io ho mai aperto cinema 4d, però credo che i fondamenti di texturing valgano per tutti i programmi; io ti consiglio di applicare ad ogni facciata della scatola una mappatura planare e sistemare la texture pezzo per pezzo, perchè se aspetti che te la piazzi lui in automatico ci potresti passare una vita :)

Share this post


Link to post
Share on other sites

L'idea che avevo è proprio quella dell'animazione. infatti, quando applico la texture alla scatola aperta, questa va che è una meraviglia. poi non so perchè, quando vado a piegare i bordi, la texture si sposta. non so cosa sia la mappatura planare, potreste erudirmi?

grazie

Share this post


Link to post
Share on other sites

secondo me conveniva dividere le texture in facciate, dal momento che una scatola è un cubo.

anche se porti i tile a 1 credo che non funzioni:la texture mi pare che si ripeta su ogni facciata mentre ogni lato dovrebbe avrerne una diversa...non conosco bene cinema ma alla fine funzionano tutti allo stesso modo.

Share this post


Link to post
Share on other sites

non è prorpio un cubo. se guardi bene la seconda immagine, vedi che c'è la forma della fustella. mi serve utilizzare quella forma perchè intendo animarla. mi sa che devo scomporre tutto. pezzo per pezzo. sperando che alla fine non si notino le giunture. ciaooooo

Share this post


Link to post
Share on other sites

ok

sto sperimentando cose nuove perchè ho notato che se la fustella rimane aperta, la texture va al suo posto. solo che si sposta quando piego gli spigoli.

vi faccio avere notizie, ma voi non abbandonatemi. continuate a postare suggerimenti.

ciauz

Share this post


Link to post
Share on other sites

forse potresti adottare un compromesso, nn verrebbe perfetto ma nn sarebbe nemmeno maluccio; prova a separare la scatola in diversi pezzi, ognuno per ogni pezzo di texture; così facendo nn dovresti avere più problemi quando vai a piegare i singoli pezzi dato che le informazioni di mappatura restano quelle che sono,

Share this post


Link to post
Share on other sites

Ho capito ;)

per non vedere le giunture, fai in modo che i bordi finiscano con lo stesso colore, in quel tipo di texture se fai così è impossibile vedere giunture poi. secondo me se dividi le texture è la cosa migliore...

Share this post


Link to post
Share on other sites

ti consiglio vivamente di incominciare a studiare l'uvwmapping-..

cmq applicando la tex in frontale a modello aperto dopo puoi fare il "fissa tex"

oppure "genera coordinate uvw" .. in pratica e la stessa cosa..

Share this post


Link to post
Share on other sites

grazie per i consigli piko. se dai un occhiata al video, vedrai che l'ho risolta. ho dato il tag fissa texture e poi ho iniziato a modellare. cmq hai ragione, devo mettermi a studiare perchè più passa il tempo e più capisco che so sempre poco rispetto a quello che dovrei. ciaooooo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...