Vai al contenuto
44 gatti

Perchè i miei render sono lentissimi?

Recommended Posts

Ragazzi , per renderizzare con vray ho un processore Intel i7 4790 e 16 gb di Ram ma i miei render hanno tempi assurdi.

Ci sono video su internet di persone che con lo stesso processore e ram realizzano render finali in circa mezz'ora..e questa cosa mi fà imbestialire. Io ho fatto un render la settimana scorsa di una scena piuttosto semplice e mi ci sono volute circa 8 ore 🤨 mentre questa settimana ho renderizzato una scena con una decina di luci e molto DOF e dopo 16 ore ho dovuto interrompere perchè il render non era neanche a metà 😫 

QUeste sono le impostazioni che ho utilizzato nell'ultimo render. Settings1.jpg.0f2c188a0ac1c89916eacdb9e3dbdd84.jpg

Ho passato molto tempo a studiare i vari parametri e penso di aver scelto i parametri con logica e cercando di rimanere su valori medio/bassi

Ad esempio Bucket anziche progressive,

40 Max subdivis anzichè i 100 delle impostazioni universali di vray

Noise treshold 0,005 invece di 0,001

Irradiance map invece della brute force

Preset low dell'iiradiance map

Suddivisioni dell'irradiance map a 40 perchè è sconsigliato superare i 50

Suddivisioni della light cache a 1800 invece di 2000 (il minimo consigliato per render finali)

Anche la risoluzione del render non è 4K  ma è di 1920x1080

 

Come vedete nonostante i parametri "al ribasso" ho dei tempi di render disumani.

Il rpocessore non ha OC ma dubito che solo questo possa spiegare la differenza di un render di mezz'ora in uno di 8 ore e anche di più.

L'unica impostazioni di cui non sono sicuro sono quelle del pannello "settings"

 

 


Modificato da 44 gatti

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
In questo momento, Marcello Pattarin ha scritto:

più che la 3.6 punta subito alla relase Next, è l'ultima disponibile e più veloce di tutte.

 

Se è disposto a spendere l'aggiornamento sicuramente è la scelta migliore e condivido il tuo consiglio, il passaggio alla 3.60 è gratuito per chi possiede la 3.50 meglio che provi a reinstallare il software cosi e poi in caso compra next perché i parametri non mi sembrano chissache

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ragazzi, ma quale update, alla versione più aggiornata o release nuova. non può metterci quei tempi anche sulla 3.50, mettendo che sia più lenta per diversi bug!

è la direzione sbagliata.

Va bene passare alla 3.60, e magari vedere anche la scena, perchè i problemi sostanzialmente derivano da li, già visto che il min shading rate è a 6, probabile che vengono usate anche le subdivision manuali. quindi vedere impostazioni di tutte le luci, ma prima resettando vray, anche con la 3.50, perchè no, e magari importare la scena in un file nuovo. con i settaggi che ho letto sopra, dovrebbe renderizzare in minuti.

questo è dettato su ambito software!!!!

invece su ambito hardware, verificare che la cpu lavori al 100%, da avvio gestione attività di windows, che le temperature della cpu siano basse, con CoreTemp.

in questo modo si inizia a capire se il problema è sw o hardware!!! oppure anche se non basta la ram, oppure modificare il memory dinamic limits ed alzarlo. tutto questo vedendo alcuni screen fa già capire meglio!!!!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Meglio provare un aggiornamento alla 3.6 prima di spendere, ma l'interrogativo di zatta è lo stesso che avevo scritto pure io, possibile che la sola versione del software possa spiegare tempi di rendering cosi lunghi?

Rispondendo a zatta: le subdivision NON sono manuali, il min shading rate è impostato a 6 perchè da chaos group è considerato un valore adatto alla maggior parte delle scene, probabilmente per renderizzare al meglio la mia ultima scena lo dovrei un po alzare, ma fungendo da moltiplicatore un valore di 6 dovrebbe renderizzare piu veloce di un valore di 10 o 20 (per esempio).

Per quanto riguarda la CPU sembra lavorare a pieno regime.

Le temperature in passato erano alte ma dopo aver installato una ventola aggiuntiva della coolermaster  adesso sembrano nella norma 17/22° a riposo 45/50° a pieno sforzo durante il render.

Come scritto il pannello setting è quello con cui ho meno dimestichezza e non saprei come modificare il memory dynamic limits.

Inizio a pensare che il motore di rendering abbia un bug oppure sia da resettare. come faccio a resettarlo? lo devo disinstallare e reinstallare?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
56 minuti fa, 44 gatti ha scritto:

Meglio provare un aggiornamento alla 3.6 prima di spendere, ma l'interrogativo di zatta è lo stesso che avevo scritto pure io, possibile che la sola versione del software possa spiegare tempi di rendering cosi lunghi?

Rispondendo a zatta: le subdivision NON sono manuali, il min shading rate è impostato a 6 perchè da chaos group è considerato un valore adatto alla maggior parte delle scene, probabilmente per renderizzare al meglio la mia ultima scena lo dovrei un po alzare, ma fungendo da moltiplicatore un valore di 6 dovrebbe renderizzare piu veloce di un valore di 10 o 20 (per esempio).

Per quanto riguarda la CPU sembra lavorare a pieno regime.

Le temperature in passato erano alte ma dopo aver installato una ventola aggiuntiva della coolermaster  adesso sembrano nella norma 17/22° a riposo 45/50° a pieno sforzo durante il render.

Come scritto il pannello setting è quello con cui ho meno dimestichezza e non saprei come modificare il memory dynamic limits.

Inizio a pensare che il motore di rendering abbia un bug oppure sia da resettare. come faccio a resettarlo? lo devo disinstallare e reinstallare?

per resettare il motore di rendering, basta cambiarlo con scanline, arnolrd..... e rimettere vray

da questo punto in poi si reinseriscono i settaggi voluti in vray.

certo è che avere qualche screen della scena e anche magari di quante luci o che luci non sarebbe male!

se vuoi, mi puoi passare la scena, ho un i7 4790k, quindi più o meno simile, anche se fatto o.c. a 4.5ghz, ma giusto per capire, da dove parte il problema.

prima di tutto resetta la scena, come ho già scritto, se non risolvi e la puoi passare anche in pvt posso controllarla.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

p.s. io il min shading rate lo tengo a 32 o a volte a 64 per animazioni dinamiche, e con la cpu descritta sopra parlando di interni o anche esterni si sta sui 2-2.30 ore in 1080p a frame, quindi per delle stills si può stare anche a settaggi più bassi, tanto il flick, non si vede. motivo per cui sono assurde quelle tempistiche!


Modificato da zatta 3d

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Al volo qualche considerazione mia.. io ho un dual xeon 2630v4 e non ci metto meno di 3-4 ore a fotogramma per renderizzare, ottimizzando tutto, con vRay 3.6.

Quante luci hai nella scena? Nella 3.5 non c'è ancora l'adaptive light sampling, ergo più luci = più tempo di render. Il Min Shading Rate è consigliato a 6 come media, lo si abbassa per pulire eventuale DOF rumoroso in camera e lo si alza per dare più sampling ai materiali. Ti permette di usare max subdivs più basse e noise threshold più alto ottenendo comunque risultati puliti la dove la scena lo permette.. ma io comunque sopra 18 non vado e li uso comunque su scene molto semplici e pulite.

Che shader usi? FastSSS2 come se piovesse? Layered shaders? In base a cosa stai usando, i tempi per pulire l'immagine aumentano.

Con la 3.6 c'è stato un salto enorme di qualità/tempi di render e una riduzione drastica dei settaggi da toccare.

Stai usando HDRI con portals? Per pulire un'HDRI ci vuole molto più tempo che per un semplice sistema ad area lights o phisical sun/sky.

Che metodo di calcolo stai usando? IM+LC? Io ormai uso, come suggerito da Chaos Group, solo BF+LC, anche perché l'IM non solo è meno preciso e realistico ma sta anche venendo accantonato come metodo di calcolo (o per lo meno questo disse Vlado mesi fa).

Poi purtroppo anche se i parametri sono gli stessi di vRay for MODO, non usando 3dsmax non mi riesco ad ambientare troppo in quegli screen, quindi non posso esser più preciso.

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
12 ore fa, zatta 3d ha scritto:

per resettare il motore di rendering, basta cambiarlo con scanline, arnolrd..... e rimettere vray

da questo punto in poi si reinseriscono i settaggi voluti in vray. 

Grazie Zatta, Oggi se trovo un po di tempo voglio provare il reset e magari anche l'aggiornamento.

 

Grazie anche per le delucidazioni riguardo il min shading rate ragazzi !, come detto però prima di mettermi a rendrizzare ho studiato su  vari testi   le impostazioni e avevo afferrato la funzione del MSR e la sua correlazione tra primary rays (DOF ecc.) e secondary rays. Anzi sono contento che nessuno abbia detto che le impostazioni sono completamente fuori di testa, come spesso succede a chi apre discussioni come questa. 😅

36 minuti fa, Michele Faccoli ha scritto:

Che metodo di calcolo stai usando? IM+LC? Io ormai uso, come suggerito da Chaos Group, solo BF+LC, anche perché l'IM non solo è meno preciso e realistico ma sta anche venendo accantonato come metodo di calcolo (o per lo meno questo disse Vlado mesi fa).

Si irradiance map +LC. ho già provato la BF qualche settimana fà. Il risultato è stato ottimo ma i tempi si dilungano ulteriormente e al momento non posso peremttermelo...se non riesco ad ottenere tempi accettabili con gli algortmi biased figuriamoci usare la BF.

36 minuti fa, Michele Faccoli ha scritto:

Quante luci hai nella scena? Nella 3.5 non c'è ancora l'adaptive light sampling, ergo più luci = più tempo di render. Il Min Shading Rate è consigliato a 6 come media, lo si abbassa per pulire eventuale DOF rumoroso in camera e lo si alza per dare più sampling ai materiali. Ti permette di usare max subdivs più basse e noise threshold più alto ottenendo comunque risultati puliti la dove la scena lo permette.. ma io comunque sopra 18 non vado e li uso comunque su scene molto semplici e pulite.

Che shader usi? FastSSS2 come se piovesse? Layered shaders? In base a cosa stai usando, i tempi per pulire l'immagine aumentano.

Puntualizzo: ho  provato 2 render su 2 scene diverse ma entrambi immagini singole o still o single frame, chiamatele come volete.

Come detto la seconda sapevo fosse impegnativa a causa di una decina di luci, tra cui HDRI e vrayLightMTL (che credo siano pesati da calcolare perchè introducono molto noise) e del DOF (che volendo potrei ottenere in Post per alleggerire il render). DOpo 16 ore di calcolo ho dovuto arrestare il render perchè non era neanche a metà.

La prima scena invece sono riuscito a completarla dopo oltre 8 ore di calcolo. ma era piuttosto semplice. Solo 27.000 poligoni, 5 luci, tutti VrayMTL standard e nessun effetto particolare. Le impostazioni usate su entrambe le scene sono praticamente le stesse che ho postato all'inizio.

Al momento sono orientato verso un bug o un icasinamento di vray perchè i tempi lunghi si presentano sia su scene "dispendiose" ma anche su quelle più semplici


Modificato da 44 gatti

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ho fatto una veloce prova con una scena test che si trova su evermotion a queto indirizzo

https://evermotion.org/vbulletin/showthread.php?106109-3DMAX-Vray-benchmark-test

l'ho renderizzata 1 minuto e 33 secondi e mi sembra un tempo ragionevole, però è una scena un pò vecchia.

Avete qualche scena non troppo pensante da farmi renderizzare per comparare i tempi?

 

Inoltre nessuno mi ha risposto a quanto dovrei impostare il dynamic mem limit per me che ho 4 RAM da 4 Giga DDR3, Non-ECC CL9 DIMM

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
21 ore fa, 44 gatti ha scritto:

 

Vai sul sito di Chaos, ti loggi e scarichi il bench fatto da loro. E li vedi se il tuo processore è in linea con i tempi degli altri. E ti sei tolto il primissimo pensiero. Poi vedi se anche quello che ha scritto zatta e non ultimo io ti consiglio di aggiornare vray. Almeno cogli l'occasione e lo reinstalli


Modificato da mOcrAm

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Si ho provato, il render con CPU ha impiegato 2 minuti e 56 che credo sia nella norma, ma questo test non mi serve a molto perchè viene fatto tramite un app standalone. Io avevo bisogno di verificare una scena su 3ds max e il Vray che c'è sopra. Non ho mai messo in dubbio che la mia CPU funzionasse bene,i mei dubbi al mssimo sono sul software, sulle impostazioni o sulla scena.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
1 ora fa, 44 gatti ha scritto:

Si ho provato, il render con CPU ha impiegato 2 minuti e 56 che credo sia nella norma, ma questo test non mi serve a molto perchè viene fatto tramite un app standalone. Io avevo bisogno di verificare una scena su 3ds max e il Vray che c'è sopra. Non ho mai messo in dubbio che la mia CPU funzionasse bene,i mei dubbi al mssimo sono sul software, sulle impostazioni o sulla scena.

2 minuti e 30 sec è il tempo che faccio io col vray bench, con o.c.

quindi il problema non è la cpu, si spera!

hai resettato vray?

se mi vuoi passqare la scena la posso controllare e verificare cosa sta succedendo!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sto facendo qualche prova su un interno con poca roba,settaggi di dafult e bassa risoluzione.

 

_Ho provato ad aumentare il dyanamic mem limit da 4000 di default a 14.000 ma nei tempi di render non si è notata differenza

 

_ La cosa ineterssante  è successa quando ho iniziato a smanettare su altri parametri. Per renderizzare la scena con i settaggi di dafult ci metto circa 36 secondi, dopo aver aumentato fino a 10 il min shading rate il render è sembrato divenatre lentissimo, sembrava quasi bloccato. Ho quindi fatto un reset e riportato ai valori di dafult, ma renderizzando di nuovo il calcolo era sempre lentissimo proprio come nel render precedente a settaggi modificati. Ho provato a fare nuovamente un reset delle impostazioni e questa volta ha funzionato, il render è nuovamente durato 36 secondi. 

Strana questa cosa 🤨 questo potrebbe spiegare perchè durante i render di prova delle mie scene con impostazioni di default tutto sembrava funzionare correttamente ma quando vado a smanettare sui parametri per il render fnale vray sembra funzionare al rallentatore.

Devo assolutamente aggiornare alla versione successiva per verificare se vray si comporta in modo anomalo


Modificato da 44 gatti

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
16 ore fa, 44 gatti ha scritto:

Sto facendo qualche prova su un interno con poca roba,settaggi di dafult e bassa risoluzione.

 

_Ho provato ad aumentare il dyanamic mem limit da 4000 di default a 14.000 ma nei tempi di render non si è notata differenza

 

_ La cosa ineterssante  è successa quando ho iniziato a smanettare su altri parametri. Per renderizzare la scena con i settaggi di dafult ci metto circa 36 secondi, dopo aver aumentato fino a 10 il min shading rate il render è sembrato divenatre lentissimo, sembrava quasi bloccato. Ho quindi fatto un reset e riportato ai valori di dafult, ma renderizzando di nuovo il calcolo era sempre lentissimo proprio come nel render precedente a settaggi modificati. Ho provato a fare nuovamente un reset delle impostazioni e questa volta ha funzionato, il render è nuovamente durato 36 secondi. 

Strana questa cosa 🤨 questo potrebbe spiegare perchè durante i render di prova delle mie scene con impostazioni di default tutto sembrava funzionare correttamente ma quando vado a smanettare sui parametri per il render fnale vray sembra funzionare al rallentatore.

Devo assolutamente aggiornare alla versione successiva per verificare se vray si comporta in modo anomalo

 

stai usando le subdivision automatiche? in questo modo gestisci la qualità attraverso il min shading rate, altrimenti se modificihi le subdivion manualmente non ha senso usare il min shading rate.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Intendi le suddivisioni di materiali, luci, ecc??? si sono automatiche e le gestisco tramite min shading rate

 

Più tardi  provo a smanettare un altro pò sul programma e vi aggiorno su eventuali novità

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
1 ora fa, 44 gatti ha scritto:

Intendi le suddivisioni di materiali, luci, ecc??? si sono automatiche e le gestisco tramite min shading rate

 

Più tardi  provo a smanettare un altro pò sul programma e vi aggiorno su eventuali novità

 

puoi girarmi la scena, posso fare qualche prova

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Grazie zatta sei gentilissimo ma al momento preferirei non mostrare le scene (non per sfiducia sia chiaro, conosco la tua serietà il livello di rispetto di cui godi in in questo forum 😉 )

 

Ho appena aggiornato alla 3.60, in questi giorni faccio un pò di prove e vedo cosa  succede...cosi andiamo per esclusione

 

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
14 minuti fa, 44 gatti ha scritto:

Grazie zatta sei gentilissimo ma al momento preferirei non mostrare le scene (non per sfiducia sia chiaro, conosco la tua serietà il livello di rispetto di cui godi in in questo forum 😉 )

 

Ho appena aggiornato alla 3.60, in questi giorni faccio un pò di prove e vedo cosa  succede...cosi andiamo per esclusione

 

 

se vuoi puoi parlare con @ChaosLele

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao , 

guarda che proprio non devi pasticciare con i parametri . Usa i quick settimg e basta . Non toccare cose a caso

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×