Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Vash23

Problema ad esportare animazione su FBX

Recommended Posts

Ciao, da un sacco di tempo che non scrivo sul forum

 

Ho voluto esercitarmi con un modello pensato per videogiochi, un piccolo robot modellato in 3ds e riggato in Maya. Sto concludendo l'animazione ma ci sono 4 joints che mi stanno dando problemi.

Per qualche motivo non riesce a trasferire la traslazione di questi 4 punti quando vado ad esportare l'FBX, sono gli unici che seguono il movimento della testa. Ho provato ad animare i loro gruppi tramite connessione di nodi e a re-imparentare i controllers alla testa, il bake dell'animazione continua a non funzionare. Come posso risolvere?

 

I cavi sono riggati tramite Control Vertex e splines

 

screenshot.jpg

Screenshot 2018-10-30 14.10.02.png

Screenshot 2018-10-30 15.02.32.png


Edited by Vash23

Share this post


Link to post
Share on other sites
4 ore fa, roberto2004 ha scritto:

non ho ben capito una cosa...in maya l'animazione ti funziona?

se si prova ad esportare in alembic che di solito non da nessun problema.

 

In Maya funziona ma non riesce ad esportarla

Share this post


Link to post
Share on other sites

Sei sicuro di aver messo il check nell´opzione bake animation, nelle impostazioni di esportazione in fbx?
Considerando che quei joints sono animati tramite connessione diretta, è necessario fare il bake delle loro trasformazioni.

Nel caso tu abbia già messo il check in quell´opzione e non funzioni, puoi provare ad eseguire il bake manualmente prima di esportare (menu EDIT - keys - bake simulation)

Ovviamente ricordati di salvare una nuova versione della scena prima del bake manuale, che romperebbe la connessione del rig.
Spero di esserti stato d´aiuto,

D

 

Share this post


Link to post
Share on other sites

Nope, rimangono fissi

 

Mi sembra sia un problema dello Skin Deformer. L'idea è che i tubi sono indipendenti dalla testa ma i 4 joints di collegamento tirano e spimngomo la mesh lungo la spline, questo non riesce a trasferirlo negli fbx

Share this post


Link to post
Share on other sites

Warning: skin deformation

 

The plug-in has found the following skin definition problems :

Unable to find the bind pose for : / cable_A_GRP. Use the DAG node current transform.

 

per tutti e 4 i tubi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x