Vai al contenuto
Logik

Logo su tazza

Recommended Posts

Salve, ho un problema che mi sta facendo impazzire, volevo posizionare un logo sulla tazza con il sub material Blend in multi/sub object però al momento dell'apertura del material/map browser il Blend non esiste, possiedo la versione di 3ds max 2018 probabile che sia stato sostituito con un altro materiale?

 

Chiedo sempre qui per un altro dubbio se posso, come si fa a esportare soltanto l'alfa (bianco e nero) di un immagine da photoshop?

 

Chiedo scusa per le domande ma sono un principiante su queste cose.

 

 

Immagine.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao logik, dallo screen vedo che hai associato diversi materiali alla tazza, l'ultimo, ID 3, è vuoto, lì dovresti metterci il tuo blend con la mask del logo. Spero di aver colto bene il tuo problema.

Per quanto riguarda photoshop, che intendi con esportare l'alfa di una immagine?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao,

non saprei dirti il perche non ti compare il materiale Blend(Standard) tra quelli disponibili, ma ti posso proporre un metodo per ottenere lo stesso risultato.

 

Come vedi dall'immagine che allego, io utilizzo Corona e non Vray, ma il principio è lo stesso solo che al posto di utilizzare il "CoronaLayeredMtl" tu dovrai utilizzare il VrayBlendMtl.

 

In pratica nel terzo slot del MultiMaterial assegni il VaryBlenMtl che avrà come Base Material il Materiale Esterno dello tazza e come primo Layer(Corona)/Coat(Vray) il Materiale Logo; alla fine inserisci nella Mask(Corona)/BlendAmount(Vray) la maschera alfa per "ritagliare" il logo. Ricordati di togliere la spunta su Tile dalle opzioni delle Bitmap e di applicare un modificatore UVWMap per aggiustare la posizione e dimensione del Logo sull'oggetto.

 

Per quanto riguarda il salvataggio della maschera da Photoshop, non ti so dire precisamente come fare perché utilizzo Afiinity Photo, ma la cosa più veloce è salvare direttamente l'immagine in un formato che supporti il canale alfa o la trasparenza, come il PNG o il TIFF, in questo modo in Max, o in qualsiasi altro programma, puoi direttamente decidere che canale utilizzare come maschera senza dover avere due file separati.

Ad esempio io sto usando lo stesso file ("fire_01.png") sia come Diffuse che come maschera per il ritaglio, ho cambiato solo i parametri che trovi dentro la Bitmap :

 

Mono Channel Output :  RGB Intensity per il Diffuse ; Alpha per la maschera

RGB Channel Output: RGB per il Diffuse; Alpha as Gray per la maschera

 

Spero di essere stato chiaro,

 

Ciao

 

Material.png

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
2 ore fa, SharkManBlu ha scritto:

Ciao,

non saprei dirti il perche non ti compare il materiale Blend(Standard) tra quelli disponibili, ma ti posso proporre un metodo per ottenere lo stesso risultato.

 

Come vedi dall'immagine che allego, io utilizzo Corona e non Vray, ma il principio è lo stesso solo che al posto di utilizzare il "CoronaLayeredMtl" tu dovrai utilizzare il VrayBlendMtl.

 

In pratica nel terzo slot del MultiMaterial assegni il VaryBlenMtl che avrà come Base Material il Materiale Esterno dello tazza e come primo Layer(Corona)/Coat(Vray) il Materiale Logo; alla fine inserisci nella Mask(Corona)/BlendAmount(Vray) la maschera alfa per "ritagliare" il logo. Ricordati di togliere la spunta su Tile dalle opzioni delle Bitmap e di applicare un modificatore UVWMap per aggiustare la posizione e dimensione del Logo sull'oggetto.

 

Per quanto riguarda il salvataggio della maschera da Photoshop, non ti so dire precisamente come fare perché utilizzo Afiinity Photo, ma la cosa più veloce è salvare direttamente l'immagine in un formato che supporti il canale alfa o la trasparenza, come il PNG o il TIFF, in questo modo in Max, o in qualsiasi altro programma, puoi direttamente decidere che canale utilizzare come maschera senza dover avere due file separati.

Ad esempio io sto usando lo stesso file ("fire_01.png") sia come Diffuse che come maschera per il ritaglio, ho cambiato solo i parametri che trovi dentro la Bitmap :

 

Mono Channel Output :  RGB Intensity per il Diffuse ; Alpha per la maschera

RGB Channel Output: RGB per il Diffuse; Alpha as Gray per la maschera

 

Spero di essere stato chiaro,

 

Ciao

 

Material.png

Intanto grazie per la spiegazione sei stato chiarissimo c'è solo un piccolo problemino, il vrayblendmtl compare in questo modo.

Per quanto riguarda Photoshop io creo la maschera facendo la selezione di quello che mi interessa, tasto destro "salva selezione" e da li mi crea la maschera sui canali, io salvavo l'immagine in formato TGA ma al momento di posizionare il logo non mi dava l'effetto trasparante ma come se ci fosse una platina bianca di sopra, forse un problema di settaggi del vrayBlend?

vray_blend.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ho provato a impostare il vrayblend mtl e sicuramente sto sbagliando qualcosa, sul base material ho messo il materiale esterno della tazza, su Coat materials il logo salvato con la maschera creata su photoshop in formata tiff e su Blend amount la stessa immagine però settata in Alpha e Alpha as Grey, come risultato mi compare il render così

prova2.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Il VrayBlend mi sembra impostato correttamente, punterei piuttosto il dito verso le impostazioni del materiale del logo, quindi prova a cambiarlo con un nuovo materiale Vray senza alcuna modifica o mappa applicata e vedi se ti da lo stesso problema.

 

Purtroppo come ti dicevo non posso essere più specifico non avendo Vray, ma il funzionamento di questo tipo di materiali è simile in molti, se non tutti, motori di render.

 

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sono riuscito a far comparire il logo del colore giusto e l'ho anche posizionato, però ho ancora il problema della trasparenza non riesco a capire il perché mi da lo sfondo con il colore originale dell'immagine, help pls.

22222.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Potresti fare questa prova giusto per capire dove si annida il problema: crea un nuovo piano ed applicagli un nuovo materiale ; al materiale assegni nello slot opacity la bitmap con la maschera alfa del logo.

Se la maschera è corretta dovresti vedere nel render (forse anche nella viewport, ma non ne sono certo) il piano "tagliato" rispetto alla maschera applicata (dove: bianco visibile, nero invisibile), quindi il problema è da ricercare nelle impostazioni del blend; al contrario se il piano non viene "tagliato" correttamente vuol dire che devi rivedere la maschera in photoshop o le impostazioni della bitmap in max.

 

In pratica devi riuscire ad isolare il problema scomponendo quanto fatto fino ad adesso in elementi più semplici e con meno variabili possibili...

 

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×