Vai al contenuto
marcatore

Fur, Maya 7 E Mr

Recommended Posts

vengo al dunque

ho una scena con un discreto polycount (circa 1.000.000)..non tante texture e non troppo ad alta risoluzione.

L'ambiente è un vigneto..giusto per capire.

Ho pensato di mettere sul terreno dell'erba..e visto che mr mi dà la possibilità di renderizzare il fur..ho utilizzato quello.

Ok..scena ha una luce direzionale con ombre raytracing e 3 nodi di ambient occlusion su vari materiali tra cui una sull'ambient del fur.

Ora la scena lavorata su un doppio athlon mp 2700 con 2 gb di ram viene "tranquillamente renderizzata" in 10 min occupandomi in batch render circa 1-1.2 gb di ram.

Per motivi vari devo portare la scena su altri pc...provo con il 2° pc che ho (athlon 64bit 3200 o qualcosa del genere con 1 gb di ram) e ci mette 2 ore!!!!!!!!

Allora...inizio a provarle tutte..

Tolgo tutte le vigne (i modelli + pesanti di tutto quanto) e lascio terreno e fur..e si renderizza...

Allora penso sia il polycount...allora..rimetto tutto...tolgo il fur e renderizza da dio.(in tempi assolutamente normali).

Tolgo l'ambient occlusion sul fur..nada..sempre render allucinanti.

In mr ho notato che quando si renderizza con il fur..c'è una fase iniziale "Calculating... press Esc..ecc..ecc.." che sembra essere dipendente dalla quantità di geometrie presenti nella scena..solo che questa cosa..sul doppio athlon è praticamente invisibile (cioè..praticamente + o - poligoni non si hanno sbalzi di tempo su questa fase)mentre sull'altro pc si passa dai 3 min con solo terreno +fur (unica geometria) ai 14 minuti con terreno+30 di pali+4 piante (il progetto avrà circa 50 di piante)+fur

QUalcuno di voi sa come controllare questa cosa...??

Qualche idea??

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

mi rispondo da solo..e ancora una volta...bestemmie all'alias x come integra mr..

ma io mi domando..ma se uso mr..xchè devono rimanere abilitate delle opzioni di maya software?? e sopratutto..xchè in fase di render continua a dare ascolto a settaggi che riguardano maya software??

in pratica..se usate fur con mr...dovete andare nei fur setting e disabilitare le prime due opzioni...

in pratica..infatti la prima opzione(che credo sia quella responsabile dell'aumento dei tempi in caso di aumento delle geometrie) è ,come da manuale, usata solo da maya software e dal modulo maya_fur .

Quindi in pratica..renderizzavo con mr..ma in realtà mi trovavo con un prepass del maya_fur come se usassi maya software..mannaggiaa a loro.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

in realtà disabilitando quell'opzione (su maya software) il fur non viene proprio composto (visto che viene renderizzato in layer tramite z-depth)

ma tu che versione di maya hai?

io ho appena fatto la prova con maya 7 e quell'opzione non ha nessun effetto sul render, sicuro di non aver cambiato niente altro?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

dagon...la cosa strana che ho visto dopo è che nelle cartelle relative al fur c'erano dei file che pesavano anche 200/300 mb..ora siccome sul secondo pc caricavo la scena via rete...e visto per esempio che nonostante abbia fatto il progetto mi devo ricaricare la texture usata per regolare la lunghezza del fur a mano, non vorrei che sul primo pc lui veda il percorso di quei file da 200/300mb e se li carica "al volo" (e cmq senza disabilitare quelle opzioni ci mette cmq 3 min circa) mentre sull'altra macchina forse deve rifarsi tutto..

boh ipotizzo io..

Cmq per fare un test..prova a fare una sfera poly, gli assegni un fur al volo e fai un render..poi ne fai un altro aumentando le suddivisioni della sfera a 100..e rilanci il render.

uso maya 7

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

sai che non ho capito bene il tuo test?

scusa è normale che la seconda venga più lenta, anche se renderizzi una sfera senza fur con 500 poligoni e poi una con 5 milioni di poligoni vedrai la differenza di tempi (deve per forza tradurre la geometria), ma questo è indipendente dal fur :huh:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

no no..ok dagon..certo...ma la differenza se provi non è nella traslation...in realtà prima c'è quella fase di "calculating ecc ecc" che diventa lunghissima...e quella non è traslation..

tanto che come ho scritto..disabilitando quell'opzione...ora renderizzo su entrameb le macchine con tempi normali..... e la fase di calculating che prima anche sul primo pc impiegava almeno 3/4 min..ora è istantanea.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ho appena fatto il test, ma non ho nessuna fase di precalc onestamente

ho provato con 20, con 100 e con 200 suddivisioni, con e senza le famose spunte

ma a te questa fase di precalc compare nel output windows? puoi postare le info?

stasi usando il batch?

io per ora ho sempre renderizzato da maya...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

questa fase di precalc compare in basso nella barra di stato diciamo di maya..vicino a alla command bar (spero di essere stato chiaro..i nomi non li ricordo bene) sotto alla timeline a sx.

cmq a me disabilitando quelle robe..parte subito..che devo dire..meglio se non ti dà problemi..

prova ora a prendere la sfera e a duplicarla un sacco di volte..in lungo e in largo...e non guardare i tempi di traslation che ovviamente si innalzano...controlla se prima della traslation ti fa sto precalc...

se non lo fa meglio..così...non so cosa sia successo allora..

boh

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ma il fatto è che questa fase di precalc dovrebbe comparire da qualche parte nell'output windows, oggi purtroppo non posso fare altre prove perché sono stretto coi tempi qui al lavoro :(

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

eh già...infatti dagon..ma in realtà anche usando come traslation la detailed messages non si nota nulla di strano all'inizio..e la cosa ancora + assurda è che in questa fase la CPU lavora al 10/20%... cmq..ripeto.. a me togliendo quel parametro le cose sno cambiate...anzi..rivoluzionate..direi...

cmq..certo..se hai tempo e voglia fai i test..altrimenti...se un giorno di capiterà...ricordati di sta cosa.. :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×