Vai al contenuto
grafico3DStudioMax

ottimizzare materiali vray

Recommended Posts

Inviata (modificato)

Guarda, a giudicare dal materiale e dalle sue impostazioni, e' roba da v-ray 1.5. 

Della qualita' delle offerte commerciali presenti sul mercato, purtroppo, non posso rispondere, ne' migliorare la situazione a monte.

Posso pero' suggerirti un modo (l'avevo gia' fatto, ma provo a spiegarmi meglio ora) per "recuperare" gli shader.

Se non sai scriptare (che aiuterebbe parecchio), la cosa piu' semplice da farsi e' aprire un materiale V-Ray nuovo nello slot a fianco di quello delle tende, e poi, per settaggi avanzati (quindi i due rollout "BRDF" e "Options") copiare IDENTICAMENTE le impostazioni dal materiale nuovo a quello vecchio.

Nel caso specifico, la discussione sulle caustiche e' nulla (il materiale ha opacita', non rifrazione), ma il rallentamento e' dovuto alla modalita' di calcolo dell'opacita' (appunto, come l'avevamo 12 anni fa...), che devi cambiare a "Stochastic".

Ricorda che le impostazioni di rendering devono rimanere al DEFAULT (cambia max AA e noise threshold soltanto.), o nulla di quel che ti scrivo si comportera' come dovrebbe.


Modificato da ChaosLele

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Potresti fare un 2sided material e impostare le tende in modo che non facciano ombre...magari non è proprio fantastica come soluzione ma spesso mi ha salvato giornate di calcolo.

Ovviamente faccio riferimento alle tende bianche ;)


Modificato da cobi82

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Il 15/4/2018 at 10:09 , ChaosLele ha scritto:

Guarda, a giudicare dal materiale e dalle sue impostazioni, e' roba da v-ray 1.5. 

Della qualita' delle offerte commerciali presenti sul mercato, purtroppo, non posso rispondere, ne' migliorare la situazione a monte.

Posso pero' suggerirti un modo (l'avevo gia' fatto, ma provo a spiegarmi meglio ora) per "recuperare" gli shader.

Se non sai scriptare (che aiuterebbe parecchio), la cosa piu' semplice da farsi e' aprire un materiale V-Ray nuovo nello slot a fianco di quello delle tende, e poi, per settaggi avanzati (quindi i due rollout "BRDF" e "Options") copiare IDENTICAMENTE le impostazioni dal materiale nuovo a quello vecchio.

Nel caso specifico, la discussione sulle caustiche e' nulla (il materiale ha opacita', non rifrazione), ma il rallentamento e' dovuto alla modalita' di calcolo dell'opacita' (appunto, come l'avevamo 12 anni fa...), che devi cambiare a "Stochastic".

Ricorda che le impostazioni di rendering devono rimanere al DEFAULT (cambia max AA e noise threshold soltanto.), o nulla di quel che ti scrivo si comportera' come dovrebbe.

 

 

Ho creato un nuovo materiale copiando quello delle tende originali e impostando : Stochastic nell' opacità dei materiali, il rendering adesso lo fa anche se i tempi sono comunque molto alti, ben 54 minuti con le tende e 30 senza, con le tende noto anche macchie da global illumination.

Togliendo il mobile vicino alle tende si vede parte della tenda che compenetra il muro, ho provato a tagliarla con lo slice plan ma 3DS diventa lentissimo, inizia a calcolare e non finisce più, quindi ho dovuto desistere.:(

tende-nuove 54 minuti.jpg

tende-nuove 30 minuti.jpg


Modificato da grafico3DStudioMax

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
9 minuti fa, ChaosLele ha scritto:

vedo macchie nel render con le tende.

Non starai per caso usando IRMap?

beh, è una parete spugnata!!!! costa anche di più a mq.!! ed anche di materiale, base di pittura al quarzo e spugnatura!!!:P:P


Modificato da zatta 3d

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Bah, cmq sia con le tende, ma soprattutto senza la tenda centrale, i tempi di 30 minuti, mi sembrano veramente eccessivi, avendo oltretutto quel noise, di fatto la scena è pressochè override, con 4 cores, (non mi ricordo se hai 6700k o 7700k...) dovrebbe saltar fuori questi draft, forse in una decina di minuti...


Modificato da zatta 3d

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
27 minutes ago, grafico3DStudioMax said:

 

Ho usato gli stessi parametri lightcache + irradiance map

Tendo a scrivere precisamente quel che intendo, in particolar modo quando sto risolvendo problemi tecnici: se non ci capiamo sul linguaggio, non saro' mai in grado di aiutarti.

Quote

 

DEFAULT (cambia max AA e noise threshold soltanto.)

 

Rileggi, e riprova. ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

quoto in pieno Lele, perchè se resetti vray, e rimetti gli stessi settaggi, tanto vale!!! ma vedo che siamo agli stessi discorsi di inizio di questa discussione!!!

il reset di vray, viene eseguito per portare tutto a nuovo, sulla nuova release, perchè settaggi, varie impostazioni si sono tramandate col tempo e con le vecchie programmazioni di vray. questo è il punto principale e la prima operazione da eseguire, in secondo luogo iniziare a modificare un settaggio alla volta con ragione di causa e non a cazzum, e man mano valutare e trovare i compromessi e velocità!!! ad esempio con un buon Sample rate, che lo si può avere per la maggiore dalla modifica di AA, si hanno addirittura tempi inferiori in render e miglior risultato (provare per credere)!!!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

in aggiunta usare le nuove procedure di Vray, perchè non usare le subdivion automatiche di materiali e luci e provare le differenze, alzando sostanzialmente solo il min shading rate? che per la dirla tutta sulle vecchie release era impostato a 2, ora di default è impostato a 6, ma mantenendo i materiali e luci con le impostazioni vecchie di subdivion, il render è più pesante di sicuro!!!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
39 minuti fa, ChaosLele ha scritto:

Tendo a scrivere precisamente quel che intendo, in particolar modo quando sto risolvendo problemi tecnici: se non ci capiamo sul linguaggio, non saro' mai in grado di aiutarti.

Rileggi, e riprova. ;)

 

Ho aperto una nuova scena, ridotto solo l' aliasing a 1 : 10, tempo di rendering 1 minuto ma si vede buio ed è tutto sballato, non ho mai usato brute force, devo ricalibrare tutte le vray camere, l' illuminazione ?

tende-nuove-brute force+lightcache 1minutoi.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Perche' aprire una nuova scena?

Cosi' se avevi effetti (tipo, ad esempio, l'esposizione) li perdi.

Il reset di V-Ray si fa a scena aperta, passando a Scanline, e di nuovo a V-Ray.

L'esposizione (a meno usassi l'automatica, e allora e' un checkbox) non e' definita li'.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
3 minuti fa, ChaosLele ha scritto:

Perche' aprire una nuova scena?

Cosi' se avevi effetti (tipo, ad esempio, l'esposizione) li perdi.

Il reset di V-Ray si fa a scena aperta, passando a Scanline, e di nuovo a V-Ray.

L'esposizione (a meno usassi l'automatica, e allora e' un checkbox) non e' definita li'.

 

Ok, allora ho capito male, dopo provo a fare come hai detto.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
18 ore fa, ChaosLele ha scritto:

Perche' aprire una nuova scena?

Cosi' se avevi effetti (tipo, ad esempio, l'esposizione) li perdi.

Il reset di V-Ray si fa a scena aperta, passando a Scanline, e di nuovo a V-Ray.

L'esposizione (a meno usassi l'automatica, e allora e' un checkbox) non e' definita li'.

 

Ciao, ho fatto come dici, viene cosi' ho abbassato solo antialiasing a 1 : 8 e aumentato la memoria a 25.000

specifico che sto utilizzando delle vecchie Vray-camere e non le Physical camere.

tende-nuove 1 minuto.jpg

 

test fatto con la Physical camera di default :

tende-nuove 1 minuto e 13.jpg


Modificato da grafico3DStudioMax

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Mi sa che facciamo prima se mi mandi la scena qui sopra (pre-reset, idealmente.), con le texture/asset necessari (archiviala), a emanuele.lecchi@chaosgroup.com

Potro' poi vedere che problema c'e', e suggerire -spero- soluzioni.

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Il problema di fondo è sempre quello: importare e mergiare scene ed elementi diversi acquistati, scaricati, chissà. Partendo spesso da scene preimpostate, ritrovandosi con 1000 problemi diversi e tempi assurdi. Ogni volta a chiedere il perché, senza mai seguire i consigli dati perché studiare costa troppa fatica. E la cosa peggiore? Consigliare agli altri lo stesso sistema con la classica frase "comprati scene e modelli fatti meglio". @zatta 3d e @ChaosLele , capisco che in un forum bisogna aiutare, ma qua siamo al ridicolo...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
1 ora fa, Manuel84 ha scritto:

Il problema di fondo è sempre quello: importare e mergiare scene ed elementi diversi acquistati, scaricati, chissà. Partendo spesso da scene preimpostate, ritrovandosi con 1000 problemi diversi e tempi assurdi. Ogni volta a chiedere il perché, senza mai seguire i consigli dati perché studiare costa troppa fatica. E la cosa peggiore? Consigliare agli altri lo stesso sistema con la classica frase "comprati scene e modelli fatti meglio". @zatta 3d e @ChaosLele , capisco che in un forum bisogna aiutare, ma qua siamo al ridicolo...

 

Ma qualcuno ti ha chiesto qualcosa ? Se ti danno cosi' fastidio i miei post mettimi in ignore list, questa tua member war nei miei confronti ha proprio rotto, a ogni post che apro devi intervenire solo per dar fastidio e creare flames.

Seganalo.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Invito @Manuel84 e @grafico3DStudioMax ad ignorarsi a vicenda grazie.

 

@Manuel84: Non è la prima volta che ti chiedo di ignorare i post di @grafico3DStudioMax. Se non ti piace il suo modo di fare sei pregato semplicemente di ignorarlo. Il forum è pubblico e chiunque può avere la possibilità di scrivere e portare avanti i lavori come vuole.

 

@grafico3DStudioMax: Non è la prima volta che ti fanno notare (non solo Manuel) che fai delle domande per avere aiuto ma poi procedi sulla tua strada senza ascoltare i consigli che ti vengono dati. Questa cosa alla lunga irrita le persone che cercano di aiutarti. Cerca di farci più attenzione.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

 ahhhhh vedo che sta andando bene questa discussione ,

che avevo già prontamente abbandonato sapendo che il risultato sarebbe stato questo.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
31 minuti fa, D@ve ha scritto:

Invito @Manuel84 e @grafico3DStudioMax ad ignorarsi a vicenda grazie.

 

@Manuel84: Non è la prima volta che ti chiedo di ignorare i post di @grafico3DStudioMax. Se non ti piace il suo modo di fare sei pregato semplicemente di ignorarlo. Il forum è pubblico e chiunque può avere la possibilità di scrivere e portare avanti i lavori come vuole.

 

@grafico3DStudioMax: Non è la prima volta che ti fanno notare (non solo Manuel) che fai delle domande per avere aiuto ma poi procedi sulla tua strada senza ascoltare i consigli che ti vengono dati. Questa cosa alla lunga irrita le persone che cercano di aiutarti. Cerca di farci più attenzione.

 

Ok, comunque sto seguendo i consigli di Chaos Lele, non è che vado per la mia strada, ma spesso non è facile capirsi via forum, poi ognuno ha i suoi metodi di lavoro e non è che posso stravolgere tutto ogni volta, ho resettato Vray come detto da Chaos Lele ma purtroppo ho sempre usato irradiance map + light cache, Brute force non l' ho mai usato per via dei tempi di rendering, ho fatto una prova ed è venuto cosi'

Aggiungo che come tutti devo anche lavorare quindi rispondo quando mi è posibile, nei miei post mi pare di aver sempre ringraziato.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
2 minuti fa, deam ha scritto:

 ahhhhh vedo che sta andando bene questa discussione ,

che avevo già prontamente abbandonato sapendo che il risultato sarebbe stato questo.

Aggiorna vray :D, a no non può...

 

Ecco ora è completa

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ahia, scusatemi per la parte mia.

Ero serio, e serenissimo, quando dicevo che forse e' meglio spedirmi la scena.

Se poi in allegato mi mandassi info sulla versione di V-Ray che stai usando, mi faciliteresti non poco le cose.

Tranquillo che non faccio il poliziotto. ;)

Al netto delle soluzioni, il dibattito potrebbe comunque giovare piu' universalmente, quindi credo sarebbe bene concluderlo, altrimenti sarebbe tutto stato per nulla.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
1 minuto fa, ChaosLele ha scritto:

Ahia, scusatemi per la parte mia.

Ero serio, e serenissimo, quando dicevo che forse e' meglio spedirmi la scena.

Se poi in allegato mi mandassi info sulla versione di V-Ray che stai usando, mi faciliteresti non poco le cose.

Tranquillo che non faccio il poliziotto. ;)

Al netto delle soluzioni, il dibattito potrebbe comunque giovare piu' universalmente, quindi credo sarebbe bene concluderlo, altrimenti sarebbe tutto stato per nulla.

hai fatto benissimo a chiedere la scena, capita a volte nel forum che, quando non si riesce a risolvere attraverso la discussione ci si passa la scena, ove possibile, non sempre lo è.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
1 minute ago, zatta 3d said:

hai fatto benissimo a chiedere la scena, capita a volte nel forum che, quando non si riesce a risolvere attraverso la discussione ci si passa la scena, ove possibile, non sempre lo è.

Bene specificare, ovviamente, grazie dell'alzata!

Qualunque materiale in arrivo su *@chaosgroup.com e' automaticamente coperto da NDA (Non-Disclosure Agreement, o riservatezza completa.).

Vi fosse bisogno, siamo in grado di firmare qualunque cosa (mutui, prestiti, matrimoni...) in piu' servisse.

In casi estremi, possiamo pure venirvi a casa in ufficio, ecco (vivo in Italia, e faccio bruttissimo col mio metro e trentacinque anche per starvi logisticamente vicino.).

 

 

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×