Vai al contenuto
UmbertoA

Mental Ray - oggetto totalmente nero

Recommended Posts

Ciao ragazzi, sono nuovissimo qua dentro. Ho appena fatto un piccolo upgrade hardware e ho ripreso a studiacchiare un po' per passione e un po' per curiosità il 3D con 3D studio max!

 

Dopo una giornata a cercare di risolvere problemi di impostazioni per luci, mapping, fluidi, path e cose varie, finalmente sono quasi riuscito a ultimare il set per renderizzare una piccola animazione ma... ho un problema. In fase di rendering uno degli oggetti (la tazza) risulta totalmente nero. Non so più che fare. Ho provato a ricreare il materiale, a spostare la luce ma, ovunque lo metta, l'oggetto appare nero... qualche idea su come risolvere il problema? Vi allego una una immagine per rendere l'idea.

3dmax 2018, Mental ray, mr. sun e mr.sky

 

Grazie in anticipo e.. boh... se vi servono informazioni chiedete pure :) 

Senza titolo-1.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Controlla non ci siano Vertex Map applicate al modello, specialmente se è importato.. o che non ci sia una texture "nera" applicata a un UV sballata.. (perché magari ti cerca una texture che non c'è e la carica completamente nera).

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Il modello è fatto direttamente su 3ds, e non ci sono texture applicate, solo un materiale, con colore piatto (bianco, per altro)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Va bene, allora, intanto perdonate il mio linguaggio poco tecnico ma.. davvero, ho ripreso solo oggi, dopo anni, ad utilizzare 3Ds, non ricordavo neanche come si mettesse l'ambient occlusion...

Ma ad ogni modo. Il materiale è preso (come gli altri) dall'elenco Arch and Design dei mental ray, (niente di anomalo o non so cosa) ed è una plastica matta color bianco. se mi chiedi shot dell'oggetto... ahah non so cosa risponderti, mi dispiace. Non ho idea di cosa sia... non linciatemi :lol:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Hahahahahahah non m isono spiegato bene :D Allora se l'oggetto è tutto nero i fattori possono essere molteplici. Ti chiedevo una immagine dell'area di lavoro con il solo oggetto e i suoi parametri in edit poly ecc. Mi appare strana sta cosa.. Hai utilizzato un mod lathe per la ciotola?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Bho, a vederlo cosi mi sembra che ci siano problemi di normal... Se ti è possibile, puoi allegare il modello della ciotola in formato .obj? lo vorrei controllare e non avendo max20018, lo apro in Blender per vedere se tutto è ok. Altrimenti ho max2016...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Allora, forse ho trovato il problema. Ho provato a cancellare la superficie interna della tazza e l'oggetto si va via via illuminando. Quindi a sto punto presumo sia un problema legato alla costruzione di base

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Va bene. Non so cosa sia successo o perché ci fosse quel problema ma, fatto sta che una volta eliminati tutti i poligoni della superficie interna, l'oggetto si è illuminato su quella parte, rimanendo oscurato all'esterno. A quel punto ho invertito le normal e adesso si vede per come si deve vedere. Tanto meglio! ma.. a sto punto, dato che ci sono... avete consigli per settare un render di buona qualità (non ULTRAGIGAMASTERRACE) per un video di 10 secondi circa?  

Ad ogni modo vi ringrazio infinitamente per l'aiuto!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×