Vai al contenuto
Angmar94

Superfici non visualizzate

Recommended Posts

Inviata (modificato)

Salve, sono alle prime armi con 3ds max e sono incappato in questo problema. Ho modellato in Autocad e importato in 3ds. Come si vede dall'immagine alcune parti delle volte non vengono visualizzate nonostante ci siano. Se può aiutare aggiungo che se metto in wireframe e con ctrl+a seleziono tutti gli spicchi delle volte, le parti difettose appaiono opache, come se ci fosse una superficie sotto. Ho visto anche in altre discussioni ma sembra che nulla corrisponda al mio problema. Vi sarei grato per l'aiuto.

prova.jpg


Modificato da Angmar94

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao,

Non capisco se il problema si presenta solo in fase di render o anche in viewport,

comunque quasi sicuramente è un problema di normali.

 

Fai questa prova veloce:

 

Seleziona tutti gli oggetti, clicca con il tasto destro del mouse  e seleziona Object Properties dal menu;

da questo pannello,nel tab in basso a sinistra "Display Properties", clicca sopra "By Layer" in modo che cambi in "By Object" (se non è gia impostato cosi).

Adesso dovresti poter mettere o togliere le spunte sulle varie voci, quella che ti interessa è "Backface Cull"; togli la spunta da questa voce ed una volta dato "OK" dovresti visualizzare correttamente nella viewport la geometria.

Apri il "Render Setup" (tasto F10 sulla tastiera), nella prima tab "Common" trova la voce "Force 2-Sided" In "Option" e assicurati che ci sia la spunta, prova a fare un render e dovresti vedere anche le volte che prima non vedevi.

 

Questa procedura è più un workaround che una soluzione vera e propria, ma così facendo si riesce a capire dov'è il problema.

 

Se funziona fammelo sapere che ti spiego come risolvere la questione a livello di geometria vera e propria.

 

Ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ok ho seguito la procedura e in parte il problema è risolto. In viewport continuano ad esserci le parti mancanti ma il render è completo, e questo è quello che conta. Grazie mille! :D

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao,

strano che in viewport non le visualizzi, sei sicuro che non ci sia la spunta su "Backface Cull" sugli oggetti che non vedi ?

 

Ad ogni modo come ti dicevo prima questo è solo un palliativo, nel senso che avere dei poligoni con le normali sbagliate puo dare grossi problemi in fase di render, anche con l'opzione "Force 2-Sided" attivata, quindi ti consiglio di sistemare la geometria.

 

Di seguito degli screen veloci per spiegarti come fare.

In questo caso il cubo l'ho convertito in un "Editable Mesh" ma il concetto è lo stesso anche con un "Editable Poly".

 

01: l'oggetto di partenza, un banale cubo

01.PNG.f19247e308e64dec7e6711fe4c63613c.PNG

 

02. Qua ho fatto in modo da avere una faccia/poligono con la normale ribaltata e con la proprietà Backface Cull attiva

02.PNG.42bd217b205d5065b22c62ad8ad2bcf5.PNG

 

03. Selezionando la faccia/poligono sbagliata/o e cliccando su "Flip" le normali di quella faccia vengono ribaltate e si ritorna a visualizzare correttamente il box.

03.PNG.a4b7a17f1e713907277638c3ba80fbb5.PNG

 

04. Bonus : Puoi provare ad usare il modificatore "Normal" e giocare con le due opzioni. In questo caso ho disattivato "Flip Normal" e attivato "Unify Normal". Per esperienza non sempre funziona, soprattutto su oggetti con molti poligoni, quindi, quando mi capita, preferisco ribaltare le normali a mano.

04.PNG.e2245321dcf0cb9ad2797ee189daf1a4.PNG

 

 

Spero sia tutto chiaro, nel caso non lo fosse non esitare a scrivere.

 

Ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Ti ringrazio per questo ulteriore aiuto anche se alla fine il problema non si è risolto, Ma, ripeto, quello che conta è il render. Ora però avrei un altro problema che non c'entra nulla con questo, ma mi sembrava inutile aprire un'altra discussione. In pratica nel render, il bianco mi appare grigio, solo però sulle superfici verticali interne. Che sia un problema di luci?


Modificato da Angmar94

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Strano che non si risolva cosi la faccenda delle superfici non visualizzate... se puoi manda il file (anche solo un pezzo ) cosi provo a capire cosa c'è che non va!

 

Per quanto riguarda il bianco che appare grigio nel render non avendo idea di che motore di render usi e come sono impostati i materiali, le luci e quant'altro, non saprei dirti come migliorare la situazione...

 

Ti consiglio quindi di postare alcune immagini, cosi possiamo provare a darti qualche dritta

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Come motore di render uso quello di default di 3dsmax. Come si vede nell'immagine sulle volte il bianco si vede. Il problema è nella parte interna delle pareti (quelle sotto le volte per intenderci).

prova 2.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ad occhio noto queste cose :

- Sembra non ci siano luci nella scena ( nessuna ombra "realistica" ) se non quelle di default

- alcune volte hanno problemi di ombreggiatura, penso dovuto ad un problema di geometria più che di render

- i muri interni grigi sembra che facciano parte della geometria dei muri esterni e quindi con lo stesso materiale più scuro rispetto alle volte

 

Ad ogni modo, come ho detto prima, senza ulteriori dettagli su materiali, luci, geometria ecc.. non è facile dirti di più

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Per le pareti interne ho selezionato solamente la faccia non tutto l'elemento. Infatti vorrei mantere le facce esterne in grigio e quelle interne in bianco. Come materiale ho usato una texture bianca, la stessa che ho usato per le volte, senza modificare nessun parametro.

Non ho impostato luci.

 


Modificato da Angmar94

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao,

 

per le luci puoi guardare questo tutorial :https://www.youtube.com/watch?v=ehlYU2bGIXs . Tratta l'illuminazione di esterni con il motore di render "Sanline Renderer", quello che stai usando tu adesso.

 

Per le pareti questo : https://www.youtube.com/watch?v=34C-4BS9kE4 . Il "Multi/Sub-Object Shader" permette di applicare su una unica geometria diversi materiali, proprio quello che stai cercando di fare tu con i muri.

 

Comunque permettimi di consigliarti un corso, anche base, di 3dsMax o almeno segui i video tutorial del canale Autodesk che, tutto sommato, danno una buona infarinatura sulla materia. 

 

 

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Il 8/7/2017 at 20:39 , SharkManBlu ha scritto:

Ciao,

 

per le luci puoi guardare questo tutorial :https://www.youtube.com/watch?v=ehlYU2bGIXs . Tratta l'illuminazione di esterni con il motore di render "Sanline Renderer", quello che stai usando tu adesso.

 

Per le pareti questo : https://www.youtube.com/watch?v=34C-4BS9kE4 . Il "Multi/Sub-Object Shader" permette di applicare su una unica geometria diversi materiali, proprio quello che stai cercando di fare tu con i muri.

 

Comunque permettimi di consigliarti un corso, anche base, di 3dsMax o almeno segui i video tutorial del canale Autodesk che, tutto sommato, danno una buona infarinatura sulla materia. 

 

 

 

 

Anche io consiglio di fare almeno un corso base di 3DStudio, imparare tutto da soli è davvero arduo, poi per poter seguire quei corsi su youtube devi sapere bene l' inglese, basta perdere un passaggio e non riesci più a far niente, scanline è un motore di rendering obsoleto, io consiglio Vray, che a parte essere decisamente migliore ha anche molti materiali, modelli 3d ecc. reperibili in rete. ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×