Vai al contenuto
Elisatreddi

Ombre troppo scure

Recommended Posts

Ciao a tutti! È la prima volta che scrivo su questo forum, e non ho ancora molta esperienza con 3Ds Max, quindi perdonate eventuali errori dovuti all'ignoranza.

Sto realizzando il render di un appartamento con illuminazione artificiale data da photometric lights, e sto avendo alcuni problemi di luminosità dell'ambiente, in particolare le ombre sotto il tavolo appaiono troppo scure. Inizialmente pensavo potesse trattarsi di un problema di materiale delle pareti, ho quindi alzato il value del diffuse in modo che riflettessero più luce, ma non è cambiato nulla. Ho quindi cambiato l'apparecchio di illuminazione posto sopra il tavolo con lampade con solidi fotometrici che emettessero una luce più diffusa, e non solo verso il basso (ad esempio di forma sferica), ma ancora non è cambiato nulla. Ora non so davvero più cosa cambiare, help!!

Allego il render iniziale render 1.tif e un paio di prove successive con le modifiche che ho scritto sopra render glo-ball.tifrender vol.tif

Grazie in anticipo!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

dunque premetto che non sono una cima, ma provo a vedere se riesco ad aiutare,

dovresti darmi qualche indicazione sui settaggi della GI che hai usato... in genere con una luce fotometrica e final gathering e photon mapping attivi non dovresti avere ombre così scure. Stai usando una physical camera?

Comunque secondo me il prolema non è legato ai materiali. Solo il lampadario mi lascia il dubbio hai usato un materiale con self illumination?

potresti anche guardare nei parametri di image control nella finestra dell'environment per chiarire e scurire le ombre.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Figurati ogni aiuto è ben accetto, sicuramente te la cavi meglio di me!

Nell Photon Mapping della GI ho messo:

max num photons per sample: 10000

Radius: 25,0 cm

Light Properties: 

average gi photons per light: 8000000

Trace Depht:

10, 10, 10

Ho attivato all objects generate and receive GI and Caustics

E il final gathering non l'ho attivato perchè il mio prof non vuole che lo usiamo, in quanto "corregge" gli errori e non è realistico. 

Inoltre sto usando una physical camera con aperture: f/2, shutter duration 1/20 e iso 800.

Per la lampada ho usato all'interno un materiale con self illumination (sempre da indicazioni del prof) e all'esterno un materiale trasparente.

Dici che non è un problema del materiale? Perchè ora ho aumentato la reflection e la situazione sembra leggermente migliorata, ma non so se sia corretto questo procedimento. prova.tif

Ti servono altre info?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ah anche per quanto riguarda l'image control nel pannello environment in teoria il mio prof vorrebbe che non toccassi nulla, dato che lo considera falsare la realtà in un certo senso...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ma la stanza non ha finestre? Potresti mettere un'area light nella corrispondenza della finestra(non so se in 3dsmax si chiama così).

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

mmm... 

Se volessi un risultato 'realistico' nel senso più vicino al termine, probabilmente non utilizzeresti mentalray e la GI ma iray, l'uso della sola GI appiattisce il rendering senza contare che l'FG attiva in automatico l'eventuale calcolo di una skylight, se ci fosse, rendendolo indispensabile. Non sindaco le indicazioni del prof, magari vuol far padroneggiare meglio la GI.

I materiali non c'entrano nulla con la 'potenza' della luce indiretta, ovvio che più chiari e riflettenti più spargono luminosità ma quando utilizzi la sola GI o la GI+FG (che ti consiglio caldamente di testare) è il solo valore di potenza della GI a determinare la 'quantità' di luce indiretta, per cui dovrai aumentare il multiplier della photon mapping per illuminare maggiormente sotto il tavolo. Come sempre, la cosa migliore è sparare il multiplier a 100 se non l'hai mai toccato così vedi subito se e come funziona, una volta accertata la 'reazione'(che faccia qualcosa) cerchi il valore più idoneo.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
25 minutes ago, Elisatreddi said:

Ah anche per quanto riguarda l'image control nel pannello environment in teoria il mio prof vorrebbe che non toccassi nulla, dato che lo considera falsare la realtà in un certo senso...

Anche qui può prevalere la volontà di semplificare le cose per velocità e comodità, usando i valori di default, ma l'esposizione è il cuore di qualsiasi rendering, per cercare risultati sofisticati sarà necessario toccarli eccome i valori dell'image control.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Le ombre sono definite dalle luci più che dai materiali, quindi renderli troppo riflettenti credo sia un po come falsare la realtà... nei materiali però abiliterei l'ambient occlusion.

Per alleggerire le ombre prova ad aumentare gli iso della camera e togli temporaneamente il lampadario per verificare che non ci siano ostruzioni alla luce da parte dei materiali... poi abbasserei un po' i max num photons per sample e average gi photons per light, mi sembrano troppo alti, soprattutto per dei render di prova.

Ombre così intense si potrebbero anche lavorare dal menu del manual setting delle luci nella finestra mental ray indirect illumination, dovresti disabilitare i settaggi automatici e lavorare con quelli manuali aumentando i fotoni e l'energia della sorgente luminosa...

Sto procedendo per tentativi...

 

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
7 ore fa, widar ha scritto:

 

Ma la stanza non ha finestre? Potresti mettere un'area light nella corrispondenza della finestra(non so se in 3dsmax si chiama così).

 

Mmh c'è solo l'illuminazione artificiale, niente luce solare, quindi non avrebbe senso dato che non entra luce dalle finestre :mellow:

 

7 ore fa, Gattotondo ha scritto:

mmm... 

Se volessi un risultato 'realistico' nel senso più vicino al termine, probabilmente non utilizzeresti mentalray e la GI ma iray, l'uso della sola GI appiattisce il rendering senza contare che l'FG attiva in automatico l'eventuale calcolo di una skylight, se ci fosse, rendendolo indispensabile. Non sindaco le indicazioni del prof, magari vuol far padroneggiare meglio la GI.

I materiali non c'entrano nulla con la 'potenza' della luce indiretta, ovvio che più chiari e riflettenti più spargono luminosità ma quando utilizzi la sola GI o la GI+FG (che ti consiglio caldamente di testare) è il solo valore di potenza della GI a determinare la 'quantità' di luce indiretta, per cui dovrai aumentare il multiplier della photon mapping per illuminare maggiormente sotto il tavolo. Come sempre, la cosa migliore è sparare il multiplier a 100 se non l'hai mai toccato così vedi subito se e come funziona, una volta accertata la 'reazione'(che faccia qualcosa) cerchi il valore più idoneo.

Purtroppo non posso scegliere il motore di rendering, ci è stato imposto mental ray :( e si credo anch'io che aumentare la riflessione non sia il modo corretto di risolvere il problema, deve essere la luce, però anche il multiplier è una cosa che secondo il mio prof non andrebbe toccata... Con tutte queste imposizioni è difficile risolvere i problemi, ma secondo lui è l'unico modo per ottenere un risultato realistico. Altre idee su cosa potrei stare sbagliando? :mellow:

 

5 ore fa, jayna ha scritto:

Le ombre sono definite dalle luci più che dai materiali, quindi renderli troppo riflettenti credo sia un po come falsare la realtà... nei materiali però abiliterei l'ambient occlusion.

Per alleggerire le ombre prova ad aumentare gli iso della camera e togli temporaneamente il lampadario per verificare che non ci siano ostruzioni alla luce da parte dei materiali... poi abbasserei un po' i max num photons per sample e average gi photons per light, mi sembrano troppo alti, soprattutto per dei render di prova.

Ombre così intense si potrebbero anche lavorare dal menu del manual setting delle luci nella finestra mental ray indirect illumination, dovresti disabilitare i settaggi automatici e lavorare con quelli manuali aumentando i fotoni e l'energia della sorgente luminosa...

Sto procedendo per tentativi...

 

Si hai ragione, diminuirò la riflessione... non conosco l'ambient occlusion, di cosa si tratta? 

Il lampadario non dovrebbe dare alcun fastidio perchè ho usato exclude nei parametri della target light. Per quanto riguarda il numero di fotoni è molto alto perchè in realtà sono quelli usati anche per il render finale, in alta risoluzione.

Per quanto riguarda mental ray indirect illumination, questo è un'altro dei paramentri che ci ha raccomandato di tenere su 1, 1, 1 con automatically calculate energy and photons. Io davvero non so cosa cambiare, praticamente non possiamo toccare niente. L'errore deve essere da qualche altra parte :crying:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
47 minutes ago, Elisatreddi said:

Purtroppo non posso scegliere il motore di rendering, ci è stato imposto mental ray :( e si credo anch'io che aumentare la riflessione non sia il modo corretto di risolvere il problema, deve essere la luce, però anche il multiplier è una cosa che secondo il mio prof non andrebbe toccata... Con tutte queste imposizioni è difficile risolvere i problemi, ma secondo lui è l'unico modo per ottenere un risultato realistico. Altre idee su cosa potrei stare sbagliando? :mellow:

Avevo capito che non potevate scegliere il motore di rendering, suggerivo solo che nella ricerca del 'realistico' di certo i soli fotoni sono quanto di più lontano nell'ottenerlo. E non mi pare proprio sia colpa del povero mentalray se non potete toccare nessun valore... Se non puoi toccare il multiplier generale o l'energy della singola luce, se non puoi toccare l'image control, puoi solo agire sulla potenza della luce diretta della lampadina e sull'esposizione generale (aperture, shutter, ISO). L'unica nota positiva è che a forza di non poter toccare nulla ti ricorderai dannatamente bene tutti i parametri che non hai potuto toccare!!! :D

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×