Jump to content
bn-top

Stanza Jap


Magma3D
 Share

Recommended Posts

Ragazzi... mi son rimesso un pò sulla stanza jap di dagon per tirargli fuori un rendering decente....

Tutto è nato da questa discussione:

http://www.treddi.com/forum/index.php?showtopic=11563&st=0

ora ero arrivato nel regolare il dgs e nell'iniziare a mettere qualche shader questo è quanto:

non fate caso alla qualità... ho messo tutti valori bassi per velocizzare il rendering

stanza4.jpg

e questo con qualche mat messo cosi di fretta:

stanzamat.jpg

ora prima di tutto.....

1) com'è possibile duplicare uno shader in modo che contenga anche tutti gli altri nodi connessi??

ho provato un pò tutte le opzioni di duplicazione degli shader stessi ma gli altri nodi non ci sono più e quindi mi è toccato rifare ogni shader da 0!

2) poi quel bagliore ancora non riesco ad attenuarlo maledizione!

3) se metto un file texture al dsg maya mi restituisce questo errore

// Error: (Mayatomr.Output) : file error: D:/3D/Maya/Documenti/Stanza Jap/texture/wood04.jpg //

anche se poi la text va bene ugualmente

4) Importantissimo.... vi capita qualche volta quando fate partire un render in MR faccia come 2 render... (mi è capitato quando facevo dei render region ) questo proprio non lo capisco!

aiutatemi please! :crying:

Link to comment
Share on other sites

bn-top

Per la prima domanda ho risolto.... devi selezionare il nodo SG dello shader per farti mantenere tutti gli altri nodi quando fai la duplicazione dello shading network.....

P.S. per la 4° domanda non confondete il pass del calcolo del fg heheh io intendo un vero e proprio rendering (meglio precisare)

Link to comment
Share on other sites

il bagliore credo sia dovuto al rimbalzo della luce sotto il tavolo, per attenuarlo puoi fare due cose: diminuire l'irradianza del tavolo o usare lo scale del fg per attenuare l'intensità del primo rmbalzo

per il problema alle texture viene fuori anche a me e non ho capito a cosa sia dovuto

per il punto 4 credo sia un bug di maya, capita anche a me, sempre però sul primo render fatto subito dopo aver aperto maya... per stare sicuro il primo render lo faccio sempre in piccolo o con valori bassi... è una scocciatura niente male

Link to comment
Share on other sites

il bagliore credo sia dovuto al rimbalzo della luce sotto il tavolo, per  attenuarlo puoi fare due cose: diminuire l'irradianza del tavolo o usare lo scale del fg per attenuare l'intensità del primo rmbalzo

per il problema alle texture viene fuori anche a me e non ho capito a cosa sia dovuto

per il punto 4 credo sia un bug di maya, capita anche a me, sempre però sul primo render fatto subito dopo aver aperto maya... per stare sicuro il primo render lo faccio sempre in piccolo o con valori bassi... è una scocciatura niente male

Grazie Dagon menomale che ci 6 te che rispondi.... non sapevo dell'utilità dello scale del FG finchè non me l'hai detto ora.... appena posso proverò quello che mi hai detto.

per il bug... e già una bella scocciatura alla grande.... se uno si dimentica si ritrova con un render che dura il doppio e se ne accorge solo dopo

Cmq grazie come al solito!

Già che ci sono non è che ti capita anche che usando le point light delle volte ti segnala che non trova un nodo delle stesse?

Ciao!!! :hello:

Link to comment
Share on other sites

Grazie Dagon menomale che ci 6 te che rispondi.... non sapevo dell'utilità dello scale del FG finchè non me l'hai detto ora.... appena posso proverò quello che mi hai detto.

per il bug... e già una bella scocciatura alla grande.... se uno si dimentica si ritrova con un render che dura il doppio e se ne accorge solo dopo

Cmq grazie come al solito!

Già che ci sono non è che ti capita anche che usando le point light delle volte ti segnala che non trova un nodo delle stesse?

Ciao!!! :hello:

uhmmm, questo non mi è mai successo, ma le point le uso solo per le area light... non so...

Link to comment
Share on other sites

  • 1 month later...

Dopo un bel pò di tempo ho riaperto questa scena in maya è ho tirato giù un paio di rendering.... come si vede non ho curato molto i materiali per la fretta... mi serve giusto vedere il risultato in termini di resa generale e d'illuminazione....

Ecco il test:

Uscito in 40 minuti scarsi:

stanza39min.jpg

Vorrei capire da dove escano tutti questi artefatti...

Ho provato un pò di cose nel quarto d'ora libero del test ma non ho trovato l'inghippo...

Qualcuno mi da una mano??

A presto!

Link to comment
Share on other sites

maròòòòòòòòòòòòòòò :D sta stanza sta diventando un tormento! Tutti a me!!!! :wallbash: diamogli una mano su!

Allora, prova a disabilitare la GI e lascia la FG almeno vediamo a chi imputare quel problema

Lascia i materiali che hai ed usa, per il momento, solo blinn e lambert. Facci sapè Marco.

Saluta l'incongruente :D:D:devil:

Link to comment
Share on other sites

sei sicuro che il rendering della prima immagine (bianca) l'hai eseguito con le stesse impostazioni delle altre?

cioé se togli i materiali e riassegni quello bianco il render viene così? :huh: mi sembra molto strano...

cmq è una questione di radius del FG, troppo basso probabilmente

posta i parametri e vediamo di capire dove sta l'inghippo ;)

Link to comment
Share on other sites

Niente da fare.... ho fatto ulteriori test... cmq rimettendo il lambert bianco ottengo quasi la stessa pic di inizio post... quasi perchè giustamente ho rifatto le geometrie e un pò di differenza nell'illuminazione c'è.... ma se vedete anche nella prima pic si vedono degli aloni neri in alcune parti...

I settaggi del rendering come detto prima sono gli stessi del tutorial... aumentando il radius del FG pulisco ma i dettagli se ne vanno a benedire... ho provato anche con un 5-50 ma addio...

Cmq - RENDER GLOBAL

AA Quality

Samples 0 | 2

Mitchel: 4 | 4

Contrast RGB: 0,05

Raytracing 4 4 8

GI

Accuracy: 512 (testato anche fino un 700)

Radius: 15

Max Photon Depth: 5

Max Reflection Photon: 5

Max Refraction Photon: 5

Final Gather

Rays: 300 (provato fino a 450)

Min / Max Radius: 2 | 15

Filter: 1

Trace Depth: 2

Trace Reflection: 1

Trace Refraction: 1

Luci 6 6 | 3 3

per ora non ho usato il mib cie per le luci... gli ho messo il colore e cambiato l'intensità.... poi che altro? sembra tutto.

Link to comment
Share on other sites

quanto ci hai messo a renderizzare l'ultima pic postata?

a quant'è il sampling dell'area light?

in sostanza ti posso dare questi consigli di massima

- se usi un AA 0-2 il sampling dell'area light può non essere eccessivo (tra 6-6 e 8-8 dovrebbe andare bene, dipende da dove è messa)

- la GI dovrebbe andare bene come accuracy, diminuirei un pochino l'intensity (ora come ora si nota che stai forzando la GI per avere tutto più chiaro possibile, io forzerei meno la GI e cercherei un compromesso tramite tonemap), in questo modo dovresti risolvere alcuni artefatti che si vedono anche nella prima img

- l'aspetto maculato è dato essenzialmente dal sampling del FG, per migliorarlo puoi fare varie cose, intanto puoi rinunciare a un pochino di occlusion, alzando leggermente il minimo (prova 3) poi puoi alzare il massimo a qualcosa come 20/30 e, allo stesso tempo, aumentare il presampling (prova a portarlo a 2, miDef > extra attributes > fg presample density) e lasciando invariato il sampling (300), prova così e posta qualche prova veloce (magari senza AA) per capire se come parametri possono andare bene, ovviamente sto andando alla cieca...

Link to comment
Share on other sites

La precedente img è stata renderizzata in 40 minuti circa (era scritto sopra).... per le luci il sampling è su 6 | 6...

Ecco il test cambiando i valori secondo i tuoi consigli... è uscita in 27 minti senza AA ma non ho messo il presampling a 2..

stanza27min.jpg

invece mettendo il presampling a 2 (con un render region) non ho visto molta differenza... puliva da una parte e sporcava dall'altro... che farebbe di preciso???

speriamo di risolvere :wallbash:

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...