Vai al contenuto
justmark2007

artefatti luce soffito. da cosa dipendono?

Recommended Posts

buongiorno,
ho un problema a cui non  ne vengo a capo. nell' immagine pur avendo settato una qualità moderatamente alta ed avento il soffitto "chiuso" ho delle fughe di luce, il problema si ripresenta anche negli spigoli dei mobili. (le zone segnate in rosso).la parete è uncomune materiale bianco senza riflessività.

non ho attivato il sole, "fuori dalla finestra ce solo una luce rettangolare dentro ad una scatola, inmodo da non avere la luminosità del cielo).

Il problema mi si ripresenta con o senza sole.

Le luci sono tutte con le shadow a 16

Partendo da sotto:
Dome a sinistra 50 default

dome a destra 200 default

dome sopra 500 default [pensavo fosse lei l' artefice vista la forte potenza, anche abbassandola non cambia, mi diminuisce la luce in scena ma in proporizione il problema rimane]

rettaongolo 1 defaut

 

ho letto tutorial a riguardo a palate, non so piu dove sbatere la testa...=(

 

Cattura.PNG

parametri.PNG

2.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Posta anche i settaggi delle luci..magari è solo una questione di shadow bias...non sono super esperto..ma perchè usi le dome e perchè cosi tante?? Hai provato a spegnere tutte le luci e provare a renderizzare con una sola luce attiva alla volta?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grazie per la risposta,
stasera posto i settaggi.
Uso le dome perchè voelvo riproducessero la luce del lampadario, non è corretto?
Per il numero è perchè altrimenti la scena mi diventa molto ma molto buia. è un fenomeno che a me avviene sempre nei render di interni (con tutti i tipi di luce), devo metter "molte" luci per avere una buona luminostià pur avendo lo shutter speed molto basso, anche a 30. (diaframma non selezionato) non so perchè.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ne posto due, tanto le altre impostazioni sono uguali.
confermo che anche con una signola luce, nelle aree di sua competenza (quindi quella in fondo chiaramente non mi fa rilettere nel mobile vicno alle sedie) e in porporzione all' intensità il fenomeno avviene.
Lo shutter è a 30....

1.PNG

2.PNG

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

qui trovi qualcosina piuttosto semplice per provare un pò alcune cose basilari...magari può esserti un pò di aiuto

http://ctrl-z.it/7-problemi-v-ray/

ovviamente trovi tantissime altre cose anche qui negli "argomenti già trattati"...però fai qualche prova...

Io sinceramente non uso le dome come illuminazione d'interno..e magari è solo un problema di qualità della GI...però magari qualcuno più avvezzo potrà darti ulteriori suggerimenti

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grazie per la risposta, quei blog e molti altri del sito li avevo già letti, ho provato a mettere in pratica i suoi consigli, ma non penso che il mio problema riguardi ciò.. aspettero magari qualcuno sa come fare...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

In light cache prova a mettere il numero di passi a 1. Ma prima ti consiglio una cosa,un piccolo suggerimento che spesso ti risolve un sacco di grattacapi. Renderizza la scena con una luce alla volta e testa tutte le luci prima di fare il render finale. Senza texture ovviamente. Cosi prima di tutto capisci se il problema sono le luci,una volta provate tutte le luci rimetti le texture e vedi se magari il problema è dato da qualche oggetto. Comunque io fossi in te eviterei tutte quelle dome.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ringrazio per la risposta.
posso sapere cosa centra il numero di passi? non sono in relazione alla cpu?
per le luci ho gia provato singolarmente, non mi danno un effetto diverso. provero a togliere i materiali e ad impostare il nuemro di passi.

Ma le dome perchè no? pensavo oltre alle ies fossero ottime per simulare la luce di un lampadario classico....

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
9 minutes ago, justmark2007 said:

ringrazio per la risposta.
posso sapere cosa centra il numero di passi? non sono in relazione alla cpu?

Si in teoria si però delle volte da problemi se messo a 0.

 

10 minutes ago, justmark2007 said:

per le luci ho gia provato singolarmente, non mi danno un effetto diverso. provero a togliere i materiali e ad impostare il nuemro di passi.

Per "non mi danno un effetto diverso" cosa intendi? Intendi che il problema persiste anche se provi le luci una a una? Si 

 

11 minutes ago, justmark2007 said:

Ma le dome perchè no? pensavo oltre alle ies fossero ottime per simulare la luce di un lampadario classico....

Si le dome sono ok ma se ne metti un bel po tutte insieme è meglio evitare. Soprattutto se le metti in uno spazio chiuso come quello. 

Prova a vedere senza materiali se il problema persiste. Se il problema persiste è colpa delle luci e quindi ti consiglio vivamente di lasciare solo una dome e utilizzare invece un'altra luce area. O nel caso prova una differente combinazione di GI.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

si, il problema persisteva sia se ne uso una alla votla (e le aree incriminate sono circostanti ad essa) sia se le calo di intensità (chiaramente il problema diventa minore, poichè tutta la scena è molto buia). ora provo con il parametro ad 1 e a rimuovere le textures, anche se non capisco perchè dovrebbero darmi problemi all' incrocio tra muro e soffito, dove non c'è nessuna texture..
Grazie per i consigli! subito faccio sapere!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

No beh il problema non è dato direttamente dal muro o dal soffitto ma magari da qualche altro oggetto troppo riflessivo che ti provoca degli artefatti. Comunque se mi dici che il problema persiste anche se le provi una ad una allora quasi sicuramente è provocato o da GI o da qualche parametro di suddivisione troppo basso.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

capisco.. ad ogni modo ho provato e non migliora nulla.. per caso dai parametri che ho postato sopra di GI magari sai su quali devo agire? perche a mio avviso sono già alti, soprattutto per il livello di dettaglio della mia scena...

 

Ps. ho provato a renderizzare anche solo i muri, con tutti gli altri layer (arredo + pavimento) spenti. stesso problema

 


Modificato da justmark2007

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Si, ho già notato anche io che sono abbastanza alti. Prova a postare anche i parametri di render. Magari c'è qualcosa di sballato e qualcuno può darti una mano. Altrimenti ti dovrai mettere l'anima in pace e cambiare la tua illuminazione.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

mah guarda l' illuminazione anche la cambierei, ci perdo sicuramente meno tempo. ma non penso di venirne a capo. ora stavo provando a fare render paraziali anche con tutte le luci spente e solo il sole, stesso problema, come se il soffitto fosse forato... ti posto gli altri parametri,magari è sballato qualcosa li....

1.PNG

2.PNG

3.PNG

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

prova a togliere la spunta all AO...poi..domanda retorica...ma sei sicuro che la geometria sia esattamente in ordine? Posta un risultato di tutto spento tranne una sola luce e con un override material vray applicato nello slot global setting.

Rileggendo il tuo post iniziale vedo che hai il sole dentro una scatola? Cosa vuoi dire? E poi guardando l immagine che hai postato (la vista superiore) vedo dei triangoli che vanno oltre il muro..potresti postare delle viste fatte da fuori con ombreggiatura piatta? Cosi pare molto difficile capire la tua scena


Modificato da alfred80

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

la geometria e correttamente in ordine l' ho controllata piu volte...

l' Ao e tolta.

la scatola (la parte che in pianta si vede sbordare storta sopra la finestra) era per NON usare l' illuminazione del sole in quella finestra li (ma nelle altre, ovvero quella vicino al tavolino nella parte sotto si) perche pensavo fosse lui l' artefice dei problemi.

i triangoli oltre il muro è un segno in pianta importato da autocad, di un precedente divisorio in cartongesso.

posto ora il render con una qualità accettabile (impostando il valore astronomico di 150 in retrace treshold, con valori inferiori non cambiava nulla.. non penso quindi sia la strada giusta, anche perche ha dilungato ad una notte il tempo di render)

l' altro è con il retrace disattivo.

2.jpg

ds.png

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

In genere sono problemi di rimbalzi dei fotoni questi artefatti. Hai provato a vedere con un check di analisi (mental ray ne ha uno, non saprei su maya però) come si comportano nell'ambiente?

 

Se scrivi in "cerca" qui su Treddi "luce strana soffitto" escono decine di discussioni simili, prova a dare un'occhiata...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

avevo gia cercato, onestamente trovavo molto per 3ds, e per certe cose non potevo trasferire le risposte a Rhino (non Maya), ad ogni modo provo a ricercare con maggiore cura, concentrandomi anche sull' argomento fotoni.
Vi dirò come sarà andata la ricerca!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×