Vai al contenuto
Emiliano Baldassarro

PROBLEMA DI IMPORT .OBJ / .MTL

Recommended Posts

Buonasera a tutti!
Ho un serio problema (a quanto pare molto comune tra gli utenti rhino):
Ogni volta che importo un file .obj, il relativo file .mtl non riconosce i materiali e non capisco dove sbaglio o cosa manca al collegamento.

Voi come risolvete questo problema? Sono giorni che provo a sbrogliare la matassa ma sto imazzendo! Non posso ricreare ogni singola texture! Aiuto!

Grazie in anticipo

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Non ci devono essere sottocartelle, il .MTL deve essere nella stessa directory dell' OBJ e tutte le textures devono essere a loro volta nella stessa directory.  Se nemmeno così le riconosce prova ad aprire il file MTL con un blocco note e a modificare le directory delle texture inserendo la directory in cui hai estratto tutto quanto.

 

Assicurati anche che il modello che hai scaricato abbia, effettivamente, le textures incluse.. molti non le includono e includono solo il file mtl (inutile).  Il file obj al suo interno non incorpora le textures. Le immagini quindi devono essere tutte presenti nel pacchetto che tu scarichi.


Modificato da Bruno E
virgola

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Grazie per la risposta!
Anche quando mi ritrovo obj scaricati con tutto nella stessa cartella non riconosce le texture presenti.
Ho provato a modificare la directory ma non cambia nulla. Può farmi qualche screen di un esempio di cosa modificare nella directory?
magari sbaglio a modificare le righe... davvero non capisco!
Quando provo a fare il processo partendo dal file .max, per esempio, l'export dell'obj nn presenta texture.

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ciao emiliano anche io effetivamente con alcuni file obj trovo problemi.

ho risolto per alcuni file facendoli passare prima per sketchup e poi salvando il file nativo del sw alla versione 8

rhino importa i file nativi quindi ti basta trascinarlo nella finestra di rhino e aprirlo o importarlo.

prova così se proprio non riesci in altro modo.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
1 ora fa, Emiliano Baldassarro ha scritto:

Grazie per la risposta!
Anche quando mi ritrovo obj scaricati con tutto nella stessa cartella non riconosce le texture presenti.
Ho provato a modificare la directory ma non cambia nulla. Può farmi qualche screen di un esempio di cosa modificare nella directory?
magari sbaglio a modificare le righe... davvero non capisco!
Quando provo a fare il processo partendo dal file .max, per esempio, l'export dell'obj nn presenta texture.

 

 

In questo momento non ho file obj importabili che non provengano da Rhino e non ho  3D studio installato. Se hai voglia esporta un obj da 3D studio come sei solito fare (anche solo una primitiva con le texture e il file mdl) e postalo qua così vedo se mi funziona.  

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×