Vai al contenuto
Ilaria Colanuono

Xrif non si caricano su un solo pc in rete!

Recommended Posts

Buongiorno a tutti!

Come suggeritomi proprio in questo forum circa 6 mesi fa, nello studio dove lavoro stiamo utilizzando molto gli xrif per poter gestire meglio i vari file degli impianti che si sovrappongono alla pianta architettonica, e soprattutto per non dover effettuare le modifiche su ogni file ma poterlo fare una tantum.
Purtroppo però c'è stato un problema, già verificatosi la scorsa settimana in mia assenza (risoltosi non so come) e tornato a farsi presente anche stamattina.
Ovvero, sul pc del capo i file xrif non vengono caricati quando si apre un dwg che ne contiene. Sul computer mio e su quello del mio collega invece funziona tutto a meraviglia, per cui ne posso dedurre che è un problema "locale". Ovviamente ho già tentato col riavvio del pc :P
Ho cercato un po' sul forum e su google ma ancora non sono giunta alla conclusione. Ho visto del comando "XLOADCTL" che però non è mai stato modificato e che quindi è sempre impostato, come di default, su 2. Inoltre, se ho ben capito, questo comando si riferisce solo a riferimenti già aperti tramite altri file, mentre il problema ci si presenta anche se sugli altri due pc non è aperto nulla.
Aggiungo inoltre che il percorso di riferimento dei file è del tipo \\NOMECOMPUTER\CartellaCondivisa\Cartellaprogetto poiché lavoriamo, appunto, in linea.

In questo momento non so come muovermi perché è ovvio che si tratta di un grave disagio, che il capo vorrebbe risolvere creando un unico file e lavorando coi livelli. Purtroppo non credo sia una soluzione fattibile non solo dal punto di vista dell'organizzazione ma anche per via delle scarse prestazioni dei computer.

Cosa mi consigliate?

Grazie in anticipo!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao, mi pare di ricordare la vecchia discussione di cui parli.

 

In ogni caso, per unire gli Xref come credo di intuire tu già sappia potresti usare il comando Bind ma io eviterei di farlo perché poi ci si ritrova col vecchio problema di difficile gestione e non stiamo a ripeterci.

 

Potrebbe essere imputabile alle numero diverse versioni di Autocad che convivono ma potrebbe essere anche dovuto alle impostazioni di rete che mal si coniugano con l'autocad della postazione, bisognerebbe vederle.

Avete provato ad entrare nella finestra degli external references e dopo aver controllato l'esattezza del percorso degli Xref cliccare con i destro sul singolo file per poi ricaricarlo?


Modificato da mtsim

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ho fatto proprio così, ho ricaricato il file in ogni singolo disegno e per ora va. La cosa strana è che il problema è apparso solo su un pc e che il percorso del file era corretto (infatti sugli altri pc si vedeva!). Non so che pensare al riguardo, spero non si riproponga il problema perché il pc è quello del capo e se va avanti così ci tocca fare un unico file con tanti layer per i vari impianti (mi oppongo fermamente alla cosa!)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Purtroppo, non per portarti sfiga, temo che il problema si ripresenterà. Forse non con questo file o almeno fino a che non lo risalverete da un'altra postazione ma questi problemini hanno la fastidiosa tendenza a ripresentarsi. Dovreste dedicare un po' di tempo alla sua risoluzione, probabilmente è una cosa banale delle impostazioni di autocad installato su quella postazione.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ora è capitato anche dalla mia postazione! Una sola volta, su un singolo file.
Sinceramente non ho alcuna idea di cosa possa essere perché non ho modificato nulla di "compromettente", né sul mio pc né su quello del capo. Mi sto limitando a ricaricare il riferimento quando non lo fa in automatico, ma la cosa può creare noie al capo... purtroppo non so dove mettere le mani perciò chiedo consiglio qui!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ho notato adesso che i file che non si riescono a caricare sono quelli in cui il percorso è del tipo c:\\CartellaCondivisa\\Cartellaprogetto etc, mentre dovrebbe essere  \\NOMECOMPUTER\CartellaCondivisa\Cartellaprogetto, che è poi il percorso che salvo ogni volta. Com'è possibile che si "cambi" in questo modo? Senza, peraltro, che siano state fatte modifiche né alle variabili di sistema né ai pc o alla rete?
C'è un modo per risolvere? Premetto che è impensabile, per l'organizzazione del lavoro, avere i file tutti nella stessa cartella. Voi come risolvete queste rogne?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Scusate, aggiorno ancora per farvi capire bene e perché sto scoprendo nuove cose.
In sostanza il problema sta proprio nel percorso del file, che risulta essere differente sul pc del capo. Su questo, infatti, c'è la cartella condivisa a cui facciamo riferimento. Il percorso necessario a caricare gli xrif nel pc del capo è del tipo "c:\\CartellaCondivisa\\Cartellaprogetto" perché nel pc non risulta esserci traccia di una cartella chiamata "\\NOMECOMPUTER\CartellaCondivisa\Cartellaprogetto", quella a cui facciamo riferimento noi assistenti quando appunto entriamo nella cartella condivisa.
Per ora ho risolto "mettendoci una toppa", ovvero specificando (nell'autocad della postazione del capo) in opzioni > file > percorso di ricerca dei file di supporto le cartelle in cui andare a cercare i file.
Temo però che questa soluzione ci porterà dei problemi poiché può capitare che due file abbiano lo stesso nome ma siano in cartelle diverse. Per essere chiara faccio un esempio: se lavoriamo a due progetti, TIZIO e CAIO, per entrambi abbiamo un file chiamato PROGETTO DEFINITIVO che viene richiamato negli appositi impianti. Ho paura che AutoCad faccia degli errori e peschi il progetto definitivo di Caio invece che quello di Tizio (almeno, ho letto online che può succedere). Nel caso "peggiore" rinominerò questi file chiamandoli PROGETTO DEFINITIVO TIZIO e PROGETTO DEFINITIVO CAIO, ma se c'è qualche altro modo per risolvere l'annosa questione... sono tutta orecchi!
Purtroppo di questa rete che abbiamo allo studio non ci capisco nulla, generalmente se ne occupa un addetto esterno, per cui non so dove mettere le mani.

Grazie ancora a chi ha avuto la pazienza di leggere fin qui!!!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Potrebbe esserti utile leggere questa discussione se ancora non l'hai trovata. In particolar modo potrebbe dare qualche risultato la parte relativa all'attribuzione dei percorsi relativi, assoluti o nessun percorso perché potrebbe concedere un certo margine di flessibilità per risolvere il problema.

 

 

Nella mia rete il sistema con percorso assoluto per i riferimenti esterni funziona egregiamente ma non è detto che valga per tutti.

Un ulteriore accorgimento è quello di codificare i nomi in modo univoco per ogni file, ricordo di averlo già suggerito, ma non è un caso se i nostri file hanno una codifica del tipo ILM_MGG_A_001_R01 (ILM=illuminotecnica; MGG=magazzini generali; A=primo progetto relativo al sito/edificio; 001=argomento tavola/n.tavola; R01=revisione).

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

In effetti me l'ero persa, grazie!

Per ora sto risolvendo inserendo le cartelle in cui cercare i file in percorso di ricerca e tenendo ben presente che i nomi dei file non devono ripetersi.
Ho visto che c'è la possibilità di inserire percorsi relativi, dovrei provare a vedere se funzionano bene con la rete. Mi sembra una soluzione più "pulita" ma non di immediata comprensione (non dico solo per me, ma per altri che hanno o avranno la necessità di metterci mano). Da quanto ho capito occorre prima di tutto creare delle cartelle progetto (credo in Opzioni > File > Percorso di ricerca dei file progetto) e solo dopo mettere mano all'utility di Gestione riferimenti.
C'è un motivo per cui dovrei preferire questo metodo a quello che sto usando al momento?
Premetto che i file non verranno spostati, e, quando ho la necessità di inviarne uno, unisco gli xrif.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×