Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
HunteriX

Problema Extrude

Recommended Posts

Salve sono un nuovo membro su Treddi. Ho un problema con l' extrude.

In pratica ho un mio logo in formato .png che vorrei convertire in modello 3D.

Per quanto riguardo l' export da photoshop e l' import su 3ds max è tutto ok, ma quando vado ad assegnare l ' extrude non mi da un risultato omogeneo.

Vi posto qui sotto un immagine.

Ho provato ad usare il modificatore "normal" per avere un risultato contrario ma non funziona.

Grazie in anticipo per eventuale risposta.

Area.png

Share this post


Link to post
Share on other sites

se il problema sono quegli elementi senza "tappo" sopra, è semplice: quelle spline non sono chiuse o sono "autointersecanti".

A colpo d'occhio: se in max vedi che ogni singola spline ha più di un vertice giallo (che sarebbe il primo vertice di una spline) sicuramente quella sagoma è composta da più spline e quindi non è chiusa.
Potrebbe perà essere una singola spline ma non chiusa quindi, anche se vedi un solo vertice giallo potrebbe comunque essere questo il problema.

Soluzione "ad occhio": cerca eventuali aperture, se sono evidenti ci vorrà un secondo.

Soluzione automatica: seleziona tutti i vertici e fai un bel "weld", tenendo una soglia non troppo alta (altrimenti ti unisce vertici lontani tra di loro) ne troppo bassa (altrimenti non unisce nulla. Tieni conto che l'apertura può essere tra 2 vertici perfettamente sovrapposti ma non uniti.
 

L'altra possibilità è che siano delle spline "autointersecanti" ovvero che ci sia una sorta di "nodo" o ricciolo sulla spline: andrà identificato e corretto a mano modificando le maniglie delle bezier per eliminare il ricciolo.

Share this post


Link to post
Share on other sites

Grazie per la risposta. Purtroppo essendo alle prime armi ho provato a fare ciò che mi hai consigliato. Ovviamente con esito negativo.

Ho anche provato a rifare il work path in photoshop ma mi da sempre lo stesso risultato.

 

Edit : Non so come ma ho scoperto 2 linee che si toccavano. Ho spostato la linea e adesso ho risolto.

Grazie per il supporto.

Logo.ai


Edited by HunteriX

Share this post


Link to post
Share on other sites

ho guardato il tuo file ed il problema è il secondo che ti dicevo: l'"autointersezione".

 

nell'immagine allegata ti indico dov'è il problema e come risolverlo.
 

è una stupidagine, ma queste cose mandano in tilt l'extrude.

autointersec.jpg

Share this post


Link to post
Share on other sites

ah, nella versione corretta le curve sono più morbide perchè ho aumentato l'interpolazione della spline, non è obbligatorio ma, in alcuni casi, una curva corretta, se poco interpolata, può andare ad autointersecarsi in questo modo.
Nel tuo caso però era proprio sbagliata la curva, anche se di poco.

Share this post


Link to post
Share on other sites

Graie mille per il supporto. Ovviamente per qualsiasi cosa che vorrei fare sul logo trovo delle difficoltà.

In pratica vorrei dare un effetto bordo usando lo strumento "insert" ma il risultato è più o meno pietoso.

 

Non so se si debba modificare prima dell 'extrude, oppure mentre si assegna l 'insert, oppure esiste un metodo dopo l' assegnazione dell' insert.

Da premettere che prima di chiedere aiuto ho fatto varie ricerche su youtube e su google ma senza risolvere.

 

Vorrei anche dare un effetto smussato ma se riesco a fare bene l' effetto bordo con l' insert mi basta :D

Area.png

Share this post


Link to post
Share on other sites

se ho capito cosa vuoi fare ti suggerisco di operare sulla editable spline:  cerca il comando "outline", devi aver selezionato le spline, come sotto oggetto, per vedere il tasto attivo.

 

Share this post


Link to post
Share on other sites
15 ore fa, Noothera ha scritto:

se ho capito cosa vuoi fare ti suggerisco di operare sulla editable spline:  cerca il comando "outline", devi aver selezionato le spline, come sotto oggetto, per vedere il tasto attivo.

 

Fantastico. Farò tesoro di ciò che ho imparato. Mi ci vorra un pò per fare tutte le Outline ma il risultato è notevole.

Ti ringrazio per il supporto.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x