Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
2slow4u

Problema mappatura planare: risulta visibile anche osservando l'oggetto da dietro...

Recommended Posts

Non riesco a capire dove sbaglio.

Ho mappato una texture su un oggetto (mappatura planare) e questa, non riesco a comprendere perche', risulta visibile anche osservando l'oggetto da dietro.

Allego un paio di immegini, sperando risulti chiaro il problema.

Il motore di rendering e' V-ray.

Grazie.

test1.jpg

test2.jpg

Share this post


Link to post
Share on other sites

Ho modificato il titolo della tua discussione. Mi raccomando di creare titolazioni il più possibile precise e facilmente capibili, per indirizzare al meglio l'utenza al tuo specifico problema. ;)

 

Grazie per la pazienza e collaborazione :) 

Share this post


Link to post
Share on other sites
4 hours ago, AgesAndroS said:

hai provato con le decal?

 

Non posso provarle perche' non trovo il comando...

Nel tab "proprieta'" non ho l'icona delle decals, ma solo quelle relative alla mappatura delle textures...:unsure:

Share this post


Link to post
Share on other sites

Probabilmente, unwrap a parte, ci sarà una soluzione più elegante... ma per aggirare la cosa potresti assegnare un materiale diverso alla parte posteriore della mesh.

Si tratterebbe di un materiale uguale a quello della parte anteriore ma senza texture.

 

ciao ciao

Share this post


Link to post
Share on other sites
2 hours ago, Michele71 said:

Penso che sia più una questione di tile...

 

In che senso?

Ti riferisci a un potenziale problema del modello 3d?

Se e' cosi', lo escludo, il problema si evidenzia su qualsiasi geometria.

Anche su una banalissima sfera, se mappo una bitmap in modalita' planare, la texture e' visibile (rovesciata) anche dal lato opposto.

Ho fatto qualche ricerca in rete e su un forum ho trovato un post di un utente che lamenta lo stesso problema.

https://flyingarchitecture.com/forum/index.php?/topic/349-decal-problem-in-vray-for-rhino/

Vorrei capire se esiste un workaround per gestire la situazione.

Per adesso mi sono limitato a splittare la geomtria a meta', applicando la texture solo sul lato frontale, riunendo poi i due gusci in un gruppo, ma non mi sembra una soluzione particolarmente elegante... :)


Edited by 2slow4u

Share this post


Link to post
Share on other sites
1 hour ago, make said:

Probabilmente, unwrap a parte, ci sarà una soluzione più elegante... ma per aggirare la cosa potresti assegnare un materiale diverso alla parte posteriore della mesh.

Si tratterebbe di un materiale uguale a quello della parte anteriore ma senza texture.

 

 

Oggi sono piu' orbo del solito, non avevo visto la tua risposta, sorry...

Come leggi sopra, ho proceduto proprio come hai pensato di fare tu.

Funziona, ma non mi piace granche' come soluzione.

Se hai voglia di darmi una dritta sull'unwrap (che non pratico, quindi non so come funziona), magari ci provo! :)

Share this post


Link to post
Share on other sites

Tile = ripetizione. Io penso che la texture venga ripetuta per l'intera geometria e da qui la proposizione sul lato opposto. Prova a vedere se c'è qualcosa che ti permette ti togliere la ripetizione e vedere cosa succede...

Share this post


Link to post
Share on other sites
1 hour ago, Michele71 said:

Tile = ripetizione. Io penso che la texture venga ripetuta per l'intera geometria e da qui la proposizione sul lato opposto. Prova a vedere se c'è qualcosa che ti permette ti togliere la ripetizione e vedere cosa succede...

 

Ovviamente l'opzione tile e' disattivata.

Sto parlando di una cosa assolutamente diversa.

Share this post


Link to post
Share on other sites

Ovviamente per te che hai già disattivato l'opzione ma meno per noi, dato che non hai accennato a tale evidenza. Comunque non so come gestisce l'unwrap Rhino, quindi mi rimetto hai più esperti di me :D:hello:

Share this post


Link to post
Share on other sites
11 minutes ago, Michele71 said:

Ovviamente per te che hai già disattivato l'opzione ma meno per noi, dato che non hai accennato a tale evidenza.

 

Michele, un tile mi avrebbe tappezzato integralmente la geometria con la texture, io invece ho due sole proiezioni, e quella posteriore, come ho scritto sopra, e' ribaltata, ecco il perche' del mio "ovviamente"...  :)

Share this post


Link to post
Share on other sites
3 ore fa, 2slow4u ha scritto:

 

Oggi sono piu' orbo del solito, non avevo visto la tua risposta, sorry...

Come leggi sopra, ho proceduto proprio come hai pensato di fare tu.

Funziona, ma non mi piace granche' come soluzione.

Se hai voglia di darmi una dritta sull'unwrap (che non pratico, quindi non so come funziona), magari ci provo! :)

Ehm... l'unwrap è un argomento un po' ampio e tra l'altro io non conosco Rhinoceros. Detto molto grossolanamente, si tratta di marcare dei seams sulla mesh dove questa andrà tagliata per aprirla e renderla piana. Così hai uno spazio piano (coordinate UV) dove mappare la texture. Insomma ci devi studiare su, c'è poco da fare.

 

Comunque un'altra soluzione forse sarebbe quella di usare la mappatura cilindrica (non planare).

Share this post


Link to post
Share on other sites

In max non funziona cosi ad esempio. Con una mappatura piana e tile attivato si può creare la tua stessa identica situazione. Infatti si risolve spuntando il tile ( mi è successo molte volte) Vediamo come si evolve la discussione, cosi imparerò qualcosa di nuovo :)

Share this post


Link to post
Share on other sites
15 minutes ago, make said:

Comunque un'altra soluzione forse sarebbe quella di usare la mappatura cilindrica (non planare).

 

Potrei sbagliarmi ma se uso una mappatura cilindrica, non posso delimitare l'area in cui voglio posizionare la texture, se non lavorando sulla superficie srotolata.

In ogni caso, insomma, tocca studiarsi sto unwrap. :)

Speravo ci fosse una soluzione piu' immediata, insomma, speravo di essere io ad aver sbagliato qualcosa, ma mi sa che (con v-ray) non e' cosi'...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x