Vai al contenuto
wergax

Chamfer in 3DS Max

Recommended Posts

Ciao a tutti,

domanda da super-noob:

3ds, creo box, converto in editable poly, seleziono due lati opposto di una stessa faccia, faccio "connect" dividendo così a metà una faccia, estrudo una delle due metà di una faccia, voglio raccordare un lato sporgente e quello interno, seleziono i due lati e faccio chamfer, quello interno lo fa male...(vedi foto 1)

...ragiono un attimo (o almeno ci provo...:lol:) ...penso che gli possa dar fastidio nell'operazione la divisione della faccia laterale...seleziono le due linee e faccio comando "remove", ora lateralmente ho due superfici intere, riprovo con il comando Chamfer e vedo che lateralmente l'operazione è corretta, ma il resto no....ho pensato ad un errore di visualizzazione ma in fase di render la superficie viene fuori proprio come da foto 2.

...dov'è che sbaglio?

Grazie in anticipo!

1.jpg

2.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

A mio avviso sbagli l'approccio.

Prima cosa: generalmente non si va a fare un chamfer a 15 suddivisioni per farlo apparire "smooth", ma si parte dal presupposto di creare un modello low poly e poi applicare un modificatore di tipo Smooth quale TurboSmooth.

In seconda battuta se applichi il chamfer allo spigolo interno non ti verrà mai come quello esterno e soprattutto non sarà concavo.

Se vuoi avere edge convesse/concave allora ti crei due spline a S e te le unici creando un'unica superficie. A quel punto fai a meno di usare chamfer/turbosmooth e hai finito.

 

 

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

fermo restando che, come dice outsider, per una forma del genere potresti partire da una spline con i vertici arrotondati ed estrudere dopo...

ma, supponendo che questa strada non sia percorribile, perchè magari stai arrotondando un modello più complesso, eccoti 2 dritte:

1) se elimini le facce perpendicolari a quelle dell'edge che vuoi arrotondare, il chamfer funziona correttamente.
Poi puoi chiudere il modello con "cap holes" (c'è sia un comando del edito poly, "cap", che un modificatore):
2rbzckh.jpg

2) in alternativa devi creare un edge che continui sulla faccia perpendicolare (immagine a sinistra) ed il chamfer funzionaerà (immagine a destra).
Poi, eventualmente, puoi procedere eliminando gli edge di troppo.
2yxgl6r.jpg


Modificato da Noothera

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
12 minuti fa, 0utsider ha scritto:

A mio avviso sbagli l'approccio.

Prima cosa: generalmente non si va a fare un chamfer a 15 suddivisioni per farlo apparire "smooth", ma si parte dal presupposto di creare un modello low poly e poi applicare un modificatore di tipo Smooth quale TurboSmooth.

In seconda battuta se applichi il chamfer allo spigolo interno non ti verrà mai come quello esterno e soprattutto non sarà concavo.

Se vuoi avere edge convesse/concave allora ti crei due spline a S e te le unici creando un'unica superficie. A quel punto fai a meno di usare chamfer/turbosmooth e hai finito.

 

 

 

grazie del tuo interessamento.

è ovvio che essendo una forma molto semplice possa essere costruita in molti altri modi, quello di creare una superficie con già la "s" e poi estruderla è certamente il più immediato. Mi sono trovato in questa situazione perché modellando mi son reso conto dopo aver fatto il box che mi serviva anche la parte passa e stretta e volevo procedere senza dover ritornare sui miei passi.

 

C'è una cosa che mi sfugge nel tuo procedimento, come faresti ad applicare lo smooth solo a quei due lati e non all'intero solido?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Il 8/2/2016 at 11:27 , wergax ha scritto:

grazie del tuo interessamento.

è ovvio che essendo una forma molto semplice possa essere costruita in molti altri modi, quello di creare una superficie con già la "s" e poi estruderla è certamente il più immediato. Mi sono trovato in questa situazione perché modellando mi son reso conto dopo aver fatto il box che mi serviva anche la parte passa e stretta e volevo procedere senza dover ritornare sui miei passi.

 

C'è una cosa che mi sfugge nel tuo procedimento, come faresti ad applicare lo smooth solo a quei due lati e non all'intero solido?

Non c'è un modo per applicare TurboSmooth a sole edge di un solido a meno di usare gli smoothing group.

qui un esempio

23tmwx5.jpg

 

Gli SG separano le aree di smooth dalle altre. due facce contigue con SG diverso avranno l'edge di contatto non smussata.

 

Un'altro modo potrebbe essere quello di impostare i Crease a 1 delle edge che non vuoi smussare. Il risultato è identico e non devi impostare gli SG stando attendo a quali valori scegliere.

 

 


Modificato da 0utsider

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×