Vai al contenuto
marcatore

Disperato...condivisione Adsl

Recommended Posts

non so + che pesci pigliare...passo al dunque.

configurazione rete

2 pc e modem ethernet adsl telindus 1100.

sul pc "server" ho due schede di rete, una collegata al modem adsl e l'altra collegata all'altro pc.

tutto andava bene fino a 3/4 gg fa..quando sulla macchina server inizia a comparire all'avvio di xp un errore "CoCreateInstanceError" senza altre spiegazioni ecc...solo un bottone di ok...

Lì x lì non dò tanto peso alla cosa....solo che caso strano della vita dopo un pò..provo a navigare sul client e non va più la connessione internet sul client.

Dopo inutili tentativi con i vari wizard di microsoft ho pensato di settare manualmente il tutto..

Quello che chiedo a chi conosce queste cose è se le impostazioni che ho delle schede sono corrette...visto che nonostante sembra tutto ok...in realtà non riesco a navigare con il client (i vari "pingaggi" tra le schede funzionano e la condivisione file e stampanti pure..tutto ok..tranne il webbe)

Ipconfig SERVER

Configurazione IP di Windows

Nome host . . . . . . . . . . . . . . : server

Suffisso DNS primario . . . . . . . :

Tipo nodo . . . . . . . . . : Sconosciuto

Routing IP abilitato. . . . . . . . . : No

Proxy WINS abilitato . . . . . . . . : No

Scheda Ethernet 3com:

Suffisso DNS specifico per connessione:

Descrizione . . . . . . . . . . . . . : 3Com EtherLink XL 10/100 PCI For

Complete PC Management NIC (3C905C-TX)

Indirizzo fisico. . . . . . . . . . . : 00-50-DA-34-E5-6D

DHCP abilitato. . . . . . . . . . . . : Sì

Configurazione automatica abilitata : Sì

Indirizzo IP. . . . . . . . . . . . . : 192.168.1.2

Subnet mask . . . . . . . . . . . . . : 255.255.255.0

Gateway predefinito . . . . . . . . . : 192.168.1.1

Server DHCP . . . . . . . . . . . . . : 192.168.1.1

Server DNS . . . . . . . . . . . . . : 85.37.17.43

151.99.125.1

Lease ottenuto. . . . . . . . . . . . : sabato 1 ottobre 2005 14.09.27

Scadenza lease . . . . . . . . . . . : sabato 1 ottobre 2005 14.09.57

Scheda Ethernet intel:

Suffisso DNS specifico per connessione:

Descrizione . . . . . . . . . . . . . : Scheda server Intel® PRO/100 S

Indirizzo fisico. . . . . . . . . . . : 00-0D-61-40-C0-8F

DHCP abilitato. . . . . . . . . . . . : No

Indirizzo IP. . . . . . . . . . . . . : 192.168.0.1

Subnet mask . . . . . . . . . . . . . : 255.255.255.0

Gateway predefinito . . . . . . . . . :

Scheda PPP telcom:

Suffisso DNS specifico per connessione:

Descrizione . . . . . . . . . . . . . : WAN (PPP/SLIP) Interface

Indirizzo fisico. . . . . . . . . . . : 00-53-45-00-00-00

DHCP abilitato. . . . . . . . . . . . : No

Indirizzo IP. . . . . . . . . . . . . : 82.58.215.222

Subnet mask . . . . . . . . . . . . . : 255.255.255.255

Gateway predefinito . . . . . . . . . : 82.58.215.222

Server DNS . . . . . . . . . . . . . : 85.37.17.43

151.99.125.1

NetBIOS su TCPIP. . . . . . : Disabilitato

Ipconfig CLIENT

Configurazione IP di Windows

Nome host . . . . . . . . . . . . . . : client

Suffisso DNS primario . . . . . . . :

Tipo nodo . . . . . . . . . . . . : Misto

Routing IP abilitato. . . . . . . . . : No

Proxy WINS abilitato . . . . . . . . : No

Scheda Ethernet Connessione alla rete locale (LAN) 2:

Suffisso DNS specifico per connessione:

Descrizione . . . . . . . . . . . . . : Marvell Yukon Gigabit Ethernet 1

0/100/1000Base-T Adapter, Copper RJ-45

Indirizzo fisico. . . . . . . . . . . : 00-11-2F-BA-B9-84

DHCP abilitato. . . . . . . . . . . . : No

Indirizzo IP. . . . . . . . . . . . . : 192.168.0.10

Subnet mask . . . . . . . . . . . . . : 255.255.255.0

Gateway predefinito . . . . . . . . . : 192.168.0.1

Server DNS . . . . . . . . . . . . . : 85.37.17.43

151.99.125.1

Ovviamente tutte sullo stesso gruppo di lavoro.

la scheda intel del server è quella collegata con il client.

la scheda 3com è quella con il modem adsl.

Allora..le ho provate tutte dalla disperazione...

cmq..se qualcuno ha qualche suggerimento..si faccia avanti.

Grazie in anticipo..

ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Io ho collegato 3 computer ad internet collegando il modem eternet ad un supereconomico switch (13 euro) con 5 prese di rete..allo stesso switch sono collegati i 3 pc con relative schede di rete..ogni pc è indipendente per quanto riguarda la connessione (una volta mi connettevo contemporaneamente da tutte e tre le macchine..ora però la connessione si ha su un computer per volta)..Windows xp prof. era istallato su tutte e tre le macchine..senza dirgli nulla ha configurato al volo rete e connessione. Naturalmente funzionano anche tutti i relativi servizi di rete, stampa etc.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

hai provato a pingare un indirizzo esterno dal client?? (es. ping www.sony.com)

hai provato a fare dal client il tracert ad un indirzzo esterno? (es. tracert www.sony.com)??

TuC

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Prova cosi:

1. Modem

2. ETH0 per modem

3. ETH1 per gateway

vai in propieta di ETH0 e ETH1

cambia tutte e due IP indirizzi a Ottieni auto indirizzo IP

vai in propieta di modem

su avanzate fai check di tutte e due "Consenti ad altri utenti in rete..." checkboxes

segli ETH1

puoi autoticamente ETH1 prendera l'IP indirizzo 192.168.0.1

per machina 2 segli un IP indirizzo 192.168.0.x (diverso da 192.168.0.1 .. ad esempio 192.168.0.3) e fai default gateway 192.168.0.1

La tua ETH0 prendera un ip indirizzo dal modem

La tua ETH1 fara "gateway" quindi collegga altre machine nella class C rete in tuo modem.

dovrebbe funzionare cosi..

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

a occhio mi sembra che il pastrocchio sia nell'avere creato due reti (la 192.168.0.x e la 192.168.1.x) usando la subnetmask 255.255.255.0 che bloccano la possibilità di accedere dall'una all'altra. Oltretutto hai messo server DNS e DHCP internet su 192.168.1.1 che non ho ben capito a cosa corrisponda, ma in ogni caso è un indirizzo di rete inaccessibile ad un computer appartenete alla rete 192.168.0.x subnettato 255.255.255.0.

Come primo tentativo modificherei la subnetmask ad un più 'rilassato' 255.255.0.0 (già così dovrebbe andare), e comunque cercherei di configurare la rete come consigliato BeaZtiE eliminando 192.168.1.x

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

non ti server subnet 255.255.0.0 se non hai piu di 255 PC in rete :)

il win32 puo creare "shared connection" solo in class c rete 192.168.0.xxx quando la ETH che fa gateway ha l'IP address 192.168.0.1

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
non ti server subnet 255.255.0.0 se non hai piu di 255 PC in rete :)

Scusa ma, in questo caso, che c'entra?

Lui ha creato due reti 192.168.0.x e 192.168.1.x (e mi sfugge il motivo di questa scelta, forse perchè ha due schede di rete su un PC, boh), anche se ha due soli PC e non 255 e imposta una subnetmask con 255.255.255.0 non si potranno mai vedere, no? :blink2: Soprattutto se sul PC con IP 192.168.0.1 vuole fargli usare il PC su 192.168.1.1 come gateway.

il win32 puo creare "shared connection" solo in class c rete 192.168.0.xxx quando la ETH che fa gateway ha l'IP address 192.168.0.1

Ovviamente, ma il problema, da quanto ha scritto marcatore, non mi sembra sia quello. O meglio, lo diventa se crei una seconda LAN cui inibisci l'accesso a quella dove c'è il gateway.

Posso anche aver letto/capito male (capita spesso :) ) il problema di marcatore, ma finchè crea due lan e usa una subnetmask che blocca la possibilità di vedersi tra le due la vedo dura...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

eccoci..allora...

la eth0 collegata al modem..ha già "ottieni ip in automatico"e quelli sono gli ip che ha ricevuto..

per la eth1 l'indirizzo 192.168.0.1 è dato in automatico da win quando abilito la condivisione della connessione internet scegliendo eth1 come connessione (come suggerito da BeaZtiE)

Ho provato sulla macchina client a mettere come subnetmask 255.255.0.0 ma nulla..lasciando come gateway però 192.168.0.1.

Ora proverò a dare ip fissi 192.168.0.xxx anche a eth0..però boh..di solito andava anche nel modo descritto da BeaZtiE.

sperem ben

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×