Vai al contenuto
Matteo Bruno

Aiuto: specular map assente in viewport

Recommended Posts

Ciao a tutti, sono un principiante e sto realizzando una piccola cassa di legno con 3d max di cui sotto potete vedere un rapido screen. Ora sto realizzando il materiale, ho aggiunto la diffuse map ed anche la specular map ma quest'ultima mi da un problema. Seppur nella preview del mio material editor io riesca a vedere un sostanziale cambiamento della rifrazione della luce nelle parti bianche della specular tale cambiamento non viene riportato nella viewport che rimane "spenta" come se non gli avessi attribuito nessuna specular. Ho già abilitato nell'editor il "enable hardware map in viewport" come potete vedere dallo screen  e ho provato ad utilizzare in viewport sia le luci di default sia alcune luci che max mette a disposizione ma il risultato non cambia. Mi potreste aiutare per favore? Spero di essere stato chiaro.
Duplico questo topic nella sezione "texturing and shading" perchè non sono sicuro in quale sezione vada meglio.

cassa2.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite

non è detto che vedi sempre in viewport anche la specular, dipende dal tipo di materiale e anche dalla

modalità realisitca della viewport che ora tu hai impostato come smooth e non come realistic

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ok, credo di aver risolto. Ho disattivato "enable hardware map in vewport", mettendo quindi "show standard map in viewport" nel material editor e attivato invece l'hardware shading nelle impostazioni della viewport. Ora funziona, sia con con le luci di default che non continuando ad utilizzare Smooth and Highlights.
Mak21, in ogni caso come potrei fare a mettere la viewport in realistic?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite


Mak21, in ogni caso come potrei fare a mettere la viewport in realistic?

prova con i materiali arch & design

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ora continuando però ho un altro problema, la soluzione che ho trovato per vedere la specular map non mi fa vedere la bump map, per quella devo per forza abilitare il "enable hardware map" nel material editor, così facendo compare la deformazione dovuta alla bump ma perdo lo scintillio della specular. uffa.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite

Risolto anche questo, bastava cambiare il tipo di viewport da Orthographic a Perspective!

io non la uso quasi mai la Orthographic, preferisco la prospettiva o la camera perché alcune cose funzionano solo li.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

premesso che non uso mai materiali standard ma arch and design, a cosa serve la specular level? 

Per attivare una mappa in scala di grigi che il programma legge come: "dove è bianco riflette la luce dove è nero la assorbe". Nella preview del material editor si nota come parte del metallo scintilla ma il legno rimane spento.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×