Vai al contenuto
Accedi per seguirlo  
3dsteel

[RISOLTO] Missing map file

Recommended Posts

Sto studiando i tutorial online di 3ds
http://help.autodesk.com/view/3DSMAX/2015/ENU/?guid=GUID-8A24EDE4-A25E-4AB5-9E71-E807B81CBC1A

quando premo il rendering mancano le texture e appare il messaggio "missing map file"

anche se aggiungo con "browse\add" e poi anche "move up" il nuovo path, dove ho verificato esserci le immagini richieste, 3ds non corregge l'errore e quindi non carica le immagini

ho verificato anche in customize\configure user path\ la presenza dei nuovi path ma niente 3ds non carica le mappe.

come posso risolvere?

grazie


Modificato da 3dsteel

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

se vado in rendering\material explorer\tools\"bitmap/photometireic path" se seleziono le map una ad una riesco ad impostare il percorso delle texture. Vorrei riuscire a fare questo in automatico come descritto nel precedente post

grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Si scusami avevo sbagliato (non avevo max sottomano) Dall'Help:

"

To add a path for a file:

  1. On the External Files panel, click Add.
  2. On the Choose New Bitmap Path dialog, do one of the following:
    • Enter a path in the Path field.
    • Navigate to locate a path.
  3. If you want to include subdirectories in this path, turn on Add Subpaths.
  4. Click Use Path.

    The new path takes effect immediately."

 

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

figurati nessun problema ;), gazie per l'aiuto

Ho trovato finalmente quell'opzione "add subpath" ma non la legge assolutamente. :(

Se sposto la cartella "image" nella cartella del file .max di lavoro allora riesce a trovare tutti i file mancanti ma io vorrei risolvere il problema aggiungendo anche altri path.

RIASSUMO (aggiungendo degli screenshoot)

qui c'è l'errore

screenshot.1954.thumb.jpg.89992617403c86

qui c'è la cartella che aggiungo con il subpath attivato

screenshot.1959.thumb.jpg.d49c249454323a

il nuovo path è in cima ma .......niente!!!!

screenshot.1960.thumb.jpg.9f02c12c1a4ae9

il render viene con le texture mancanti, il legno è l'unico che ho forzato manualmente e si vede.

3dsmax mi sta accettando solo i percorsi di progetto\default e basta!!!

DOMANDONA: è un bug oppure c'è qualcosa tipo "root only" che obbliga a non leggere qualsiasi cartella?

qui c'è il tutorial

http://help.autodesk.com/view/3DSMAX/2015/ENU/?guid=GUID-9EBFF43C-3477-4406-B81E-9EFC311AD289

qui

ci sono i file da scaricare (per chi volesse provarci)

http://knowledge.autodesk.com/support/3ds-max/downloads/caas/downloads/content/3ds-max-2015-tutorials.html


Modificato da 3dsteel

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Allora, all'inizio del tutorial ti viene chiesto di scompattare i file utili agli esercizi e di inserire gli stessi in una cartella chiamata "Autodesk 3ds Max 2015 tutorials" Successivamente creare una cartella progetto riferita a quest'ultima. Tu hai fatto ciò?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

no, non l'ho fatto e questo giustifica il fatto che inizialmente manchino le texture non che manchino dopo l'add path.

Sicuramente sbaglio qualcosa ma voglio provare a capire.

Facendo l'add path avrei dovuto risolvere questo problema senza creare le cartella così come richiesto. Sbaglio?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Si, dovrebbe essere cosi, ma il percorso memorizzato dei file rispetta un criterio dettato all'inizio da autodesk per il tutorial. Ad esempio, le immagini si trovano in sceneasset/image quindi la mappa caricata riferisce a questo percorso, e non trovando tali cartelle, non legge le texture... prova ad aggiungerle al tuo path personalizzato..


Modificato da Michele71

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Scusami ma a me il discorso non torna. Spero che tu abbia pazienza con un principiante. Nel mio percorso personalizzato ci sono le texture mancanti, se guardi le immagini precedenti ho proprio selezionato la euphbark.tga che è missing nel render ma presente in h:\image.

Ho consultato anche l'help

http://knowledge.autodesk.com/support/3ds-max/learn-explore/caas/CloudHelp/cloudhelp/2015/ENU/3DSMax/files/GUID-BD426294-329E-48D2-AB34-8982E63E2FA0-htm.html

dove oltre alla frase riportata da te c'è anche scritto

 

3ds Max stores the path of any file you load. When the file is reloaded, the search order is as follows:

  1. The path saved with the file.
  2. The directory of the current scene.
  3. The paths listed in the External Files panel, starting at the top of the list.
    Note: To save loading time, if a map with the same name exists in two different locations (paths), 3ds Max loads it only once. This can cause a problem only if your scene includes two different maps with the same name. In this case, only the first map encountered will appear in the scene.
  4. Every subdirectory under the directory of the current scene.

per cui presumo che se non trova nei percorsi registrati all'inizio del progetto dovrebbe leggerli in ogni caso in quelli aggiunti successivamente.

Da quello che capisco invece non considera la list dei path e cerca solo in sceneasset/image

o c'è qualche comando che gli toglie questo vincolo di esclusività sul percorso sceneasset/image oppure se continua a non accettare i path esterni non può essere che un bug. Visto che sono un principiante credo sia più improbabile essere un baco


Modificato da 3dsteel

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ho anche provato a cancellare tutte i path presenti in configure user path\external files lasciando solo h:\images ma niente non ci va assolutamente. Esiste un modo per forzare tutto il caricamento delle texture da una pecisa cartella, dico "forzare" perchè a quanto pare "indicare" non serve a niente

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grazie, ho risolto seguendo il tuo consiglio ed andando veramente a caso!!!!!

questi sono i passaggi (oscuro x ora il senso di alcuni comandi)

aggiungere il nuovo percorso per es. "h:\images" con "browse\add" e "add subpath" quando appare il msg di errore "Missing map files"
shift T per asset tracking
path\highligth editable asset
path\make path absolute
e al posto di tutti i "missing" ora appare "found"
ora il render è a posto ma se salvo il file e chiudo\riapro ritorna l'errore "Missing map files"
path\highligth editable asset
paths\preferences\convert path to UNC
salvo e il problema è risolto fa il render completo anche se salvo, chiudo e riapro

capirò meglio più avanti

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora
Accedi per seguirlo  

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×