Vai al contenuto
5EYA

3dsmax: problema mod. ffd su un poly select di vertex

Recommended Posts

Ciao

Stavo provando a rifare passo passo il tutorial dell Sedia Fortuna,

ma ho riscontrato un problema al minuto 39'25''

Quando cerco di applicare il mod. ffd 3x3x3 al poly select del seggiolino, non riesco a spostare i control points sull'asse z, mi si spostano solo sui 2 assi x e y. Inoltre la gabbia sembrerebbe bidimensionale, forse perchè i vertici della poly selct sono tutti complanari, ma anche nel video vedo che la gabbia è così.

Secondo voi qual'è il problema?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

detta così mi sa molto di bug, non mi pare che esistano motivi per cui non si possano muovere degli handle di un ffd lungo un'asse...

Hai provato ad imporre un contraint sull'asse z?

Se non hai il pannello visibile, clicca con il bottone destro in una zona libera delll'interfaccia (a fianco alla toolbar, per esempio), ti appare un menu (vedi immagine qui sotto), scegli "Axis constraints", apparirà il pannellino che vedi nell'immagine.

constraint.jpg

qui seleziona "z" e prova di nuovo.


Modificato da Noothera

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

detta così mi sa molto di bug, non mi pare che esistano motivi per cui non si possano muovere degli handle di un ffd lungo un'asse...

Hai provato ad imporre un contraint sull'asse z?

Guarda, cosa intendi per bug? Io ho la versione design 2015.

Comunque, ho provato a rifare, e quando cerco di spostarli sull'asse z la casella dell'axis costrain z mi si seleziona in automatico, ma penso sia normale che sia così.

In ogni caso vedo che i vertex è come se si spostassero di nemmeno un millemetro....

Non è che sto sbagliando qualcosa io? Magari c'è qualcosa che mi sfugge...

Di fatto quando applico l'ffd 3x3x3 al poly select del seggiolino vedo solo una gabbia 3x3 piatta con 9 control points.

Se alzo sull'asse questi control points, si alzano a vuoto, non sortendo alcun effetto, e sotto di loro ci sono gli altri 18 control points rimanenti, che anch'essi se spostati sull'asse z non sortiscono alcun effetto sui vertex....


Modificato da 5EYA

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

se i vertici che hai selezionato sono tutti sullo stesso piano, è normale che la griglia sembri bidimensionale.

é meno normale che, muovendo i control points, non si deformi l'oggetto.

Parlo di bug perchè a volte capita che un comando non funzioni in una particolare scena o oggetto...

in questi casi conviene a provare a collassare la mesh e rifare il passaggio che non funziona.

A volte faccio un passo in più:

Creo una primitiva (box, sfera... fa lo stesso), la centro sull'oggetto che mi da problemi, la rendo Editable Poly e faccio attach sull'oggetto (il sedile, nel tuo caso).

Quindi seleziono i poligoni della primitiva originale (con la selezione "element", il cubetto) e li cancello.

A questo punto ho un oggetto che è, come poligoni, identico a quello che mi dava problemi, ma ho "resettato" eventuali problemi che, per qualche motivo, si portava dietro.

Prima di farlo però toglie eventuali meshsmooth o turbosmoooth.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Allora, premetto che non contemplavo la possibilità che potessero esserci bug, e speravo che a causare il problema fosse stato qualche opzione sbagliata....e infatti mi sa che c'è qualcosa che non va perchè anche col tuo metodo non cambia nulla.:

Ho provato a creare un plane nella stessa scena e applicarci prima un poly select poi,un un ffd 3x3x3 e funziona.

Allora ho provato sia a collassare tutta la sedia in editable poly e sia a creare una primitiva come dicevi di fare tu, convertirla in editable poly,centrarla nella sedia, fare un attach e cancellarla, (ritrovandomi così solo un editable poly) ma senza risultati.

C'è qualcosa che non va e non riesco a capire cosa.


Modificato da 5EYA

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Altre prove...ho fatto un detach del seggiolino dalla sedia, ho estruso il border, fatto un cap, cancellato il vecchio seggiolino e creato uno nuovo utilizzando il cap. L'ho attaccato alla sedia e ho ricreato la geometria con dei cut.

Mi fa sempre lo stesso scherzo.

Non capisco.

Ogni tanto provo a creare un nuovo plane in questa scena e con il nuovo plane non ho nessun problema ad applicare l'ffd al polyselect e a muoverlo sull'asse z

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Allora.

-ho fatto un detach del seggiolino selezionando i polygon,

-ho creato un nuovo plane e l'ho posizionato sul seggiolino staccato, e rendendolo trasparente ho fatto dei cut per riprodurre un nuovo seggiolino col la stessa geometria.

a questo punto funziona, ma se lo attacco nuovamente alla sedia fa ancora lo stesso scherzo quindi il problema è all'interno della sedia...

qualche idea?

Ad ogni modo dato che dovevo andare avanti col tutorial a questo punto ho prima applicato l'ffd, e poi terminato ho attaccato alla sedia.

Per essere precisi ho fatto un attach della sedia al seggiolino. Così facendo anche successivi ffd funzionano.

Non so se fosse avessi fatto ail contrario, ovvero un attach del seggiolino alla sedia poi avrei avuto problemi con successivi ffd.

Mi spiace non aver capito a cosa fosse dovuto il problema...non sono sicuro fosse un bug...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

fatico a seguirti, non conoscendo il tutorial...

Cmq, da quello che ho visto, in alternativa puoi muovere i vertici senza un FFD, magari attivando soft-selection, ed ottieni lo stesso risultato, magari lavorando solo un po' di più...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×