Vai al contenuto

Recommended Posts

Buongiorno,

e innanzitutto grazie a chiunque abbia la pazienza di rispondermi.

Sto realizzando render di interni di un alloggio, per le prime due camere ( stanza letto e bagno) direi tutto ok, posto le immagini, su cui vorrei suggerimenti su come renderle più realistiche.

Finite queste due stanze sono passata al soggiorno ma credo (sono sicura:-) ) di aver commesso un errore nel mentre xke ha iniziato a darmi l errore RCGI 0.4 error 361001: photon emission shader returned miFALSE: aborting photon tracing

(Sto realizzando i render cn 3dmax 2010 Fg+Gi mental ray nell ambiente ci sono mr sun mr sky su ogni finestra le sky portal e all interno degli ambienti ci sono delle luci fotometriche.)

ho letto sul forum un po' di informazion. Ho provato a disattivare prima la Gi e andava nuovamente tutto bene ( ma con una resa che non mi piaceva), poi provato a stacccare il FG e lasciare la Gi attiva modificato i settaggi del sole ( mettendo vali valore di energy ) ma come si può vedere dalla piccola prova di render del soggiorno ( non ancora terminato e con materiali di prova) la luce solare brucia l immagine, posso chiedere suggerimenti su come risolvere il problema

grazie mille

post-57328-0-27627300-1412926825_thumb.j

post-57328-0-08141200-1412926864_thumb.j

post-57328-0-67088100-1412926874_thumb.j

post-57328-0-87723800-1412926962_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Vedi se risolvi leggendo qui

http://www.treddi.com/forum/topic/58096-errore-mental-ray-global-illumination/

http://www.treddi.com/forum/topic/67671-errore-in-mental-ray/

Prova a cancellare le luci interne e ricrearle.

Per migliorare i render smussa gli spigoli, il letto poi sembra un blocco di pietra, cuscini e coperta da rimodellare, aggiungi il battiscopa, telecamere con angolo troppo distorto, le immagini sono abbastanza piatte, parti da un clay render per studiare l'illuminazione

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grazie mille della risposta! avevo già letto quelle conversazioni, e le modifiche che stavo effettuando le basavo sui consigli che venivano dati. Credo di aver risolto, non è ancora come vorrei la luce ma continuo a lavorarci. Sono consapevole che le telecamere sono molto distorte ma mi hanno chiesto immagini molto estese degli ambienti ( che sono molto piccoli) e non sapevo come fare se non distorcendo l angolo, suggerimentI?

proverò sicuramente a smussare gli angoli,grazie; il letto sono sincera l ho preso già modellato per mancanza di tempo, ne cerco uno meno rigido.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sono consapevole che le telecamere sono molto distorte ma mi hanno chiesto immagini molto estese degli ambienti ( che sono molto piccoli) e non sapevo come fare se non distorcendo l angolo, suggerimentI?

Puoi allontanare il punto di vista mettendo un po' di clipping o togliendo un muro dalla vista della camera. Così comprendi una percentuale maggiore della stanza nel campo visivo senza doverne aumentare troppo l'angolo.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grazie! proverò togiendo un muro, unico dubbio ( magari dico una cavolata) togliendo il muro la luce esterna non entra anche da quel punto?

credevo di aver risolto il problema iniziare della conversazione e nonostante sia giorni che leggo sulla Gi e Fg sicuramente mi sto perdendo qualche passaggio importante.

Se lascio attivo solo FG la luce è a posto ma i tempi di render senza cambiare settaggi si sono triplicati, se lascio solo la GI mi compare il messaggio di errore che posto , so che sul forum è già stato trattato l argomento ma mi potete aiutare per favore

post-57328-0-35256800-1413447035_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Quell'errore è tipico di mental ray con gli interni, devi fare un piano sotto il pavimento della stanza molto più grande dei locali, dargli un materiale bianco non riflettente, tasto destro sul piano e "non renderable" mi pare...

Il problema è che se mental ray non ha qualcosa all'esterno su cui rimbalzare i fotoni fa un gran casino...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

avevo già letto questa cosa e il piano esiste già enorme bianco non riflettente :-( ma niente il messaggio continua

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Mi spiace, quando capitava a me di solito risolvevo così, è un bug talmente stupido che gira da anni.. Altre idee non saprei. Per il muro non devi toglierlo o nasconderlo, basta che lo selezioni e tasto destro togli la spunta a "visible to camera" o qualcosa del genere (non ho max aperto).

un'idea per max potrebbe essere di resettare mental ray. Quindi prova così, salva la scena (magari con salvataggio incrementale) , cambi il motore di render mettendo scanline, poi rimetti mental ray e gli ridai le impostazioni. A volte funziona...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grazie x il muro! prima Asalap mi ha giustamente detto che le immagini sono un po piatte come le miglioro?

ho provato a togliere il motore di render e rimetterlo ma il messaggio per la GI rimane :-( alalp

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Prova ad attivare nel pannello Indirect illumination "all object generate and receive GI and caustics"

e soprattutto prova a fare un merge del solo modello in una nuova scena, controlla le unità di misura, l'origine e reimposta tutta l'illuminazione.

Parti dal daylight e lanci un render di prova con solo FG, poi un render di prova con solo GI, poi con FG + Gi

aggiungi le sky portal e provi solo FG, solo GI, FG + GI

aggiungi le fotometriche e ripeti

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Un consiglio in aggiunta a quello di Asalalp, parti con un materiale clay quasi bianco e senza riflessioni, e controlla le luci.

Quando è tutto a posto sistema gli elementi e la modellazione pezzo per pezzo. Poi aggiungi piano piano i materiali, la tenda lasciala per ultima

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

le unità di misura sono giuste tutte in cm. ho attivato all object nel pannello Gi e ancora nulla. ora provo con il merge grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

fatto un file nuovo, fatto merge Cancellate tute le luci rimesso solo la luce solare, effettuato render e ricompare l errore :-(

cosa faccio??

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Allora, ho scaricato il file help.max, lanciato il render e mi dà quell'errore. ho cancellato il system daylight (quindi bussola e sole) , ne ho rimesso uno nuovo e funziona. Magari imposta anche il photon target, andando a guardare che la larghezza di esso vada a prendere l'intero edificio. Che versione di max stai usando?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

uso max 64 bit 2010, ma come cancellandolo il problema è andato via ??prima di scrivere a voi ci avevo già provato e mi dava cmq errore

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

e oltre tutto i primi render a(nche se lungi dall essere perfetti) li facevo in due orette ora solo FG ci mette 3 ore ad arrivare al 59% del solo calcolo final gather :-(

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Giustamente lavori con le licenze che hai (come tutti dovrebbero fare :P )

Bè è giusto, se calcoli solo FG devi alzare i bounce e quindi sale anche il tempo. Nei parametri di render hai attivato sia fg che gi? hai flaggato "optimize for Final gather (slower GI)" ?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

avevo attivato sia fg che gi e faceva i render della camera che ho postato sopra, ora se li attivo entrambi parte l'errore quindi poi ho disattivato la gi e il render va con solo fg ma ci mette una vita!! con 4 diffuse bounces.

scusa l ignoranza ma optimize for Fg (slower gi) dove lo trovo? è nel pannello della gI giusto?

se è quello e la gi da errori devo spegnerlo se no si blocca ogni 5 secondi

quindi devo arrendermi a render lunghi? non esiste modo di risolvere quell errore?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

intendi sostituirlo con lo standard e fare prove di render ?

se intendevi così fatto e rimane l errore


Modificato da ChiaraQ

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×