Vai al contenuto
XISCO

problemi con matte/shadow - 3dmax 2010 - Mental ray

Recommended Posts

Ciao a tutti! Sto cercando di fare un esercizio di fotoinserimento con MR e MAX 2010.

Sto usando una forma geometrica con un semplice materiale arch. & design appoggiata a un piano a cui ho dato il materiale matte/shadow/reflection.

nel forum ho trovato questi post con un problema simile al mio:

http://www.treddi.com/forum/topic/88437-matte-shadow-in-3d-studio-max-2011non-va/page__hl__matteshadow

http://www.treddi.com/forum/topic/50271-problema-con-il-matteshadow-sul-plane/page__hl__matteshadow

Ma io non riesco a risolvere il mio problema che è il seguente.

Quando metto il m/s al piano o questo rimane troppo scuro o cambiando i settaggi dell'exposure control, si brucia.

O altrimenti mi si brucia l'oggetto che proietta l'ombra.

Si mescolano bene piano e foto solo quando attivo "process background" ma questo mi cambia i livelli della foto che invece vorrei lasciare immodificata. In pratica io vorrei solo l'oggetto in questione e la sua ombra proiettata su un piano invisibile.

allego immagini con i settaggi dell'Exposure Control

IMM 01 - exp. 9.0 (phisical units)

IMM 02 - exp 9.0 (unitless -1400)

IMM 03 come la precedente ma con spuntato "process background"

Grazie

post-101616-0-95188500-1407508203_thumb.

post-101616-0-31400200-1407508243_thumb.

post-101616-0-26829700-1407508253_thumb.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

rimedio spartano fatto in casa:

togli il controllo dell'esposizione e abbassa l'intensità del daylight (sia del sun che dello sky).

Esisteranno sicuramente metodi migliori e più corretti ma in questo modo risolvi velocemente.

Ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Grazie Fedor e Michele. In realtà il tutorial l'ho visto ma non presenta il problema che ho riscontrato io. lui applica il materiale ed è fatta. Cosi' come quest'altro tutorial di Autodesk (con max 2014)

Fedor, quando torno a casa proverò senz'altro a fare come dici tu e vi farò sapere

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Effettivamente togliendo l'exposure control e diminuendo drasticamente l'intensità del sole e del cielo (con un cielo diverso dal MR sky) il render viene e lo sfondo non risulta modificato.

Grazie!!

post-101616-0-68680300-1407525507_thumb.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Lol il tutorial l'ho creato io :D

Ora non sono al pc, quindi vado a "naso"... Nel rollout "Matte/Shadow/Reflection Parameters" hai messo la mappa "Environment/Background Camera Map" (con la tua immagine dello sfondo) nello slot "Camera Mapped Background"? Se si, prova ad copiare questa mappa anche nel rollout "Indirect Illumination rollout" in modo tale che l'intensita' della luce indiretta venga determinata dall'immagine stessa... Ripeto che vado a memoria, e quindi non so' se potrebbe essere una soluzione plausibile....

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao Fedor, intanto complimenti per il tutorial. Il tuo tutorial era uno dei tre che stavo studiando per imparare il fotoinserimento con il matte shadow. Ho provato a fare come dici tu ma mi si ripresenta il problema. E' come se il materiale non fosse trasparente. Non è che dipende dalla versione di max (2010)?

Ho rimesso l'exposure control.

post-101616-0-42495500-1407706690_thumb.

post-101616-0-06979100-1407706697_thumb.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ho fatto un po' di prove ed effettivamente l'illuminazione globale determinata da sunlight (mr) da problemi. Quindi mantenendo l'exposure control attivato, devi sistemare i parametri di Physical Scale, background scale (map) e l'illuminazione in generale:

post-49586-0-34508900-1407753427_thumb.j

In sostanza, l'illuminazione determinata dal sole, cozza con il mach camera map presente in environmet, dato che sia il FG che la GI calcolano i pixel presenti nell'immagine in modo fisico. Quindi aumentando i valori di Multiplier in camera map, si "aggira" tale problema:

post-49586-0-66797800-1407753682_thumb.j

Per ricapitolare, i valori di "Unitless", "multipliier" e l'intensità delle luci devo collaborare reciprocamente. Fai delle prove e vedi cosa esce fuori...

Sotto un prova volante di tutto il discorso. Il parallelepipedo brucia un po', ma con l'ausilio dei valori dell''environmet ecc, si può fare meglio..

post-49586-0-08932600-1407753805_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Grazie Michele, effettivamente giocando con i vari parametri si ottiene un risultato migliore. Ci sono stato una ventina di minuti ed ho ottenuto questo:

In effetti nelle zone dove la foto non è mediamente uniforme ci sono ancora dei problemi.

Pero' con tutti questi settaggi il fotomontaggio si fa quasi prima con photoshop e il canale alpha.

Comincio a a pensare che con la mia versione di Max abbia dei problemi con il matte shadow. Ho trovato questo tutorial ufficiale che usa il Matte shadow e l'MR sun senza problemi di trasparenza. Però usa anche una versione di Max piu' aggiornata

post-101616-0-01755600-1407779894_thumb.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

L'importante è apprendere il concetto, poi è normale che Photoshop ci viene in aiuto ;) Comunque il mio video tutorial sul foto-inserimento, è stato fatto con 3dsMax2010....

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×