Vai al contenuto
  • Annunci

    • D@ve

      Visita la nuova Home Page di Treddi.com   19/02/2018

      E' finalmente on-line la nuova home page di Treddi.com. Da oggi tutti i contenuti del portale saranno facilmente accessibili e visibili direttamente dall'home page dove avrete la possibilità di dare i vostri like a contenuti, immagini e progetti. Ogni giorno potrete trovare nuovi contenuti e news relative al mondo della computer grafica e seguire le numerose attività del portale.  Fate il login e fateci avere i vostri feedback!  https://www.treddi.com/
HiRes

Rispolverando Blender - Problemi Constraints e Edit mode

Recommended Posts

ciao a tutti,

dopo taaaaaanto tempo ho deciso di rispolverare blender, riaprendo un vecchio progetto.

oltre ad aver dimenticato tante cose e non essere aggiornato sulle ultime novità della 2.70, mi sono imbattuto in due problemi di cui uno sicuramente stupido....

il primo:

ci sono alcune mesh che in edit mode mi appaiono blu (praticamente impossibile individuare vertici e bordi) mentre altre rimangono normalmente in grigio.

sono andato a cercare nelle opzioni di configurazione, nelle proprietà delle mesh cercando le differenze tra l'una e l'altra ma non ne sono uscito...

post-41404-0-73265200-1396936994_thumb.jpost-41404-0-73855400-1396936996_thumb.j

altro problema un po più complicato:

sto riggando le varie parti e mi sono fermato perchè non trovo una spiegazione logica:

post-41404-0-02828400-1396936999_thumb.j

il pezzo evidenziato in verde può ruotare solamente sull'asse Y (locale) ed è limitato per rendere la cosa più realistica

quindi come si vede, ho bloccato gli assi che non servono e applicato un limit rotation constraint.

fino a qui tutto bene.

il problema sorge quando cerco di trasferire il controllo a un oggetto separato dalla mesh, cosa che poi ho fatto per altri oggetti e che ovviamente ha funzionato...

quindi:

creo l'oggetto controller,

alla mesh incriminata applico un copy rotation constraint e qui non c'è più verso di farla ruotare come dovrebbe.

ho provato tutti gli assi anche con inverse e offset.

ho dovuto impostare lo "spazio" su local perchè l'oggetto potrebbe subire movimenti comandati da altri e poi perchè così ho fatto normalmente per gli altri pezzi...

non capisco proprio il diverso comportamento...

grazie.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao Hires, lieto di risentirti.

La storia dell'edit mode non mi è mai successa...sembra quasi che hai usato il weight-paint su tutta la mesh ed il blu è uguale al peso 0 o nullo. Ovviamente sto ipotizzando.

Per l'animazione prova ad imparentare l'oggetto ad un empty , animando e assegnando a quest'ultima la rotazione da te voluta.

Cambiamenti ce ne sono stati tanti anche nelle API, per cui non è così scontato che un file di una vecchia release si comporti a dovere.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Ciao Hires, lieto di risentirti.

La storia dell'edit mode non mi è mai successa...sembra quasi che hai usato il weight-paint su tutta la mesh ed il blu è uguale al peso 0 o nullo. Ovviamente sto ipotizzando.

Per l'animazione prova ad imparentare l'oggetto ad un empty , animando e assegnando a quest'ultima la rotazione da te voluta.

Cambiamenti ce ne sono stati tanti anche nelle API, per cui non è così scontato che un file di una vecchia release si comporti a dovere.

ciao caro, quanto tempo... ;)

il primo problema l'ho risolto e effettivamente riguarda i pesi dei vertici anche se non li ho mai cambiati. in realtà è solo una questione di visualizzazione in edit mode:

aprendo il pannello (tasto N) bisogna deselezionare la voce "Show vertex weight"...

sinceramente non mi ricordo di averla mai attivata però può essere che mi sia dimenticato oppure, come dici tu, il passaggio da una versione all'altra potrebbe dare qualche noia.

per il secondo problema non so se un helper o empty possa fare la differenza con qualunque altro oggetto...

stavo pensando di resettare le varie rotazioni perchè credo sia proprio un problema di assi ballerini...

vedremo.

p.s.

ma non c'era un modo per orientare solo ed esclusivamente il pivot? (come in 3D max)


Modificato da HiRes

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Letto solo ora, spero tu abbia risolto, dovrebbe essere un problema di priorità.

Sul tuo oggetto avrai alla fine due constraint:

Limit

Copy Rot

Devi mettere la constraint Limit più in basso nello stack e non in cima, in questo modo agisce per ultima e fa il suo lavoro.

ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

si grazie, ho risolto passando direttamente per i drivers ma terrò conto del tuo suggerimento per eventuali altri problemi.

ciao :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ho anche notato che sulla tua mesh il rotation sull'asse X è parti a 180°. Non so ora se questo possa influire sui problemi che hai elencato (ho letto velocemente), ma è sempre buona norma applicare scala e rotazione prima di passare a constrains e animazioni varie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

mi pare di aver provato ad applicare solo Rotazione... ora non ricordo e non intendo riprovare... :D

però mi è sembrato tutto molto strano anche perchè i drivers sostanzialmente fanno più o meno la stessa cosa anche se offrono un controllo più avanzato.

per alcuni oggetti ho dovuto comunque regolare alcuni valori perchè funzionasse tutto a dovere... parlo sempre dei drivers.

grazie :)


Modificato da HiRes

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×