Vai al contenuto
  • Annunci

    • D@ve

      Visita la nuova Home Page di Treddi.com   19/02/2018

      E' finalmente on-line la nuova home page di Treddi.com. Da oggi tutti i contenuti del portale saranno facilmente accessibili e visibili direttamente dall'home page dove avrete la possibilità di dare i vostri like a contenuti, immagini e progetti. Ogni giorno potrete trovare nuovi contenuti e news relative al mondo della computer grafica e seguire le numerose attività del portale.  Fate il login e fateci avere i vostri feedback!  https://www.treddi.com/
marlettalber

Problema di visualizzazione con 3DS Max 2014

Recommended Posts

Salve ragazzi. Volevo sottoporvi un problema che ho riscontrato utilizzando 3D Studio Max 2014 e volevo capire se è un problema solo mio.

Ho creato un semplice Box che poi ho convertito in Editable Poly. Quindi, ho selezionato gli spigoli verticali ed ho applicato un semplice chamfer. A questo punto, come potete vedere dall'immagine allegata, uno dei poligoni (in realtà anche il poligono opposto a questo) si presenta di colore scuro (indipendentemente dal tipo di visualizzazione utilizzata nella viewport). La situazione rimane la stessa anche se lancio il render o se applico un materiale all'oggetto.

A voi capita? Non so se è un problema di "incompatibilità" hardware.

Preciso che la versione del programma è stata appena aggiornata fino al SP3, ma il problema continua a darlo.

post-52059-0-15569500-1383653747_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao,

il problema non è dipeso dal sw o hw, qui si tratta delle basi di 3dsmax però!!!! :mellow:

Leggiti questa discussione qui

Ciao Diabolik0,

scusa ma non ho capito la tua risposta. Più che altro, non capisco a cosa ti riferisci.

Te lo dico perché uso 3DS Max da un bel po', non sono un mago della modellazione poligonale (anzi, ho ancora molto da imparare), ma questo problema non l'ho mai riscontrato con le versioni precedenti del programma. Infatti, ho eseguito le stesse identiche semplici mosse con la versione 2012 ed è andato tutto liscio.

Magari non ho capito io il tuo commento. Puoi essere più specifico?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

No, in effetti non è un problema di smoothing groups.... in effetti lo spigolo scuro viene fuori comunque. Così come altri stani artefatti. Si tratta, secondo me, della nuova gestione delle ombre ed illuminazione di default da parte dei nuovi driver Nitrous di max 2014. Se infatti illumini lo spigolo con una qualsiasi luce, l'effetto in render, sparisce. Cosi come sparisce nel caso in cui illumini la scena con le luci di scena e non con le default light.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

No, in effetti non è un problema di smoothing groups....

Superokkio erà gia grave se il "problema" fosse stato di smoothing groups, e non risolverlo, senza fare almeno una ricerca........

figuriamoci adesso.

:P

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sono d'accordo con Superokkio. Se lancio un render di prova senza inserire alcuna luce, il problema rimane. Addirittura anche applicando un qualsiasi materiale all'oggetto.

Se, invece si aggiungono luci alla scena, sembra attenuarsi o scomparire. Dovrei provare in una scena "vera" (definendo ambienti, materiali e luci) per vedere cosa succede.

Trovo, però, strano che il problema che si manifesta nella Viewport si verifichi anche nel render (che dovrebbe avere un calcolo diverso rispetto all'anteprima della Viewport).

Avete riscontrato anche voi questo problema nei vostri computer?

P.S. a parte questo problema, direi che la visualizzazione nelle viewport è stata notevolmente migliorata rispetto alle versioni precedenti del programma.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Prova a disabilitare Nitrus e usare directx....

Grazie per il consiglio. Ho fatto come hai suggerito, ma il problema persiste... quindi non è Nitrus in se a creare il problema...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Appunto, la prova era per valutare se era un problema di driver... Una cosa, dato che io max 2010, salva in formato .fbx (o max2010) il Box che ti da' problemi.... vorrei dargli un'occhiata sempre se possibile ovviamente :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite

Scusate ma non è una semplice impostazione della viewport?

3ds max ha una luce di default in viewport - e volendo nelle sue

opzioni di configurazione viewport si possono impostare più luci per evitare ombre nette.

Questo indipendentemente da nitrous o direct x.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Come si immagina (dato che non ha specificato nulla) la configurazione delle luci e' quella predefinita, quindi con due punti di illuminazione...

Esatto Michele71. Ho solo creato il box e manipolato come ho detto. Non ho aggiunto null'altro.

Non riesco ad allegarvi un'immagine dello stesso box creato col 2014 ed aperto col 2012. Il problema scompare. Per cui è un difetto del 2014 o di incompatibilità di qualche parte del mio computer.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Scusate ma non è una semplice impostazione della viewport?

3ds max ha una luce di default in viewport - e volendo nelle sue

opzioni di configurazione viewport si possono impostare più luci per evitare ombre nette.

Questo indipendentemente da nitrous o direct x.

Ok. Ho provato ad andare nelle impostazioni della viewport, come hai correttamente suggerito, ed ho sostituito l'illuminazione a due luci con quella ad una luce. Sai che ti dico?

Il problema è andato via. Per cui la conclusione è che il problema a due luci non da grandi risultati nel 2014, visto che nel 2012 funziona bene. Chissà qual è la vera motivazione?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Risolto!!!

Il problema dipendeva dall'assenza del flag su una opzione aggiunta nella 2014. Se aprite la finestra di configurazione delle viewport, ed andate nella scheda Visual Style & Appearance, proprio dove è contenuta la sezione della scelta del sistema ad una o due luci, troverete una nuova opzione che si chiama Default Lights Follow View Angle. Se è disattivata crea il "problema" che riscontravo io. Per cui basta attivare tale opzione ed il gioco è fatto.

Vi ringrazio per gli aiuti che mi avete dato e mi scuso per il disturbo (visto che la soluzione era abbastanza semplice). Spero, almeno, che servirà a qualcun altro che riscontrerà lo stesso "problema".

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Quoto mOceAm. E' una soluzione che puo' apparire semplice, ma non lo e', visto che tali modifiche vengono passate sottosilenzio. Quindi la tua perseveranza nel trovare una soluzione al problema a dato risultati concreti, e ho scoperto una nuova cosa :D

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite

Ok. Ho provato ad andare nelle impostazioni della viewport, come hai correttamente suggerito, ed ho sostituito l'illuminazione a due luci con quella ad una luce. Sai che ti dico?

Il problema è andato via. Per cui la conclusione è che il problema a due luci non da grandi risultati nel 2014, visto che nel 2012 funziona bene. Chissà qual è la vera motivazione?

Le impostazioni con nitrous si sono espanse per cercare più realismo anche in viewport, per questo nella configurazione viewport ad ogni relase si aggiungono nuove opzioni, queste da un certo punto di vista aiutano nel realismo, ma da un altro punto di vista lasciano qualche dubbio se non si seguono tutti gli aggiornamenti del programma, nelle varie news delle precedenti relase queste opzioni erano descritte.

La cosa importante è che hai trovato dove impostarle.

Ti saluto. ciao.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Credo che lo spirito del sito e della comunity sia quello di condividere le soluzioni ai problemi che ognuno, nel suo piccolo, incontra cimentandosi nei vari programmi. Ho imparato molto in questi anni osservando le varie discussioni del sito, e sono contento di poter mettere anch'io un piccolo tassello ed aiutare e condividere con gli altri.

Alla prossima e buon 3D a tutti.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

...La spunta su Default Lights follow view angle, risolve il problema nella finestra di preview, ma non nel rendering con default light nel quale lo spigolo continua a restare nero. Per risolvere il problema anche nella finestra di rendering bisogna utilizzare una sola default light... bha!!! :TeapotBlinkRed:

Certo questa cosa può sembrare una fesseria ... anche perché sostanzialmente riguarda un "difetto" di visualizzazione, ma l'insidia (e relativa perdita di tempo) sta nel fatto che quella faccia nera sembra a tutti gli effetti una normal capovolta o una faccia assente.

...

buono a sapersi!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×