Vai al contenuto
Emmemeno

Vray E G-buffer (zdepth)

Recommended Posts

Qualcuno mi spiega come faccio a salvare l'immagine zdepth, dopo aver selezionato nella finestra G-Buffer l'opzione zdepth? Se nella finestra di rendering selezioni output Z mi viene una mappa con gli oggetti in bianco e lo sfondo nero, senza sfumature! CIò non va bene. E poi i file rla e rpf che sono che neanche photoshop li apre? :)

Grazie per le delucidazioni,

ramar

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

rla e rpf sono estensioni proprietarie discreet per ottimizzare il flusso dati fra Max e Combustion (accoppiata letale).

Se vuoi aprire un render con G-Buffer in PS, usa come formato il TGA.

Mappa nera con oggetti bianchi? Prova ad aprire lo stesso il file con photoshop e a giocare coi punti focali (min e max) del filtro che ti fa il dof su canale Z-depth (non ricordo il nome esatto).

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
rla e rpf sono estensioni proprietarie discreet per ottimizzare il flusso dati fra Max e Combustion (accoppiata letale).

Se vuoi aprire un render con G-Buffer in PS, usa come formato il TGA.

Mappa nera con oggetti bianchi? Prova ad aprire lo stesso il file con photoshop e a giocare coi punti focali (min e max) del filtro che ti fa il dof su canale Z-depth (non ricordo il nome esatto).

Quindi salvando l'immagine in TGA il canale zdepth viene salvato? Non devo salvare una seconda immagine b/n dello zdepth (cosa che comunque non saprei fare) :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
nelle opzioni di salvataggio TGA c'è la caratteristica g-buffer \ z-depth

Pola non c'è questa opzione....ci sono solo:

bits per pixels

Compress

Alpha Split

Pre-multiplied alpha

E comunque non ho capito da photoshop come si prende la mappa di un canale g-buffer, e come si applica il blur (da filtro o da un effetto al livello?)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

strano, mi ricordavo che il TGA ti consente di salvare quel canale...

appena riapro MAX gli do un'occhiata ma ti devo fare aspettare ancora qualche giorno...

Per quanto riguarda invece PhotoS, devi avere la versione CS e devi usare il filtro:

--> filter

--> blur

--> lens blur

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
strano, mi ricordavo che il TGA ti consente di salvare quel canale...

appena riapro MAX gli do un'occhiata ma ti devo fare aspettare ancora qualche giorno...

Per quanto riguarda invece PhotoS, devi avere la versione CS e devi usare il filtro:

--> filter

--> blur

--> lens blur

azz photoshop cs? che è?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
è la versione 8

Come i prodotti della macromedia sono diventati MX l'ultima release dei prodotti adobe si chiamano CS ;)

Ok, ho trovato questo effetto lens blur. Il problema è che:

a) non so come prendere la mappa zdepth dal photoshop

B) non so come mettere tra le impostazioni del lens blur la mappa del punto a). Ma non esiste qualche tutorial? :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

il mio metodo rudimentale è questo:

l'immagine dello zdepth la salvo con uno screenshoot k ritaglio con ps e poi prendo l'immagine alla quale voglio applicare l'effetto dof, duplico il livello e a quello superiore imposto come maschera lo zdepth e poi sfoco il livello sotto a mio piacimento...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
dipende, a volte esce bene, altre volte è un metodo pessimo. se devo mettere a fuoco qualcosa in primo piano è ok

Io addirittura la mappa zdepth la vedo bianca e nera senza sfumature....sto ancora in alto mare per capire come si fa questa cosa...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Io addirittura la mappa zdepth la vedo bianca e nera senza sfumature....sto ancora in alto mare per capire come si fa questa cosa...

anche a me è capitato con una scena... mi metteva lo zdepth solo se attivavo il dof... pero tanto valeva... se nn lo attivavo mi faceva cosi senza sfumature.. infatti l'avevo mollato perchè nn capivo come funzionava... poi un giorno con un altra scena ci ho riprovato e tutto ok... l'unica cosa (che ancora oggi nn capisco perchè) è che mi mette il canale z una volta si e una volta no.. cioè un rendering me lo mette e il rendering sucessivo no senza che io tocchi nulla..

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×