Vai al contenuto
fcw5

Problema Con Rpc

Recommended Posts

Salve a tutti,

ho un problema di renderizzazione: la scena è composta da un lotto con circa 20 villette e sistemazione esterna (strade, marciapiedi, lampioni, panchine...). La sistemazione del verde l'ho composta con tanti RPC (alberi).

Una volta lanciato il rendering, arriva quasi alla fine che mi renderizza gli ultimi alberi come tanti cubetti verdi :crying:

Ma gli RPC non dovrebbero essere oggetti leggeri e facili da renderizzare??

Il programma è MAX 6, uso il light tracer con i settaggi base ed una omni (luce ambiente) x illuminare le zone nere.

Addirittura una telecamera (ne ho 4: una per ogni punto cardinale) non mi fa vedere le ombre SOLO degli alberi!

Sto impazzendo! Cosa devo fare? togliere parte degli alberi? (al light tracer non posso rinunciare, devo finire tutto per lunedì)

Grazie, fcw

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao ...innanzi tutto devi controllare che le luci che hai messo (cioè la omni), non escluda gli rpc...

non so il perchè ma a volte max lo fa per velocizzare il render...

dopo di che per ogni rpc tu hai dei settaggi tipo la self illumination ..devi controllare tutti questi parametri...

poi se copi gli rpc, copiali con il comando copy e non istanza perchè ti crea problemi sulla visualizzazione..

altrimenti ti consiglio di mettere il verde alla fine di tutto con photoshop che è la cosa migliore ....

fammi sapere ciao e buon lavoro :hello:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Le luci illuminano gli RPC, loro generano ombra, ammetto che ho fatto l'istanza di una siepe xchè ho fatto l'istanza della villetta che ho moltipliacto 10 volte! ma non è lei a darmi il problema...

Può essere la sk video? ho una (provvisoria) radeon 9600, stasera mi portano una X800 pro

Grazie, fcw

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Parli bene tu :( io non li so mica usare... sono applicazioni aggiuntive o già integrate su max (R6)?

Se sono più veloci in fase di render, mi leggo i vs tutorial ed imparo ad usarli, il light tracer è lentissimo, ma mi piace l'effetto sfumatura delle ombre :wub:

Grazie ancora... ti fo sapere come c'ho levato le gambe!

Ciao fcw

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Questo è un mio lavoretto fatto con final render...renderizzato in 15 minuti... non è un granchè ma le ombre ti danno l'idea di quello che questi motori di rendering riescon a fare...

03def7zj.th.jpg

ciao ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
prova altrimenti con un motore di rendering tipo final render o v-ray e ti semplifichi la vita!!!

ciao ciao

Ma non si era detto che gli RPC non lavorano con finalrender, v-ray e neanche mentalray? Mi pare che funzionano solo con lo scanline. Comunque vale la pena dare un'occhiata alle faq del sito ArchVision. Ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Non c'è bisogno, hai ragione, quando ho acquistato il 3D studio era impostato di default (credo) il mental ray, quello che renderizza a quadretti per capirsi, c'ho ammattito 2 giorni, poi ho chiamato il rivenditore di RPC e lui mi ha informato sulla incompatibilità.

Cmq è il mio pc che non batte pari! stamani ho accesso il pc, il max 6, il file ed ho lanciato il render senza fare assolutamente altro. Bè è venuto bellissimo, ho salvato, ho cambiato telecamera, ho spostato 2 oggetti e fatto 2 prove di rendering senza light tracer e quando ho lanciato il rendering finale, già solo il rettangolo su cui è applicato il materiale erba è venuto grigio, lo ombre degli alberi sono spariti... insomma uno schifo.

Adesso il pc è spento, stasera lo riaccenderò e lancerò lo stesso rendering, chi vuole scommettere che verrà bene??

Da cosa può dipendere? il pc ha 2 settimane di vita, è un athol 3200, sk madre K8V-x, radeon 9600 e 1,5 GB di ram!

Grazie, fcw

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ti garantisco che le ombre degli RPC sono molto capricciose, io per non aver problemi uso ombre zonali con ,chiaramente, la spunta su "ombre trasparenti" controllo che la luce non escluca gli RPC dal generare le ombre, controllo che gli RPC abbiano la spunta su cast shadows.

Io per un esterno userei una direzionale per il sole e la skylight per illuminazione generale (diciamo tipo una posizione alla missionaria, classico setup lol)

Mi pare una news di pochi giorni fa una versione beta da parte di Archvision sul supporto degli RPC anche per Mental ray per Max...godo...

Ciao


Modificato da Hussar

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Fai cosí:

- creati due file da quello che stai usando

- nel tuo primo file renderizza la tua scena senza gli rpc e con il tuo light tracer

- fatto questo apri il secondo e togli lightracer e luci skylight

- attiva gli rpc

- crea una luce (una direct light) in corrispondeza del tuo sole, con ombre raytrace

- a tutto il resto della scena assegna un materiale matte/shadow

- salva tutti e due i render in un formato che gestisca il canale alpha (png, tga o tiff)

- apri photoshop e importa il render degli rpc su quello "base", attiva la visibilitá tramite canale alpha e il gioco é fatto, veloce e indolore ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao ragazzi,

dopo tutto il fine settimana passato a fare prove ed esperimenti, sfruttando per lo più i vs utili consigli, e leggendo qua e là (comprese le faq di archvision... chiedo venia per non averlo fatto prima), ho capito il problema delle ombre!! :eek:

Che cavolata!!!!

Dipende dalla posizione della luce (che genera l'ombra) e della telecamera, in 2 parole: gli RPC generano l'ombra quando il "sole" è, più o meno, alle spalle della telecamera. Nel mio caso specifico, avevo 4 telecamere su ciascun punto cardinale xchè dovevo fare un'immagine da diversi punti di vista, ma nella medesima situazione, quindi la luce del sole non si è mai mossa e solo 2 telecamere avevano l'ombra sugli RPC! Questo "difetto" vale per le piante e per le persone, ma non sulle auto.

In pratica basta spostare il sole ogni volta che si genera un'immagine, io di solito la metto dietro alla telecamera un pò spostata a sinistra.

Il problema degli alberi renderizzati come cubetti verdi, è probabilmente un problema legato al mio file, ne aveva troppi e non riusciva a calcolarli, mi è bastato nascondere gli RPC non ripresi in quella specifica vista ed ho risolto... su questo punto non garantisco una spiegazione scientifica.

Grazie a tutti per i consigli mi sono stati utili

Ciao, fcw

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×