Vai al contenuto
arearch

Deformazione solidi importati da autocad in 3ds Max 2011

Recommended Posts

Ciao a tutti...sono un nuovo utente del forum.

Scrivo per sapere se qualcuno sa come risolvere questo problema: ho creato il modello 3d di un'area in autocad architecture 2012, ma una volta importato in 3ds max (sia con File Link Manager che con Import), le facce dei solidi sono tutte divergenti tra loro e alcune sembrano staccate.

Ho provato a seguire le indicazioni trovate in altre discussioni, come abbassare i valori del parametro surface deviation for 3d solids o aumentare i valori di _facetres prima di importare il dwg, ma il problema persiste. Potrebbe essere dovuto all'utilizzo delle regioni 2d e ai comandi Unisci e Sottrai in autocad per modellare i solidi?

Allego alcune immagini per darvi l'idea del problema. Se qualcuno mi sa dire come fare ad ottenere il modello corretto in 3ds Max mi sarebbe di grandissimo aiuto.

Ringrazio anticipatamente.

post-90255-0-40276600-1368381353_thumb.j

post-90255-0-04775400-1368381365_thumb.j

post-90255-0-55848900-1368381374_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Probabilmente non hai letto attentamente le indicazioni nelle altre discussioni dove spesso si suggerisce, prima di importare, di posizionare il modello vicino all'origine assoluta (ucs globale o WCS) del file di autocad.


Modificato da philix

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Grazie per l'info...mi era sfuggita.

Ho spostato l'ucs al centro del mio modello 3d di autocad e ho importato il tutto in 3ds, ma il risultato non è cambiato. A questo punto non so quale possa essere il problema.

Il disegno in autocad è stato fatto in metri, e prima dell'importazione in 3ds max ho sistemato anche qui l'unità di misura in metri.

Allego la finestra di importazione così mi puoi dire se c'è qualcosa che non va. Grazie.

post-90255-0-54264200-1368436374_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

in geometry option, flagga weld nerby vertices e fai delle prove di import abbassando il weld treshold e ti consiglio di flaggare anche rescale


Modificato da zatta 3d

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ho modificato i parametri indicati e ho fatto alcune prove con valori diversi. E' comparsa una nuova finestra (che allego) che rileva eventuali problemi con la posizione dell'origine degli assi del modello 3d, posizione che ho centrato rispetto al disegno in autocad.

Cliccando su Si viene importato il file in 3ds, ma i solidi continuano ad essere deformati.

post-90255-0-80318700-1368445074_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Io rifarei un controllo in cad, perché il modello non si trova in prossimità dell'origine degli assi. In quella finestra è specificato molto bene, con addirittura le coordinate.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

non va spostato l'USC, bensì l'UCS va spostato sulla posizione globale e poi va spostato il modello vicino all'UCS che, stando nella posizione globale, si chiama WCS


Modificato da philix

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

controlla pure se nella scena in autocad ci sono degli oggetti rimasti lontanissimi dal modello

prova anche a salvare il modello autocad in formati 2004 o anche 2000

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Grazie per i consigli! Finalmente sono riuscito a risolvere il problema!

Innanzitutto ho spostato il modello vicino all'ucs globale: ho selezionato tutto il modello, ho cliccato in uno spigolo centrale rispetto all'area del modello, e poi, dopo aver selezionato Sposta, ho digitato 0,0,0...penso sia la procedura giusta, nn l'avevo mai fatto prima.

Dopodichè ho salvato come autocad 2004 e ho importato in 3ds max secondo le indicazioni di zatta 3d, selezionando rescale e weld nerby verticles con valori al minimo di weld treshold (0,001). Anche il surface deviation for 3d solids è stato settato al minimo (0,001).

Una volta importato il modello in 3ds le geometrie sono corrette come nel cad. Facendo dei render di prova compaiono delle macchie nere, specie nella vista Top. Anche mettendo un materiale, queste macchie continuano ad esserci. Potrebbe essere dovuto al fatto che ho usato le regioni e le facce 3d in autocad per modellare il terreno e le sponde di un ruscello? Non sapendo modellare in 3ds ho usato questi elementi in autocad per il terreno. Le macchie scure compaiono proprio solo nei layer dove ci sono queste regioni. Le varie regioni sono state unite tra loro per averne di meno, ma non penso sia un problema.

Allego delle immagini con i risultati...ancora grazie!

post-90255-0-10277600-1368540593_thumb.j

post-90255-0-80510700-1368540606_thumb.j

post-90255-0-84818500-1368540627_thumb.j

post-90255-0-18354600-1368540642_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ti sei già risposto da solo, purtroppo devi stare attento ad unire i solidi in autocad, perché potresti trovarti delle sorprese dopo l'import. Prova ad unirle in più operazioni distinte e controlla anche che non ci siano doppi solidi ;) ;) ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ti sei già risposto da solo, purtroppo devi stare attento ad unire i solidi in autocad, perché potresti trovarti delle sorprese dopo l'import. Prova ad unirle in più operazioni distinte e controlla anche che non ci siano doppi solidi ;) ;) ;)

ok grazie seguirò il tuo consiglio e poi farò sapere com'è andata.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Come mi è parso di capire in "derive autocad primitives by" hai selezionato l'opzione Layer .....

Le problematiche che descrivi probabilmente derivano da tale scelta in quanto il questo modo gli oggetti sullo stesso layer verranno raggruppati, in Max, in un unico oggetto selezionabile.

Per risolvere dovrai usare l'opzione :

Entity, Blocks as Node Hierarchy

in questo modo in Max ti riproverai i medesimi oggetti selezionabili in AutoCAD.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ok grazie...cmq ho separato in autocad le regioni che avevo fatto, in modo da non averle tutte unite e ho ripetuto l'importazione. Purtroppo le macchie nere rimangono ancora, ma solo nella vista top. Nelle altre viste il problema c'è, ma per fortuna riguarda solo poche aree del modello.

Applicando una texture al terreno, le macchie rimangono anche nel render, ma se uso un materiale della Autodesk Material Library, esse scompaiono...quindi mi sa che userò questo.

A questo punto ho un'altra domanda: usando alcuni materiali della Autodesk material Library appunto, anche cliccando show standard map in viewport, il materiale non è visibile nella scena, ma solo nel rendering...questo però è un problema per scalare la texture. Non si verifica con tutti i materiali della Aut. Mat. Lib. ma solo con alcuni. Inoltre applicando sempre alcuni materiali della stessa libreria, questi sono neri nella scena.

Allego due immagini...una con il materiale erba ricavato da una texture, e l'altra con l'erba ottenuta utilizzando un materiale della Autodesk Material library.

post-90255-0-06568500-1368627563_thumb.j

post-90255-0-08497800-1368627584_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

A questo punto ho un'altra domanda: usando alcuni materiali della Autodesk material Library appunto, anche cliccando show standard map in viewport, il materiale non è visibile nella scena, ma solo nel rendering...questo però è un problema per scalare la texture. Non si verifica con tutti i materiali della Aut. Mat. Lib. ma solo con alcuni. Inoltre applicando sempre alcuni materiali della stessa libreria, questi sono neri nella scena.

Allego due immagini...una con il materiale erba ricavato da una texture, e l'altra con l'erba ottenuta utilizzando un materiale della Autodesk Material library.

Se le superfici sono vaste, come il tuo prato, la non visibilità del materiale nella vista a monitor potrebbe essere dovuto, probabilmente, alle prestazioni della scheda video che installi. Diciamo che è un problema consueto...

Fai cosi: apri il Material Editoe > scheda Common > clicca sul pulsante "Setup ..." >nella finestra che si apre ATTIVA il cek "enable proxy system > conferma cliccando su "OK. Generate proxies Now"

In questo modo il problema si dovrebbe risolvere ….dico si dovrebbe

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×