Vai al contenuto
Bliz

Problema con modificatore Surface su 3DS Max 2011

Recommended Posts

Salve, ho un dilemma che mi assilla da qualche ora e che non riesco a risolvere.

Ho 3 spline attaccate insieme e facenti parte dello stesso gruppo (unite insieme con il comando Attach).

chobs.jpg

Inserisco quindi un modificatore CrossSection per dargli una "intelaiatura" visto che dovrò creare una sorta di lamiera in 3D.

2eaq9lk.jpg

Fino a qui tutto ok, solo che al momento di inserire un modificatore Surface per creare la struttura in 3D, le spline scompaiono. Ciò non dovrebbe accadere, visto che sul tutorial che seguo l'insegnante fa le procedure allo stesso modo ed a lui risulta.

24uxh91.jpg

Quale può essere il problema? Ho provato di tutto, a fare un cross section manuale, a cambiare l'ordine di attach delle singole spline...ma niente, l'oggetto scompare sempre.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Ciao,

ho fatto la medesima procedura e funziona senza problemi. Prova a mettere il flag su Flip normals.


Modificato da zatta 3d

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite

può essere come ha detto Zatta, oppure una delle spline è invertita.

tutte le spline devono essere costruite nella stessa direzione, ad esempio da destra verso sinistra.

inoltre se nel surface i vertici non sono adiacenti, non è possibile costruire la faccia del poligono.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Avevo provato anche a flippare le normal. Mi sa che allora una spline è invertita! Se non ricordo male la prima l'ho fatta da sinistra verso destra, la centrale da destra verso sinistra (la terza è la copia della prima). Grazie, provo da capo! :D

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Stavolta mi è venuto fuori un pasticcio che non segue per nulla la forma originale delle spline. Se attivo "show vertex number" i numeri dei vertici sembrano errati, nel senso che ci sono tanti numeri sovrapposti...è un macello.

2hzwht.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Come non detto, missione compiuta! Ho ritracciato le curve con delle arc spline anzichè disegnarle manualmente, ed adesso tutto funziona alla perfezione :D

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite
Inviata (modificato)

Stavolta mi è venuto fuori un pasticcio che non segue per nulla la forma originale delle spline. Se attivo "show vertex number" i numeri dei vertici sembrano errati, nel senso che ci sono tanti numeri sovrapposti...è un macello.

2hzwht.jpg

show vertex ti serve propio per quello, per verificare se ci sono 2 vertici uno sopra all'altro con un numero diverso.

significa che hai fatto qualche pasticcio......

una spline di 3 punti è sempre composta dal vertice 1 - 2 - 3

non da 3 - 2 - 1.

credo che ti mancano le basi della modellazione spline.


Modificato da Mak21

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Si, mi mancano le basi della modellazione spline, ma in ogni caso seguo un tutorial su Digital Tutors dove l'insegnante disegna una spline di 4 punti da sinistra verso destra. Poi ne crea una copia, che suppongo abbia sempre vertici 1-2-3-4 nello stesso ordine. A quel punto la posiziona e gli da una forma curva, quindi anzichè copiarla ne fa una copia con mirror sull'asse x (utilizzando il working pivot). Così si formano tre linee, una dritta centrale e due curve speculari ai fianchi (come riportato sulla prima immagine). Bene, fatto questo, dovrebbero avere tutte e tre le linee i vertici 1-2-3-4 adiacenti. Poi prosegue (ed io lo imito) con il crossSection che "chiude" le spline. Solo che il surface a me non va perché come detto da te i vertici sono ammassati.

Adesso vorrei capire solo una cosa: perché se seguo questa procedura su un nuovo documento funziona tutto bene (vertici ordinati), mentre se lo faccio all'interno del documento con tutto il mio lavoro i vertici si ammassano? Avrò smanettato qualche opzione?

In ogni caso, come si inverte una spline? :D

Grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ho appena scoperto che il problema me lo da solo se inizio a manipolare anche leggermente i vertici per modellare le spline. Se disegno ma non sposto i vertici, il surface modifier funziona correttamente.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite

Ho appena scoperto che il problema me lo da solo se inizio a manipolare anche leggermente i vertici per modellare le spline. Se disegno ma non sposto i vertici, il surface modifier funziona correttamente.

è quello che ti avevo scritto prima. ;)

inoltre se nel surface i vertici non sono adiacenti, non è possibile costruire la faccia del poligono.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×