Vai al contenuto

FlazBartowski

Members
  • Portfolio

    Portfolio
  • Numero messaggi

    13
  • Registrato

  • Ultima Visita

  1. FlazBartowski

    Maya Fluid e Trax Editor

    Ciao, innanzitutto ti ringrazio per le risposte e le dritte, tuttavia avrei bisogno di qualche delucidazione in più se possibile. Prima, però, penso sia necessario spiegarti un po' meglio la mia scena. In pratica ho un breve filmato fatto con una telecamera "di casa" a cui ho aggiunto delle simulazioni che dovrebbero essere "veloci". Più precisamente delle esplosioni e delle animazioni di fumo/polvere. L'idea e di avere un tempo di "combustione" delle mie esplosioni rapido e un secondo intervallo di tempo, più ampio, dove i miei fumi hanno il tempo di diffondersi e dissipare più lentamente. Ovviamente il filmato originale l'ho messo come reference applicando un image plane alla mia camera su cui precedentemente ho eseguito un tracking con Boujou. Ora, la mia esplosione deve essere veloce e la camera si muove pertanto per visualizzare un'anteprima coerente ho bisogno di velocizzare l'animazione. Se cambio il frame rate di acquisizione del playblast, questo non mi aiuta perchè mi ritroverei a vedere comunque l'inizio della mia combustione dopodichè la camera passerebbe a inquadrare qualcos'altro. Ripeto, la mia domanda nasce da un'esigenza di "preview" a bassa qualità, so bene che per raggiungere un risultato finale dovrò prendere la mia animazione com'è e arrangiare il timing in compositing, però avrei bisogno appunto di un sistema anche non molto accurato di previsualizzazione. Per quanto riguarda la tua osservazione sui substep, avrei bisogno se possibile di qualche chiarimento in più. Se non ho capito male i substeps definiscono il numero di volte che il mio solver "elabora" la mia animazione per frame. Una volta che ho la mia cache e disabilito la evaluation con l'apposito checkbox, come faccio a cambiare la "frequenza di calcolo" (substeps) manipolando la mia cache? Ti chiedo perchè probabilmente è proprio a causa di un errore del genere che la mia esplosione appare diversa dopo la manipolazione della cache! Grazie mille ancora per l'attenzione, apprezzo molto l'aiuto. Fabio. P.S. Immagino che vi stiate chiedendo da dove ho tirato fuori questo utilizzo strampalato del Trax Editor. A dire la verità, in un post su cgsociety dove un tizio aveva la mia stessa esigenza di un modo veloce di cambiare il timing delle animazioni per previsualizzare la propria simulazione. A dire la verità ero abbastanza soddisfatto perchè fino all'ultima sim, le altre apparivano uguali a quella fatta senza manipolazione della cache, solo coi tempi corretti. Tuttavia, probabilmente non è un gran sistema...
  2. FlazBartowski

    Maya Fluid e Trax Editor

    Appunto, ma se uso la funzione di playblast creo un'anteprima della mia scena così com'è, nel mio caso volevo avere un'anteprima con le velocità delle animazioni modificate.
  3. FlazBartowski

    Maya Fluid e Trax Editor

    Allora farò tutto in compositing, era per avere già un'idea generale su Maya. Grazie mille per le risposte. Fabio.
  4. FlazBartowski

    Maya Fluid e Trax Editor

    Salve a tutti, vi scrivo oggi perchè ho un problema con Maya e non riesco a venirne a capo. Ho creato una scena con numerose animazioni di fluidi. Per ognuna di queste ho creato una cache che è stata modificata attraverso il Trax Editor. Si tratta di esplosioni, quindi per rendere l'effetto più realistico ho diviso la mia "traccia" in più parti e ne ho scalato la lunghezza in modo tale da rendere alcune parti dell'animazione più veloci di altre. Ora, per tutte le animazioni (tranne una) non ho avuto problemi, il risultato si è dimostrato abbastanza buono e comunque ogni azione sulla traccia non ha modificato l'animazione originale. Tuttavia, con l'ultima sono arrivati i problemi: effettuando le stesse operazioni eseguite per le precedenti, il risultato dell'animazione cambia drasticamente: si creano artifacts, le proporzioni temperature/density/fuel sembrano andare a ramengo e in pratica appare tutto sbagliato. La cache ovviamente è stata creata su tutti i parametri (density,temperature,fuel...). Facendo qualche esperimento in più col trax editor ho scoperto che non è lo scale a creare problemi bensì l'operazione di split: se infatti prendo la mia traccia originale e la scalo soltanto nessun problema, se invece la prendo e la divido in due senza modificarla ulteriormente, ecco che la mia animazione cambia. Quello che non mi è chiaro è come sia possibile che con n-1 animazioni non abbia riscontrato alcun problema mentre questa mi stia facendo dannare. L'unica cosa che posso aggiungere a riguardo è che quest'ultima animazione fa uso ben più massiccio di fuel e temperature emessi rispetto alle altre, però non so quanto questo possa influire. Pertanto mi rivolgo a voi per capire innanzitutto se sono io che ho commesso qualche errore e se sia possibile risolverlo, oppure se ci sia qualche tecnica più flessibile e migliore per cambiare la velocità di un fluido mantenendo l'animazione uguale a quella attuale (non vorrei cambiare la Simulation Rate). Grazie mille a tutti e buon weekend. Fabio.
  5. Ciao a tutti, da qualche mese ormai mi sono addentrato nel mondo delle simulazioni di effetti, utilizzando solamente il motore di Maya, "Maya Fluids". Col tempo, però mi sono reso conto di quanto sia davvero incontrollabile per quanto riguarda alcuni tipi di animazioni. Mi spiego meglio: finchè si vogliono ricreare esplosioni standard (come quelle dei vari tutorial gnomon oppure esplosioni di tipo "nucleare") il motore si adatta egregiamente. La mia difficoltà nasce però dal tentativo di ricreare esplosioni un po' più complesse. Per fare un esempio, ma sul web se ne possono trovare davvero molti, mi chiedo come sia possibile, attraverso il Maya Fluids realizzare una simulazione del genere: Lasciando perdere la qualità del singolo esempio, mi chiedo come sia possibile ricreare una deflagrazione del genere, anche mettendosi lì e controllando ogni singolo paramentro in funzione del tempo all'interno di Maya. Inoltre, facendo alcune ricerche su internet, mi sono reso conto che il 90% dei video che si trovano su youtube riguardo a Maya Fluids mostrano esplosioni di tipo nucleare (come ho detto prima, si prestano davvero bene, o esplosioni simili a quelle viste nel tutorial della gnomon (gas oil, flame thrower ecc...). E non solo: anche cercando tra gli innumerevoli tutorial troviamo esercizi che ci permettono di creare effetti identici a quelli appena descritti. Quindi quello che volevo sapere da voi era se questa è una mia impressione o effettivamente il sistema di Maya ha dei limiti verso alcuni tipi di effetti, e soprattutto, ammesso che questi limiti esistano, se sia possibile abbatterli cominciando ad utilizzare altri software come Houdini e FumeFX. Grazie mille.
  6. Ciao a tutti, ho un problema con un'animazione di un gas (creata su Maya 2011), probabilmente è una cosa molto semplice, che io non conosco perchè è la prima volta che mi ritrovo a dover eseguire un'animazione in pochi frame. Vi spiego la situazione: fino ad oggi ho fatto un po' di animazioni utilizzando sempre un grande numero di frame. Adesso ho voluto fare il passo successivo, sovrapponendo un'animazione su un video. Il problema è molto semplice, prima di addentrarmi nell'animazione con sotto la sequenza di frame del mio video, l'ho creata su un intervallo di 100 frame. Il risultato è buono e il gas dissipa e si "comporta" correttamente. A questo punto ho voluto comprimere la mia animazione in 15 frame, aumentando (ingenuamente pensando che potesse bastare) la densità di frame della time slider (dalla finestra Preferences/Time Slider/Playback by) ottenendo così un totale di 100 frame dove prima ce n'erano 15. Il risultato è completamente sbagliato: l'emitter emette densità ma poi non avviene nessuna simulazione, rendendo il mio fumo un tratto nero. Purtroppo ho sempre lavorato (per imparare) con un intervallo di frame molto elevato e quindi mi manca quel passaggio che mi permette di comprimere un'animazione in pochi frame, probabilmente un'opzione che non conosco o un errore nella "pipeline" se così si può chiamare. Sperando nella vostra pazienza e disponibilità vi ringrazio per l'aiuto anticipatamente:)
  7. FlazBartowski

    Problema col rendering dei Fluid Effects

    Grazie mille per la vostra disponibilità
  8. FlazBartowski

    Problema col rendering dei Fluid Effects

    Ok ci stiamo avvicinando ad una soluzione: Su Maya 2010 va tutto normalmente, quindi il problema è relativo all'ultima versione di maya.
  9. FlazBartowski

    Problema col rendering dei Fluid Effects

    Ciao a tutti, innanzitutto grazie mille per le vostre risposte, davvero molto gentili. Dunque riepiloghiamo: nella viewport non mi renderizza correttamente (anche rispetto a quanto vedo nel video del tutorial dove anche nella viewport i fluidi si vedono in modo corretto), nella render view stesso discorso. Renderizzando invece l'intera animazione col batch render la simulazione è corretta. A questo punto anche io ho pensato ad un problema di scheda video, ma i driver sono aggiornati ed è una nvidia 8800 gt. Fino a questo momento, anche con altri fluidi, non ho mai avuto problemi. Edit: mi sono dimenticato già ieri di dirvi che dallo script editor non mi da alcun problema.
  10. FlazBartowski

    Problema col rendering dei Fluid Effects

    Aggiornamento: ho provato a fare un Batch Render e dall'anteprima sembra che da lì il risultato è quello che dovrebbe essere. Ma perchè confrontando lo stesso frame con il render che ho postato in uno ci sono le fiamme e nell'altro queste strane bolle? Purtroppo di rendering non ne so abbastanza per capire dove andare a toccare per visualizzare i singoli frame correttamente:(
  11. FlazBartowski

    Problema col rendering dei Fluid Effects

    Rieccomi, dunque come illuminazione in entrambe le scene vi è solo una spotlight e una point light. Settaggi di ambedue standard. Di cache assegnata ce n'era ma avevo già provato ad eliminarla, ma niente. Il problema è che avviando l'animazione sembra che emetta "pochi" e "grandi" particles che poi renderizza in quel modo.
  12. FlazBartowski

    Problema col rendering dei Fluid Effects

    Ciao! Uso Maya 2011, stessa versione utilizzata nel tutorial che trovi a questo link: http://www.thegnomonworkshop.com/store/product/898/ Per quanto riguarda i settaggi, non so quali postare perchè penso di poter escludere sia quelli dell'emitter che quelli del FluidShape perchè, come ho scritto prima, caricando la scena fornita col dvd, quindi con tutti i settaggi dell'istruttore, il problema persiste. Grazie mille per la risposta. Fabio.
  13. FlazBartowski

    Problema col rendering dei Fluid Effects

    Ciao a tutti, ho un problema abbastanza particolare. Sto seguendo uno degli ultimi videocorsi della Gnomon, quello riguardo a Maya Unlimited. In questo Tutorial si crea la simulazione del fuoco che esce da un lanciafiamme e la collisione con un box posto perpendicolarmente rispetto alla direzione dell'emitter. Ora, il mio problema è questo: fatto il primo rendering, anzichè farmi vedere il fuoco mi escono degli strani cubi gelatinosi. Subito ho pensato che fosse un problema di settaggi nell'emitter o nel FluidShape, ma dopo un po' di controlli ho provato ad aprire la scena ultimata allegata al dvd e facendo il rendering ritrovo lo stesso identico problema.Quindi presumo che sia un problema collegato a mental ray, di cui conosco solo alcune cose basilari, ecco perchè mi rivolgo a voi. Grazie mille. Fabio.
×