Vai al contenuto

kamuro

Members
  • Portfolio

    Portfolio
  • Numero messaggi

    91
  • Registrato

  • Ultima Visita

  1. kamuro

    Oggetto Che Si Illumina

    ciao a tutti! sto modellando un oggetto con Rhino e non riesco a far in modo che questo "produca" luce... ho provato a seguire vari tutorial, controllando i parametri di emissione, ma l'oggetto viene renderizzato tutto nero.. inoltre non so come fare per rendere buio il background (come se fosse notte o in un ambiente chiuso, per capirci) vi ringrazio in anticipo
  2. kamuro

    Mel Tutorial

    grazie mille per il codice commentato (adesso è molto + kiaro anke per me profano) e per i commenti che hai fatto al mio codice! sei stato davvero molto kiaro! per quanto riguarda la storia del dominio forse mi ero spiegato male all'inizio .. gli argomenti delle funzioni devono essere π*x/a (con x da 0 ad a) e π*y/b (con y da 0 a . quindi devo rappresentare seno e il coseno da 0 a π. Cmq la tua soluzione mi piace molto perké dà la possibilità di dettagliare maggiormente alcune zone, cosa che la mia non permetteva. grazie mille per tutti i chiarimenti e le spiegazioni francesco
  3. kamuro

    Mel Tutorial

    già ... avevo provato anke io a fare una cosa simile .. ma mi succede una cosa strana con questo codice (qui sotto): come puoi vedere height e width del piano sono fissate quando creo la Piastra. ma poi le 2 dimensioni (x,z) cambiano in funzione del parametro c, che invece nel codice incide solo per la y .. mi spiego meglio.. io ci metto c=5 e lui mi disegna il piano e me lo deforma. metto c=4 e mi disegna un piano che anche come width e height è + piccolo .. ma io nn gli dico da nessuna parte che -w e -h devono dipendere da c!!!! sapresti dirmi dov'è che sbaglio? (cmq ora provo il tuo codice .. anke se in certi punti intuisco solo a senso quello che hai scritto ) $pi = 3.1415927; $n=0; //coordinate float $y = 0.0; float $x = 0.0; float $z = 0.0; //parametri $k = 10; //punti-1 lungo X $l = 10; //punti-1 lungo Z $a = 20; //larghezza X $b = 20; //larghezza Z $c = 5; //amplificazione della deformata //definisci la Piastra polyPlane -ch on -o on -ax 0 -1 0 -w $a -h $b -sw $k -sh $l -cuv 2 -n "Piastra"; move ($a/2) 0 ($b/2) ("Piastra"); //sposta i Cv della Piastra for ($i=0; $i<$l+1; $i++) { for ($j=0; $j<$k+1; $j++) { $y = $c * sin($pi * $j / $k)*cos($pi * $i / $l); $x = $j; $z = $i; move $x $y $z Piastra.vtx[$n]; $n++; } }
  4. kamuro

    Mel Tutorial

    Ciao. innanzitutto grazie per i 5 tutorial sul MEL. volevo kiedervi, da perfetto ignorante in materia, se (e come) fosse possibile tramite MEL disegnare una superficie dando l'espressione matematica della stessa. nello specifico ho bisogno di disegnare la superficie z=sin(πx/a)*cos(πy/B) dove a e b sono parametri geometrici che conosco.. quindi semplici costanti note. il tutto limitato al dominio [0,a]x[0,b] spero ke qualcuno possa aiutarmi grazie mille
  5. Grazie ragazzi!!! Il problema era proprio quello (tutta la zona in alto a destra, fra le due linee rosse, aveva le normali invertite)! Ma sapete anke dirmi il perké quei poligoni avevano la normale in quel modo? ciao ciao e grazie mille!!!
  6. scusate l'ignoranza ... ma come si fa a controllare dove punta la normale?? e come si fa a rigirarla??
  7. guarda...ci sn stato 2-3 ore su a vedere se i vertici nn erano saldati e ho cancellato 1 ad 1 gli edge e nn ce n'erano doppi... solo quando provo a cancellare quelli mi dice che nn si può cancellare i border edges...
  8. kamuro

    "border Edges" Non Solo Al Bordo... ?

    Ciao a tutti! sto provando a modellare un volto umano e cominciano i problemi.. dopo aver aggiunto,estruso e spostato un po' di poligoni ho provato a fare smooth e ho notato ke in 2 punti della mesh non mi smootha lasciando lo spigolo vivo! dopo un'ora di ho capito ke non smootha in corrispondenza dei BORDER EDGES ... il problema è ke mi ritrovo dei border edges interni alla mesh!! Sicuramente ho pasticciato un po' mentre modellavo (nn avendo un criterio razionale), ma adesso come posso eliminare i border edges da lì in mezzo e lasciarli solo sui bordi effettivi della mesh? Il delete non funziona ... cosa mi consigliate? vi posto un immagine così è tutto + kiaro (in rosso sono evidenziati i border edges interni alla mesh) cmq voi cosa mi consigliate per far sì ke il problema non nasca d nuovo? in ke passaggio posso aver fatto finire lì in mezzo quegli edges?? considerate ke ho seguito il famosissimo tutorial di Giovanna d'Arco, quindi sono partito da un loop di poly attorno all'okkio, poi un loop attorno alle labbra e poi ho unito i 2 loop; per renderli parte della stessa geometria ho usato il comando Combine (ah...uso Maya 6.0), ho saldato i vertici e poi ho continuato ad estrudere gli edge esterni verso l'esterno e saldare i vertici quando necessario! Aspetto consigli!! Grazie a tutti
  9. purtroppo per il contest nn ho postato l'ultimissima versione ma quella prima del rimbalzo delle gocce (ke cmq è nettamente meglio rispetto alla prima, grazie ai consigli di c_dere). cmq grazie mille per i complimenti! sono piuttosto soddisfatto dato ke è il mio primo vt! beh, spero di vedere il tuo lavoro sul forum! ciao ciao
  10. beh..+ ke final questo è un vero e proprio WIP visto il numero di correzioni! ma ormai, credo siamo agli sgoccioli! ho seguito alla lettera i tuoi consigli e, come al solito, l'immagine mi sembra migliore!! Tu ke ne pensi(ormai è una cosa a 2)? per quanto riguarda la striscia + scura nella parte inferiore del vetro...chissà cos'era adesso sembra nn esserci +!!!! Grazie ancora per il tempo che mi hai dedicato e per tutti i consigli!!!!
  11. ke te ne pare?? l'effetto del rimbalzo si nota molto sul bordo superiore dell'auto (c'è quell'alone bianco)! a me piace parekkio! tu ke ne pensi? ho anke completamente modificato i riflessi (cercando info sullo IOR di cui ignoravo l'esistenza); adesso tutto ciò ke è perpendicolare alla camera è molto sfumato, vedi il paraurti. agli angoli, dove il telaio curva, invece, la riflessione è + netta! pensi vada meglio così?
  12. e avevi perfettamente ragione...anke a me nn piaceva per niente! l'ultimo tentativo, dopo la tua spiegazione, credo sia nettamente migliore!!! ke ne pensi adesso? ho provato a seguire il tuo consiglio utilizzando + di un livello! fammi sapere e grazie mille per i consigli! ah...dimenticavo.. ho anche cambiato i riflessi... sono solo leggermente + estesi rispetto a prima, forse leggermente + deformati ... mamma quanto è difficile creare un riflesso realistico...
  13. ho provato ad usare lo sfumino sul noise di fondo per variare la direzione delle gocce! che ne pensi c_dere?
  14. @ proposito della pioggia: hai consigli da darmi per rendere random (entro un range) la direzione dell'acqua? io per crearla ho riempito un layer con un noise monocromatico e poi ho usato il filtro "Effetto movimento". Il problema è che con quel filtro la direzione è unica! @ proposito dei riflessi: cosa andrebbe migliorato? cmq grazie per l'appunto!!!
×