Vai al contenuto

Giulio26

Members
  • Portfolio

    Portfolio
  • Numero messaggi

    15
  • Registrato

  • Ultima Visita

Info su Giulio26

  • Rango
    Matricola

Informazioni professionali

  • Impiego
    Impiegato (Employee)

Ospiti che hanno visualizzato il profilo

Il blocco recente degli ospiti è disabilitato e non viene visualizzato dagli altri utenti.

  1. Giulio26

    PROBLEMA: RENDER CRASH

    Penso che il problema fosse quello; gestivo il muro con multitexture + bercon tile e il pavimento con floor generator + multitexture. In entrambe le geometrie non avevo caricato molte texture, una 10 per il muro (ma come già scritto veramente leggere!) e un 5/6 tetxure per il pavimento... Quando sono andato ad eliminare una porzione del pavimento non inquadrata e le procedurali dal muro gestendo il displacement con un'unica texture (grande), il problema si è risolto. Ho finito di renderizzare ieri sera e la ram non è mai andata oltre il 60%. Grazie a tutti
  2. Giulio26

    PROBLEMA: RENDER CRASH

    Confrontandomi con altri professionisti mi è stato confermato il fatto che sia sufficiente nasconderli, senza la necessità di eliminarli.
  3. Giulio26

    PROBLEMA: RENDER CRASH

    thumb
    Buongiorno a tutti. Per dovere di cronaca comunico di aver risolto il problema, anche se non sono riuscito ad identificare con totale sicurezza la causa. Mi sono comportato come segue: ho disattivato tutti i displacement e fur ho ridotto subdivs sia di materiali che luci ai valori di default Risultato: la scena collassava ugualmente, questa volta dando però un errore diverso, sconosciuto sia a max che vray. Seguendo il consiglio di zatta 3d ho disattivato i bercon tile ed ho assegnato al muro un vray material standard; ugualmente crash. (wtf??) Sono entrato quindi a gamba tesa, ho ridimensionato la geometria della stanza riducendola al minimo indispensabile, ricontrollato tutte le texture utilizzando quelle più adatte in dimensioni e lavorandole in photoshop come peso in MB e formato. Ho eliminato il fur dal tappeto, cambiato la texture ed assegnato un normale bump (la posizione della camera non fa notare la differenza). Ho utilizzato una texture unica per il muro in mattoni assegnando un vray displacement e ridotto in dimensioni la texture della coperta (da 4 a 1K) assegnado anche in questo caso un vray displacement. Ho riportato i valori di luci e materiali a valori definitivi e tadaaa... Tutto ok. L'utilizzo di ram si è stabilizzato ad 11GB su 32GB circa, ovviamente la cpu è a tavoletta. Considerando anche altre applicazioni che lavorano in background il totale dei processi consuma circa il 60% di ram. Ragionandoci sopra, il mio problema penso fosse dovuto alla mappa bercon tile applicata al muro (come suggerito dalla community) e anche da una bella porzione di pavimento (floor generator) inutilizzata, non presente in camera, che vray cercava comunque di calcolare; forse era proprio in questo momento che si bloccava (updating instances) "crashando" poi inevitabilmente. Ringrazio per gli spunti di ragionamento. Ora so cosa regalarmi per Natale 🙂
  4. Giulio26

    PROBLEMA: RENDER CRASH

    Nelle mie giornate di studio mi sono imbattuto in un tutorial dove veniva spiegato come realizzare una parete in mattoni con vray displacement senza utilizzare un'unica grande texture ma diverse texture piccole, una per ogni mattone. Queste applicate ad una mappa multitexture, a sua volta applicata ad una mappa bercon tile, venivano sufficientemente randomizzate in modo da non far percepire la parete complessiva con delle ripetizioni. Il fatto di avere texture piccole e dal peso ridotto (meno di 100k ciascuna) mi ha fatto pensare di introdurre un elemento meno difficile da gestire in fase di rendering, rispetto ad una texture sufficientemente grande da coprire la parete intera, o una porzione considerevole.
  5. Giulio26

    PROBLEMA: RENDER CRASH

    Ok, grazie per i consigli. Questa sera mi adopero..
  6. Giulio26

    PROBLEMA: RENDER CRASH

    Proverò anche questa. Mi sembra però strano perché disattivandoli tutti e 3 (2 displace + 1 fur) si bloccava tutto comunque.
  7. Giulio26

    PROBLEMA: RENDER CRASH

    Soluzione o no, sicuramente è un tentativo che posso fare avendo risorse a disposizione. Sto chiedendo il vostro aiuto appunto per avere più possibile idee sulle quali ragionare. Essendo meno esperto di voi posso solo che imparare cose nuove..
  8. Giulio26

    PROBLEMA: RENDER CRASH

    Trovato: https://www.pcgamer.com/what-are-page-and-swap-files-and-how-big-should-they-be/
  9. Giulio26

    PROBLEMA: RENDER CRASH

    Quindi "zatta 3d" qualche consiglio pratico su come muovermi? Non so come swappare su disco.
  10. Giulio26

    PROBLEMA: RENDER CRASH

    Sto usando Vray 3.60.3 Si certo, è stato il primo step, ho disattivato i due vray disp e il vray fur; in tutta onestà il fur rallentava la scena più dei displacement; me ne sono accorto perché è arrivato al punto di crash più velocemente 😅 Il secondo step è stato nascondere tutte le geometrie non presenti in camera. Il terzo step a seconda della distanza dalla camera interagire con i turbosmooth e gli opensubdiv per ridurre il numero di poligoni e diaciamo che un 700000 li ho tolti. Quarto step sono andato, sempre basandomi sulla distanza dalla camera, a ridurre la risoluzione delle texture e verificare che quelle usate per reflection, glossines, bump, etc... fossero effettivamente in scala di grigio e non in rgb (magari per dimenticanza), in modo da far portar loro meno info. Non mi rimangono molti tentativi... Questa sera provo a non inserire il denoiser render channel come indipendente, oppure lasciarlo ma alzare il noise threshold ad un 0,01 anziché 0.005. Un'altro suggerimento trovato in rete è dove possibile il non utilizzare grandi texture ma piccole texture tileable e combinarle tra loro per coprire grandi superfici, in modo da far caricare a vray meno info. Inizierò anche a cambiare formato immagini, eviterò jpg per png in modo da non costringere vray a decomprimere le texture, però a discapito delle dimensioni della singola texture. Scusate ma sto scrivendo tutto quello che mi passa per la testa, magari diventa un buon input per qualcuno di voi...
  11. Giulio26

    PROBLEMA: RENDER CRASH

    No, non ancora, essendo la prima volta che affronto un problema simile non sapevo bene come comportarmi. Questa sera proverò... Grazie
  12. Giulio26

    PROBLEMA: RENDER CRASH

    Già fatto. Tendenzialmente lo imposto a metà della RAM totale; pensando inizialmente fosse un problema di memoria l'ho portato a 28GB, con use embree e conserve memory attivi. Penso che se fosse un problema legato alla memoria disponibile il messaggio di errore sarebbe diverso, più esplicito in quel senso. Sembra quasi che quando si blocca stia provando a caricare delle istanze (??) che però in scena non esistono, ho controllato la geometria più e più volte. Ho anche nascosto tutto quello che non è in camera per alleggerire ulteriormente.
  13. Giulio26

    PROBLEMA: RENDER CRASH

    thumb
    Ciao a tutti, un problemino mi sta facendo uscire matto e chiedo l'aiuto della community. Sono due giorni che provo a lanciare il rendering definitivo di una scena (3ds max + vray 3.6) e, dopo circa 5/10 minuti di caricamento, vray decide di bloccarsi ritornando il seguente messaggio di errore: UNHANDLED EXCEPTION: preparing instances last marker is at./src/vrayrender.cpp line 4130: preparing camera sampler Sono iniziate le mie ricerche e i miei tentativi per risolvere. Inizialmente ho pensato che utilizzasse tutta la ram disponibile, di conseguenza con task manager di windows ho iniziato a controllare i "consumi" durante il processo e sono intervenuto su geometria (turbosmooth, etc ridotti al minimo dove possibile), sulle texture (ridotte di risoluzione dove possibile, controllato i formati e il metodo colore per ogni mappa), ma niente. In scena ho 2 vray displacement per due geometrie (classico muro in mattoni e una coperta) + 1 vray fur per il tappeto. Leggendo forum (anche datati) ho notato che problemi come il mio lo riscontrano persone che utilizzano multiscatter o plugin come forest pack. Ho disattivato tutti e 3, provato, niente. Errore ancora presente. Allego 3 immagini come aiuto: Stato di avanzamento di vray nel momento in cui si blocca (updating instances) Il consumo generale in quel momento il messaggio di errore generato Ora qualche domanda stupida che mi è nata spontanea: Per la prima volta sto utilizzando il render channel denoiser come canale separato per la post-prod invece che integrato direttamente nell'RGB in abbinamento ad un noise threshold abbastanza potente (0,005). Potrebbero questi due elementi combinati sovraccaricare troppo il tutto? Per generare il muro in mattoni non ho utilizzato la classica super texture dalla quale creare poi le mappe necessarie e applicare il vray displacement ma ho creato tante piccole texture di mattoni (pesano meno di 100k l'una) e le ho combinate insieme utilizzando multitexture e bercon tile. Potrebbe essere questo? Chiedo scusa per la disperazione che trasuda da questo messaggio ma dato che il sonno l'ho già perso eviterei di perdere anche la ragione, chiedo quindi aiuto ai treddisti sensei presenti. PS: il mio hardware è composto come segue: CPU: i7 6850K RAM: 32GB DDR4 3000 MHz GPU: msi GTX 1070 X 8GB Grazie 🙂
  14. Giulio26

    3ds max - estensione monitor

    Ciao a tutti, chiedo il vostro aiuto per un problemino (stupido) ma che limita le mie possibilità lavorative. Lavoro con 3ds max (2014) e Vray (3.00.03) per creare e sviluppare i miei progetti. Utilizzo un MacBook Pro Retina Display datato metà 2013, al quale ho applicato la procedura di bootcamp e installato Windows 10 per far girare 3ds max. Lavoro con due monitor: - il monitor del MacBook: LCD con risoluzione 2880x1800 - monitor Samsung S24D300 con risoluzione 1920x1880 - sono collegati tra loro tramite cavetto hdmi L'idea è quella di utilizzare il monitor Samsung come principale e quello del portatile come accessorio per le palette, etc.. Il problema è che su quest'ultimo le varie palette di 3ds max, per esempio l'editor materiali, piuttosto che la finestra di render setup, vengono visualizzate minuscole rendendo la lettura impossibile. Ho controllato e ricontrollato e le risoluzioni di entrambi i monitor sono corrette. La scheda grafica è un'Invidia GeForce GT 650M; il driver è aggiornato e anche lei funziona correttamente... Qualcuno della community sarebbe così gentile da indicarmi un'eventuale impostazione in 3ds max o da qualsiasi altra parte per risolvere il problema o anche reperire le informazioni necessarie a risolverlo? La mia ricerca nel web momentaneamente non ha prodotto risultati sensibili... Nel frattempo ringrazio per la cortesia. Ciao
  15. Giulio26

    Presentazione

    Buongiorno a tutti, mi chiamo Giulio e sono un appassionato di grafica 2D / 3D e rendering fotografici. Spero di poter condividere con voi quello che so e poter imparare molto dalla community di treddi.
×